locked
Outbound Route Problem RRS feed

  • Question

  •  

    Hi All..

     

    Im stuck and I am tearing my hair out on this one.

     

    I have a OCS in Ent Consolidated.  Meadiation Server is delpolyed and pointed at an Asterisk Box that is setup and connected to a live SIP trunk.

     

    I have a few call normalization rules setup to add +61 in front of numbers to adhere to OCS's E.164 requirements, which normalize correctly.

     

    I have the phone usages and everything setup correctly, that i can guarantee.

     

    Now I think my problem lies with the Target Regular Expression on the Phone Route.  I have used the Ent Voice Route Helper to set a Expression of ^(\d*)$.  This should theoretically allow all calls to pass.  I have also tried .* which i found in another post on here which didnt work.

     

    When MOC tried to make a call it gets the 403 Forbidden error with the below debug

     

    A SIP request made by Communicator failed in an unexpected manner (status code 80ef0193). More information is contained in the following technical data:
     
     RequestUri:   sip:+61415331359@headquarters.livestockexchange.com.au;user=phone
    From:         sip:nathan.champ@headquarters.livestockexchange.com.au;tag=62dec2a6c9
    To:           sip:+61415331359@headquarters.livestockexchange.com.au;user=phone;tag=216CFFCFE62D06899AFDE4C2F573E82A
    Call-ID:      b07001b4d5994dc198ffff52cc0f1d39
    Content-type: application/sdp;call-type=audiovideo

    v=0
    o=- 0 0 IN IP4 192.168.1.82
    s=session
    c=IN IP4 192.168.1.82
    b=CT:99980
    t=0 0
    m=audio 10880 RTP/AVP 114 111 112 115 116 4 8 0 97 101
    k=base64:uj/mmtnC0j5GsYPhLdR/GDED0FXeKZpJOnqJzq8MomdXmtEegOa6pSvUhYd2
    a=candidate:CR1K4G9y+Fkz2RT3UW0hwmGkS8PrsRg+yPnJHhnYKNk 1 Ex5zCGWS5GNM+ASsU179qQ UDP 0.900 192.168.1.82 10880
    a=candidate:CR1K4G9y+Fkz2RT3UW0hwmGkS8PrsRg+yPnJHhnYKNk 2 Ex5zCGWS5GNM+ASsU179qQ UDP 0.900 192.168.1.82 51456
    a=candidate:GWtCURsojZQ0nbU2mpM86Zswndlr4Qn+gchZEWkd6EU 1 C9bm4asbf9Oiv4o1JiQ3Zw UDP 0.900 169.254.2.2 45184
    a=candidate:GWtCURsojZQ0nbU2mpM86Zswndlr4Qn+gchZEWkd6EU 2 C9bm4asbf9Oiv4o1JiQ3Zw UDP 0.900 169.254.2.2 33024
    a=cryptoscale:1 client AES_CM_128_HMAC_SHA1_80 inline:MNUTcP5xuCZtP00GloUnh2qlc20HD+8mY+x3E4Q5|2^31|1:1
    a=crypto:2 AES_CM_128_HMAC_SHA1_80 inlineTongue TiedmIzc7i5QPSyHzxeqA1P8Nhh0L4Ixa4Kuyie0fSw|2^31|1:1
    a=maxptime:200
    a=rtcp:51456
    a=rtpmap:114 x-msrta/16000
    a=fmtp:114 bitrate=29000
    a=rtpmap:111 SIREN/16000
    a=fmtp:111 bitrate=16000
    a=rtpmap:112 G7221/16000
    a=fmtp:112 bitrate=24000
    a=rtpmap:115 x-msrta/8000
    a=fmtp:115 bitrate=11800
    a=rtpmap:116 AAL2-G726-32/8000
    a=rtpmap:4 G723/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:97 RED/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=encryptionSurpriseptional


    Response Data:

    403  Forbidden
    ms-diagnostics:  12004;reason="No route found";source="LESVRAP01.headquarters.livestockexchange.com.au";appName="OutboundRouting"

     
     Resolution:
     If this error continues to occur, please contact your network administrator. The network administrator can use a tool like winerror.exe from the Windows Resource Kit or lcserror.exe from the Office Communications Server Resource Kit in order to interpret any error codes listed above.

     

    I am watching Asterisk in debug mode and its definately not being hit from the mediation server.  I have no errors on the mediation server so I am pretty sure this is just a problem with my Outbound Phone Route.

     

    I am setting up a very basic environment where I dont need users locked down by what they can/cant call.

     

    Can anyone assist with what might be the cause ??

    Thursday, October 16, 2008 11:41 PM

All replies

  • For what it's worth, I am also using .* as the default route, with the Mediation server as the gateway, and this is working for me.

     

    You could try posting your Mediation server config and I'll compare it to mine. Edit the server name and run this command to generate it:

     

    "C:\Program Files\Common Files\Microsoft Office Communications Server 2007\lcscmd" /config /action:export /level:machine /configfile:c:\mediationserver.xml /fqdn:mediationserver.domain.com

    Friday, October 17, 2008 7:15 PM
  • Hi,

     

    For sure .* is the catch-all route. If you have that in as your route, I can say 100% that it's not a problem with the regular expression.

     

     

     

    But a couple questions about the route:

    1.) What phone usage have you assigned to the route itself?

    2.) What mediation server have you specified in the route itself?

    3.) In your mediation server config, next-hop connections tab, what do you have specified as the PSTN gateway's IP address? It should be your Asterisk box and port 5060.

    4.) When you go into Enterprise Voice Helper - have you tried Ad-hoc tests? Go to the Ad-hoc tab, then select the "user" tab.

     a. under dialed number enter +61415331359

     b. under "user" enter nathan.champ@headquarters.livestockexchange.com.au

     c. under "location profile" pick the default location profile

     d. hit the "test" button.

     

    You should see your default route show up on the right side of the screen. If it doesn't show up, then you have something wrong with your policy, usage etc.

     

    If it does show up, then my guess is that your Mediation server isn't routing traffic properly. If your Mediation server has 2 NICs with 2 IP addresses on 2 different subnets, you need to make sure that you aren't using 2 default gateways - this will cause routing issues on the mediation server & probably result in the mediation server not able to pass traffic to asterisk. You should only have 1 default gateway on your "internal" IP address. To route to the asterisk server, add a persistent static route to the Mediation server via the command line.

     

    If you don't have the above scenario, go to the Mediation Server and open a command prompt. Telnet to asterisk on port 5060 and see if it connects. If not, then maybe Asterisk isn't listening on 5060, only 5061?

     

    Regards,

    Matt

     

     

     

    Wednesday, October 22, 2008 8:21 PM
  • We're having the exact same error message every once in a while with certain people.  The difference is that we haven't implemented the Mediation Server piece yet.  Any suggestions?
    Wednesday, March 18, 2009 11:55 PM