locked
Drives on sata controller not seen ? RRS feed

  • Question

  • Hi All,

    All of my bits & pieces arrived last Thursday and I've been having a ball building my WHS from scratch.

    Its all gone well so far except for one issue where WHS (not just in the console), dosn't see the 4 x 1TB drives that are attached to my sataII controller card (see link for details of this card).

    http://www.highpoint-tech.com/USA/rr2640x1.htm

    This card has its own bios screen during start-up and it shows all its connected drives but when windows has loaded, I only see the drives attached to my motherboard (ASUS P5QL-EM), I have the motherboard drives configured as "IDE"

    The sataII controller card has drivers for XP and 2003 and I've tried them both.

    I've updated the BIOS for both the motherboard and sata card.

    I'm thinking this card may not be suited to WHS ?

    Any ideas ?

    Regards from Australia

    Jack
    Sunday, April 26, 2009 4:20 AM

Answers

  • That's a fairly complex RAID HBA, Jack. I would honestly not recommend it for use with Windows Home Server: RAID is not supported, in the Windows Home Server environment it's pretty limiting, and it tends to make the recovery scenarios for Windows Home Server rather difficult.

    If you have to use that card, and want to let Windows Home Server manage your system reliability (recommended), I believe you will need to:
    • connect your disks to the RAID HBA
    • In the RAID BIOS, define one "array" per disk and treat each of them as a JBOD array. (Note: it's possible that you will be able to create a single JBOD array and have the individual drives exposed at the end of the process. The manual is unclear on this point.)
    • Start the Windows Home Server installation.
    • At the hardware detection screen, you will probably not see all of your disks. Provide the drivers for your RAID HBA at this time and make sure you can see everything. (See below for additional steps if your system disk is connected to this HBA.)
    • Continue through the wizard and complete Windows Home Server installation.
    I would recommend practicing a server recovery scenario, becuase you will need to provide drivers during that as well.

    If your system drive is connected to this HBA, you will need to supply drivers twice. The first time is as above, at the hardwar detection screen. The second time is just after the first reboot, at the Press F6 prompt that appears at the bottom of the screen. In this case, you must supply your drivers on a floppy, or other device that requires no drivers to work (so not usually a USB flash drive).

    I'm not on the WHS team, I just post a lot. :)
    Monday, April 27, 2009 3:13 PM
    Moderator

All replies

  • Hi,
    if Windows Home Server sees the controller in device manager, but not the drives, this is not a matter of WHS. Can the controller see the drives in it's Bios? Maybe you need to configure the controller in a first step, how the drives are to be used.
    Best greetings from Germany
    Olaf
    Sunday, April 26, 2009 9:58 AM
    Moderator
  • Hi Olaf,

    I can confirm that Windows does see the sata controller in device manager.

    I have "Initiated" the 4 drives in the controllers bios.

    Your probably right and I'm missing something but I can't see where ?

    This card (see link in 1st post) is probably over-kill for WHS

    Jack

    Monday, April 27, 2009 5:37 AM
  • Hi Jack,
    do you see the disks in disk management, if logged in locally to the server?
    In this case you can try, if the FAQ How to reinitialize a disk, which is not accepted for the storage pool would help.
    Best greetings from Germany
    Olaf

    Monday, April 27, 2009 7:33 AM
    Moderator
  • Hi Olaf,

    No the disks just dont show up at all within windows but when I use the cards raid management software I can.

    I've had some success by creating individual JBOD's.

    After doing that windows could then see the disks and I was able to add them to the storage pool.

    What do you think ?

    Jack
    Monday, April 27, 2009 11:30 AM
  • That's a fairly complex RAID HBA, Jack. I would honestly not recommend it for use with Windows Home Server: RAID is not supported, in the Windows Home Server environment it's pretty limiting, and it tends to make the recovery scenarios for Windows Home Server rather difficult.

    If you have to use that card, and want to let Windows Home Server manage your system reliability (recommended), I believe you will need to:
    • connect your disks to the RAID HBA
    • In the RAID BIOS, define one "array" per disk and treat each of them as a JBOD array. (Note: it's possible that you will be able to create a single JBOD array and have the individual drives exposed at the end of the process. The manual is unclear on this point.)
    • Start the Windows Home Server installation.
    • At the hardware detection screen, you will probably not see all of your disks. Provide the drivers for your RAID HBA at this time and make sure you can see everything. (See below for additional steps if your system disk is connected to this HBA.)
    • Continue through the wizard and complete Windows Home Server installation.
    I would recommend practicing a server recovery scenario, becuase you will need to provide drivers during that as well.

    If your system drive is connected to this HBA, you will need to supply drivers twice. The first time is as above, at the hardwar detection screen. The second time is just after the first reboot, at the Press F6 prompt that appears at the bottom of the screen. In this case, you must supply your drivers on a floppy, or other device that requires no drivers to work (so not usually a USB flash drive).

    I'm not on the WHS team, I just post a lot. :)
    Monday, April 27, 2009 3:13 PM
    Moderator