locked
Can't delete folder- Can't find the specified file. RRS feed

  • Question

  • In my total paranoid state after diving deep into the way DE works on WHS PP3 and now Vail, I decided to back up 3.8TB of data onto a Dynamic disk under the control of WHS 2003 server. The backup took @14 hours and "failed" because of one file. I was able to delete the file but its subdir (folder ..I'm showing my age) will not delete. The message is Can't find the specified file. I changed the name of the subdir but the deletion error message still refers to the original file name. (could this be a clue?) I ran chkdsk on the entire D: drive (upon reboot) without any problems ~16TB. I tried some other solutions but none have worked.    \\WHSERVER\Videos\Anime\Japanese\_SUB-TITLES\Hunter X Hunter\bad . bad is the offending folder. I have ensured I have all the permissions needed. If anyone has an idea please "share" it.

    Thank You,

    Jeff

    Sunday, May 9, 2010 1:52 PM

All replies

  • Could be there's a leftover "tombstone" (reparsepoint) in this folder which is no longer pointing to an actual file. To resolve such issue you can:

    1. Use the conflict resolver add-in

    2. Use the Windows Home Server Cleanup Utility which will effectively do the same job. A bit less fancy but it has worked flawlessly in my hands

    3. Resolve "manually";  Open command shell. cd to the folder containing the reparsepoints for the problematic files (like D:\shares\software), then run the following two lines of code, one after the other. They both do the same thing, one does it for all the files that contain no spaces, the second for everything else.

    For %i in (*.*) do fsutil reparsepoint delete %i

    For %i in (*.*) do fsutil reparsepoint delete "%i"

    Also please checkout FAQ: How do I resolve file conflicts.

    In any case, make sure all essenital files stored on your homeserver are backed up securely before you start.

    Monday, May 10, 2010 6:07 AM
    Moderator