locked
Installation problems RRS feed

  • Question

  • Hi All

    First I want to ask pardon because I don't place this question into the right topic. But I didn't find any topic about 2007. So Admins may replace my question.

    I'm trying to install a communications server 2007 standard on a windows server 2003 sp1.
    I will explane everything step by step so you can understand my question and situation. But first some background information about my situation:
    I test everything remotely and on that desktop I work in VMware. I've got two windows xp pro pc's and one windows server 2003 sp1 where the DNS and AD is allready installed. The two pc's can ping to the server and the server can ping them too. The desktops can login in the domain (the name is: testomgeving.local)

    So, I insert the cd communications server 2007 into the server. I go to 'my computer', click on D:\SE_VOLUME (this can be that it's not the right name, I've took a .iso from the cd). After that I click on setup.exe. Communications server 2007 is launching. I point the standard edition out en click on deploy standard edition.
    The installation of "prep Schema" went succesfull. There is a "completed" on the right of this.
    When I go to the next one ("Prep Forest") I get a fault. But I will tell you what I do: I click on run to install the prep Forest. Click next on the welcome window, I select System Container in the root domain, click next, Domain is : "testomgeving.local" (this is true, this is also the onlyone written in the windows. So I click next. Then I should select a SIP domain. As default the testomgeving.local is written. I can't select anything else because there is nothing to select except the 'testomgeving.local'. I don't really understand what I should enter here... I know that the SIP is for Voice over IP but how can I know which domain it should entered there? So I let this default and I click next. I get a summary and I click next. And I get a failed wizard.

    When I go to the log I can find this fault:
    [0xC3EC78CA] At least one builtin display specifier object could not be found.
    Please make sure all display specifier objects were created successfully
    during DcPromo process by checking log files (%Windir%\Debug\Dcpromohelp.log
    and %Windir%\Debug\Csv.log).

    I've already tried to find solutions on other websites and forum but I didn't find anything that helped...

    I hope some of you could find a solution.

    Greets,
    Anneke



    edit:

    I found I had to make some SRV-records:

    1. _sipinternaltls._tcp.<domain> - for internalTLS connections
    2. _sipinternal._tcp.<domain> - for internalTCP connections (performed only if TCP is allowed)
    3. _sip._tls.<domain> - for externalTLS connections
    4. _sip._tcp.<domain> - for externalTCP connections



    So I did, I also entered admin rights to it.



    Now, I've tried everything I could find on the internet:

    - csvde.exe (but closed immediately)

    - dcpromo.exe (http://support.microsoft.com/default.aspx?scid=kb;en-us;308592)

    - dchelp.exe

    - Dcdiag (but doesn't know that)

    - lcserror.exe (but closed immediately)

    - ABSConfig.exe

    - CertificateHelper.exe

    - SRVLookup.exe



    Extra information:

    It is a standard ocs, on a windows server 2003 sp2; I can ping two pc's in the domain: testomgeving.local; I can do the nslookup succesfully; Iraisde the level from 2000 (native) to 2003; users can logon on the domain succesfully;

    the prep schema went succesfully but I can't verify (commando is not supported)



    The logs:

    (csv.log)




    [code]

    Connecting to "(null)"
    Logging in as current user using SSPI
    Importing directory from file "C:\WINDOWS\system32\mui\dispspec\dcpromo.csv"
    Loading entries
    2: CN=401,CN=DisplaySpecifiers,CN=Configuration,DC=testomgeving,DC=local
    Attribute 0) cn: 401
    Attribute 1) showInAdvancedViewOnly: TRUE
    Attribute 2) instanceType: 4
    Attribute 3) distinguishedName: CN=401,CN=DisplaySpecifiers,CN=Configuration,DC=testomgeving,DC=local
    Attribute 4) objectCategory: CN=Container,CN=Schema,CN=Configuration,DC=testomgeving,DC=local
    Attribute 5) objectClass: container
    Attribute 6) name: 401

    Add error on line 2: Already Exists
    The server side error is "An attempt was made to add an object to the directory with a name that is already in use."
    0 entries modified successfully.
    An error has occurred in the program

    [/code]



    and (dcpromo.log)




    [code]
    dcpromohelp 7B0.140 0000 opening log file C:\WINDOWS\debug\dcpromohelp.log
    dcpromohelp 7B0.140 0001 C:\WINDOWS\system32\dcphelp.exe
    dcpromohelp 7B0.140 0002 file timestamp 03/25/2005 13:00:00.000
    dcpromohelp 7B0.140 0003 local time 11/19/2007 15:26:37.312
    dcpromohelp 7B0.140 0004 running Windows NT 5.2 build 3790 Service Pack 1 (BuildLab:3790.srv03_sp1_rtm.050324-1447) i386
    dcpromohelp 7B0.140 0005 logging flags 0001003C
    dcpromohelp 7B0.140 0006 Enter main
    dcpromohelp 7B0.140 0007 Enter DoIt
    dcpromohelp 7B0.140 0008 Enter IsDSRunning
    dcpromohelp 7B0.140 0009 Enter MyDsRoleGetPrimaryDomainInformation
    dcpromohelp 7B0.140 000A Enter MyDsRoleGetPrimaryDomainInformationHelper
    dcpromohelp 7B0.140 000B Calling DsRoleGetPrimaryDomainInformation
    dcpromohelp 7B0.140 000C lpServer : (null)
    dcpromohelp 7B0.140 000D InfoLevel : 0x1 (DsRolePrimaryDomainInfoBasic)
    dcpromohelp 7B0.140 000E HRESULT = 0x00000000
    dcpromohelp 7B0.140 000F MachineRole : 0x5
    dcpromohelp 7B0.140 0010 Flags : 0x1000001
    dcpromohelp 7B0.140 0011 DomainNameFlat : TESTOMGEVING
    dcpromohelp 7B0.140 0012 DomainNameDns : testomgeving.local
    dcpromohelp 7B0.140 0013 DomainForestName : testomgeving.local
    dcpromohelp 7B0.140 0014 DS is running
    dcpromohelp 7B0.140 0015 Enter TemplateGetObject LDAP://RootDse
    dcpromohelp 7B0.140 0016 DC=testomgeving,DC=local
    dcpromohelp 7B0.140 0017 Enter StartCsvde DC=testomgeving,DC=local
    dcpromohelp 7B0.140 0018 Calling CreateProcess
    dcpromohelp 7B0.140 0019 C:\WINDOWS\system32\csvde.exe
    dcpromohelp 7B0.140 001A -i -f C:\WINDOWS\system32\mui\dispspec\dcpromo.csv -c DOMAINPLACEHOLDER DC=testomgeving,DC=local -j C:\WINDOWS\debug
    dcpromohelp 7B0.140 001B Enter FS::GetPathSyntax C:\WINDOWS\system32\csvde.exe
    dcpromohelp 7B0.140 001C HRESULT = 0x00000000
    dcpromohelp 7B0.140 001D closing log
    [/code]

    Thursday, November 22, 2007 3:07 PM

All replies

  • It appears to me that you have a pre-existing configuration issue in your Active Directory deployment.  The key piece of information is the fact that the Display Specifier already exists according to your log.

     

    Start here: http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B308592

     

    You may need to manually import the missing object specifier.  Are you using any non-English language versions of any software?

    Thursday, November 22, 2007 4:42 PM
    Moderator
  • Hi Jeff

    Thanks for answering me so fast. I went already to the site but on the first link I see there, I get a "Location cannot be found", idem with the second one.
    Like I said before, I tried to open the dchelp.exe but it closes so fast, that I can't read what was written... I also tried to add the csvde-command in the commandline but it doesn't understand that.

    I think I use only English-languaged software.

    I also don't understand what you're saying. You say I've got the Display Specifier already in my software but then you speak about something that is missing. Which object is missing?

    Greets

    edit:

    My boss thinks that it has something to do with the raise domain level. I raised the level (domain and forest) to windows server 2003. But I see in that the OCS needs a windows server 2000 native level. I also noticed that I can't unraise this level. What am I supose to do?
    Thursday, November 22, 2007 5:56 PM
  • HI,

     

    2003 native mode works fine!

     

    Rgrds

    HenrikR

     

    Friday, November 23, 2007 11:58 AM
  •  

    Hi HenrikR

     

    Thank you for your reply.

     

    You don't think it has something to do with the raise level? I also read that the windows server 2000 native is good for windows 2000 AND 2003. That's why I was doubted that the answer can maybe be the unraise of this function level of my domain and forest.

     

    What do you think that's wrong? I searched to the display specifier and to delete it manually but I'm affraid I will delete the wrong records.

     

    Greetings

    Friday, November 23, 2007 1:26 PM
  • You can't 'unraise' or demote the forest or domain functional levels, but when it's said that Windows 200 Native mode is required, that means as the lowest possible compatible level, so any higher level is certainly supported.
    Saturday, November 24, 2007 2:21 PM
    Moderator
  • OK, so now we know that that is not the problem. But what can be the problem then? Something about my domain-settings?

    Edit:

    Look what I've found :

    "Active Directory object permissions appear to duplicate other permissions in Windows Server 2003 (http://support.microsoft.com/kb/884117)

    Can this be the problem? But they don't mention a solution... What am I supposed to do?

     

    Sunday, November 25, 2007 12:35 PM
  •  

    Check 2 things:

     

    1) Your domain level set to windows 2003 native

    2) Your forest level set to windows 2003 native.

     

    Both of this can be checked by using Active Directory domain and trusts from Administrativr tools

     

    3) Check your schema replication was successful, the procedure for same is mentioned, when you run the OCS Setup exe from CD. The step 2 says how to verify schema replication was successful.

     

    Also make sure you are running Forest prep with enterprise admin id.

     

    Cheers

    AP

    Wednesday, November 28, 2007 6:55 AM
  • Hi!

    Thank you for your reply.

    Like I said before, my  function level of both (forest and domain) is raised up to windows 2003. There is no option for a Native...

    I can't check my schema because the command I entered is not right (he can't understand the command) So I can't check my schema.

    Those enterprise admin id, is that a group where I can add my administrator to?

    Greetings
    Wednesday, November 28, 2007 9:38 AM
  • I know you originally stated that the Schema update reported as successful, but at this point I'd start back at the beginning and check each step out one-by-one.

     

    Is the account you are running the setup from a member of the Schema Admins group in the forest-root domain?  Without that membership you will not be able to make changes to the forest Schema.  Also, verify that the server holding the Schema Master role is granted rights to modify the schema: http://technet.microsoft.com/en-us/library/Bb727064.aspx

     

    I haven't personally seen what errors are produced if this prerequisite is not met, I assumed the wizard would say specifically what the problem is.

     

    Make sure you have ALL of the documented prerequisites met.

    Wednesday, November 28, 2007 12:20 PM
    Moderator
  • yes enterprise admin is a group for which administrator can be added as a member.

     

    2ndly, you need to run the LCSCMD.exe from the OCS CD/software dump by going to the setup\i386 folder.

     

    Following is the syntax of the command

     

    LcsCmd /Forest /action:CheckSchemaPrepState /PDCRequired:FALSE

     

    After the command is executed, go to the document and settings folder and then navigate to the user you are logged in > local settings > temp. Select the checkschemaprep.HTM file and snsure there is success.

     

    Regards

    Pankaj

     

    Wednesday, November 28, 2007 12:48 PM
  • Ok, I'll check that.

    The LCSCMD.exe doesn't open! It opens and closes so fast that I can't read what was written. So I can't enter the command. Even when I go to start - run - cmd , I dont get anything. The command is not right. So I can't check the schema. When I run again the prepschema, everything looks fine.
    Even when I go to the OCD CD/ i386/ lcscmd.exe... it closes immediatly.
    Wednesday, November 28, 2007 1:15 PM
  • That command is valid.  Make sure you first open the command prompt, then change to the directory where the lcscmd.exe is stored by default:

     

    C:\Program Files\Common Files\Microsoft Office Communications Server 2007

     

    Then execute the command as shown.  The results should look similar to this:

     

    C:\Program Files\Common Files\Microsoft Office Communications Server 2007>lcscmd /forest /action:checkSchemaPrepState /PDCRequired:False


    Microsoft Office Communications Server 2007 Deployment Command Console
    Copyright (c) Microsoft Corporation.  All rights reserved.

    Executing "Initialize Forest Object"
    Executing "Initialize Active Directory Connections"
    Executing "Check Schema Prep State"
    Check the log file "C:\DOCUME~1\administrator\LOCALS~1\Temp\checkSchemaPrepState[2007_11_28][09_16_52].html" for details.
    Action completed successfully

     

    Then locate and view the HTML outfile shown above to view the results.

    Wednesday, November 28, 2007 3:24 PM
    Moderator
  • How can I navigate in DOS? How can I go into the folder? I know how to go out a folder by using the ".." but I don't know to get in. Has it something with "cd D:\", to enter the D-disk (which is my CD-drive) 'cause I have to go to the CD I guess? Or do I have to navigate to the C:\ ... ?

     

    Wednesday, November 28, 2007 4:25 PM
  • No disrespect intended, but if the concepts above are still a bit foreign to you I can only imagine you'll continue to struggle with the deployment and configuration of this product, it

    can be a bit complicated.  Navigating the file system from the command prompt is a very basic concept, I'd suggest searching online for some tutorials on the subject.  Good Luck.

     

    Wednesday, November 28, 2007 8:09 PM
    Moderator
  • I"m sorry too, I'm just a student and don't get any help at work. The things I do, I learn at school just in January, so I can't do anything about it... But it's nothing, I'll figure it out myself...

     

    Wednesday, November 28, 2007 9:08 PM