locked
upgrades RRS feed

  • Question

  • I am running a e-machine windows Me. i cant upgrade to windows xp vista or7 or8 everytime i try they say you need a newer version of windows which i am trying to get. any suggestions?  
    Wednesday, September 1, 2010 12:21 PM

Answers