locked
Can't Access WHS Shares Through the Network RRS feed

  • Question

  • I'm not certain this is the best place for this question, but since I have PP1 installed, I'm hoping someone can answer this.

     

    I have several PCs on the network with WHS. One of them is my company's PC running XP Pro with a VPN. I've configured the VPN to allow access to the local network. I can see the other PCs and the WHS server, but when I try to access WHS shares, I get the message that I don't have access rights. I don't have this problem accessing the other PCs on the network, and I don't have this problem when I disable the VPN.

     

    Is there any way to make this work when the VPN is enabled?

     

    Thanks.

     

    Jerry

    Monday, June 30, 2008 9:49 PM

Answers

  • Typically, I would actually advise against pursuing the scenario you're trying to work through. There are too many factors that have to align (what VPN client? How is it configured? How is your corporate VPN server configured? Etc.) for it to be worth the effort in the first place. That NET USE works at all is a pleasant surprise; I suggested it because it had the greatest chance of success, not because I knew it would work perfectly.

    NET USE is probably unable to establish a persistent connection because you're establishing it with the VPN in one state, then switching states on the VPN a couple of times. A VPN establishes a connection to another network; establishing a new connection has a high probability of breaking other network connections while it's up. And if you establish a connection while the VPN is up, well your routing is very different at that point, so when you disconnect from the VPN your connection to your server fails again.

    All of which adds up to "be happy with what you've got." I guess. Smile

    Edit: Oh, yes, two other things: for a connection to your server your NET USE should look like this:

    NET USE Z: \\computername\sharename password /USER:username /PERSISTENT:YES

    Note that "username" is just the name of a WHS user, and you misspelled "PERSISTENT" in your command. And I probably wouldn't use Z:, which is used by the backup/restore engine when you do a "loose files" restore, but that's not a big deal.
    Friday, July 4, 2008 4:41 AM
    Moderator

All replies

  •  Jerry-Z wrote:
    Is there any way to make this work when the VPN is enabled?
    You could try mapping a drive (or connecting directly) and explicitly provide credentials.
    Tuesday, July 1, 2008 12:38 AM
    Moderator
  • Wouldn't let me map the drive. This is driving me nuts (pun intended).

     

    Jerry

     

    Thursday, July 3, 2008 9:55 PM
  •  Jerry-Z wrote:
    Wouldn't let me map the drive. This is driving me nuts (pun intended).

     

    Jerry

     

    Is the logon name to the client PC and the user account on WHS the same name?  If so, are they the same password?

    Thursday, July 3, 2008 10:29 PM
    Moderator
  • To map a network drive with explicit credentials, you can use the NET USE command at a command prompt (type NET USE /? and press Enter to learn all the available parameters), or you can:
    • Right click a share.
    • Select Map Network Drive... from the menu that appears.
    • Select a drive letter, and check "Reconnect at logon" if you want the drive to be automatically reconnected every time you log on to the machine.
    • Click on Connect using a different user name.
    • In the window that pops up, supply a user name and password that have access to the share on your server.
    • Click OK, then Finish.


    Thursday, July 3, 2008 11:53 PM
    Moderator
  • So here's where I'm at.

     

    Ken, I took your advice and used the "Net Use" command and it works fine. Thanks. However, even though I'm using the "persistant:yes" option, when I logoff/logon, the (re)connection doesn't work. I've been able to use Map Network Drive correctly as well, but even though "Reconnect at logon" is selected, it never reconnects either. I'm wondering if the problem is that the business PC is on a different domain, and somehow the domain is being appended to the login name?

     

    Here's the "net use" command I am using.

     

    net use z: \\home-server\sharename password /user:WORKGROUP\login-name /persistant:yes

     

    The domain for the PC is CORP.

     

    Any ideas of where I go from here?

     

    Thanks. And thank you too Kariya21.

     

    Jerry

     

     

     

    Friday, July 4, 2008 2:28 AM
  • Typically, I would actually advise against pursuing the scenario you're trying to work through. There are too many factors that have to align (what VPN client? How is it configured? How is your corporate VPN server configured? Etc.) for it to be worth the effort in the first place. That NET USE works at all is a pleasant surprise; I suggested it because it had the greatest chance of success, not because I knew it would work perfectly.

    NET USE is probably unable to establish a persistent connection because you're establishing it with the VPN in one state, then switching states on the VPN a couple of times. A VPN establishes a connection to another network; establishing a new connection has a high probability of breaking other network connections while it's up. And if you establish a connection while the VPN is up, well your routing is very different at that point, so when you disconnect from the VPN your connection to your server fails again.

    All of which adds up to "be happy with what you've got." I guess. Smile

    Edit: Oh, yes, two other things: for a connection to your server your NET USE should look like this:

    NET USE Z: \\computername\sharename password /USER:username /PERSISTENT:YES

    Note that "username" is just the name of a WHS user, and you misspelled "PERSISTENT" in your command. And I probably wouldn't use Z:, which is used by the backup/restore engine when you do a "loose files" restore, but that's not a big deal.
    Friday, July 4, 2008 4:41 AM
    Moderator
  • Thank you very much, Ken. Misspelled word was just my fumble fingers on the note, not the actual command string. No cut n paste with KVM.

     

    And I fully agree with "be happy with what you've got." It's just an extra step. It works, and I am happy.

     

    Now if I can only get the backup working like it used to work on the same PC. Getting the VSS error that several other have received. But that's another issue for another time and another thread.

     

    All done.

     

    Jerry

     

    Friday, July 4, 2008 12:22 PM
  • Jerry,

     

    At one time I was attempting the same configuration as you with a company laptop that connected to an internal domain via VPN.  I was also trying to use folder sync.  I established that the only way to get consistent access to my WHS while connecting and disconnecting from the VPN was to leave a shared folder view open (minimized) on the laptop.  I found that the issue was that if I connected to the WHS before I connected to the VPN, then established the VPN, the connection to WHS would be lost after about 20 minutes.  I found that leaving the window view open to the WHS prevented the session from closing and kept the connection to WHS alive.

     

    May be worth a try!

     

    Toby

     

    Friday, July 4, 2008 4:49 PM
  • Toby,

     

    I don't know what happened or what changed, but it used to work fine. I have a shortcut to the Shares on my desktop and it used to open all the time. Then it stopped working. I haven't been able to determine why.

     

    However, I just added a .bat to the VPN when it connects. The .bat has the USE NET command string. Seems to work.

     

    Thanks for the input. Most appreciated.

     

    Jerry

    Monday, July 7, 2008 3:32 PM