locked
OCS 2007 R2 Trial - Front-End Service Fail RRS feed

  • Question

  • OCS 2007 R2 Trial on Server 2003 R2 x64. Installed and ran fine. Then after a few days, the user groups stopped expanding. After trying various things (reset passwords and set passwords to not expire on the RTC accounts) I applied the update rollup from KB967831. That got all the services working. However, Communicator was still saying it couldn't retrieve the users from the groups. Reset all the passwords again on the RTC accounts and restarted. Now, the Front-end service fails.

    Worker process exited prematurely.  The process will be automatically restarted.
    Process: 'C:\Program Files\Microsoft Office Communications Server 2007 R2\Server\Core\RtcHost.exe'  Exit Code: E0434F4D (No Message Text Found).

    then

    A component could not be started.  The service has to stop.
    Component: Live Communications Applications Module  Error code: C3E83201 (SIPPROXY_E_SHUTDOWN_REQUESTED)

    Any suggestions? Thanks in advance.
    Friday, June 12, 2009 4:31 PM

All replies

  • Well, I re-applied the KB967831 update roll-up again - and it worked. Front-end service is running once again.

    Very curious to know what it is "repairing".

    So I'm back to the error on Communicator - "Server is temporarily busy. Please try again later".

    Friday, June 12, 2009 5:01 PM
  • Ok, I had been playing with the application pool "LSGroupExpAppPool" - and I hadn't re-started it. So that explained the "Server is temporarily busy" message.

    Now I'm really back to where I started.

    Communicator is reporting "Cannot perform this action, and the cause is unknown" when the user group is queried for expansion.

    On the OCS side, the event viewer is showing in the logs 2 errors for the OCS Address Book

    Address Book web service encountered an exception
    Microsoft.LiveServer.DLExpansion.AbWebServiceSettingException: Failed to read AbAttribute table from backend ---> System.NullReferenceException: Object reference not set to an instance of an object.

    and

    Failed to initialize Address Book web service setting
    Initialization will be retried in 5 minutes
    Resolution: Check previous event logs for more information

    The IIS log shows the attempts by Communicator to retrieve the Groups - and the HTTP 500 error

    2009-06-12 17:14:25 W3SVC1 172.16.xxx.xxx POST /GroupExpansion/Int/service.asmx - 443 DOMAIN\username 172.16.xxx.xxx Microsoft+Office+Communicator/3.0 500 0 0

    Friday, June 12, 2009 5:38 PM
  • Did you update the credentials on the IIS App Pool?
    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=66
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Friday, June 12, 2009 6:51 PM
    Moderator
  • Yes I did - that was the reason why I had the application pool stopped at one time.

    After the latest error, I did go in and re-type the password for the RTCComponentService account in the application pool - stop/start the application pool.

    Still the same error. I'm in the process of re-installing Communicator 2007 R2 and ensuring that it isn't an Outlook/Communicator issue.

    Although, I do still get the errors in the event log of the OCS server - see 2 replies above for specific error details.
    Friday, June 12, 2009 7:20 PM
  • Have Communicator running clean now - "no bangs" - Installed Office 2007 SP2 which cleared up the error in Communicator - "Outlook update is needed".

    Same error exists in Communicator - "Cannot perform this action, and the cause is unknown" - when trying to expand any defined groups.

    Same errors on OCS event viewer

    Address Book web service encountered an exception
    Microsoft.LiveServer.DLExpansion.AbWebServiceSettingException: Failed to read AbAttribute table from backend ---> System.NullReferenceException: Object reference not set to an instance of an object.

    then

    Failed to initialize Address Book web service setting
    Initialization will be retried in 5 minutes
    Resolution: Check previous event logs for more information

    Friday, June 12, 2009 8:53 PM
  • Wow.

    So the Trial OCS 2007 R2 was installed on a new, clean install of Server 2003 R2 x64 on 05/25/2009 - and the OCS event viewer is now reporting that the OCS 2007 Trial period has expired.

    Amazing. I've never been able to get it to work properly. The only remaining issue was that it couldn't properly expand the user groups.

    Thankfully, I don't have to make the final buying decision on this product. But if the powers that be do decide to proceed with this MS product, I certainly hope that the paid version is a better product than the trial version.
    Sunday, June 14, 2009 7:44 AM
  • Hi

          Please check this link:

    Updates available for expiration date issue with the evaluation editions of Office Communications Server (OCS) 2007 R2 and Office Communicator (OC) 2007 R2
    http://communicationsserverteam.com/archive/2009/06/10/523.aspx


    Thanks


    • Proposed as answer by Alex Lewis Monday, June 15, 2009 10:03 PM
    Sunday, June 14, 2009 6:55 PM
  • Hi - thank you very much for that link.

    After installation of hotfix, I did have to re-enter the password for all my services - then all services restarted with no errors.

    However, still having the error on Communicator - "Cannot perform this action, and the cause is unknown" - when expanding a group of users.

    And the same errors on the OCS event viewer

    Address Book web service encountered an exception
    Microsoft.LiveServer.DLExpansion.AbWebServiceSettingException: Failed to read AbAttribute table from backend ---> System.NullReferenceException: Object reference not set to an instance of an object.

    then

    Failed to initialize Address Book web service setting
    Initialization will be retried in 5 minutes
    Resolution: Check previous event logs for more information

    Has anyone ever seen these errors? or found a solution?
    Monday, June 15, 2009 3:55 PM
  • Hi - Yes, I did find that posting before - IIS_WPG is in the Local Security Policy for "Impersonate a client after authentication".

    I do still have the 2 errors in the IIS log - same errors as detailed in the blog post above.

    2009-06-15 15:22:07 W3SVC1 172.16.xxx.xxx POST /GroupExpansion/Int/service.asmx - 443 - 172.16.xxx.xxx Microsoft+Office+Communicator/3.0 401 2 2148074254
    2009-06-15 15:22:14 W3SVC1 172.16.xxx.xxx POST /GroupExpansion/Int/service.asmx - 443 domain\username 172.16.xxx.xxx Microsoft+Office+Communicator/3.0 500 0 0

    I have also tried manually pushing the Address Book sync with the following command

    "C:\Program Files\Microsoft Office Communications Server 2007 R2\Server\Core\abserver.exe" -syncnow
    Monday, June 15, 2009 8:09 PM