locked
WHS drops off the network during backup of clients RRS feed

  • Question

  • Please can someone help out here.  I have a 100% repeatable problem and it seems I am not the first:

    http://social.microsoft.com/forums/en-US/whssoftware/thread/94f15185-2173-4648-a4a7-f1bcf19a38a3/

    I have converted a Shuttle SN78SH7 which was working fine with Win XP SP3 into a home server (I am a partner and obtained home server from MAPS).  My config is as follows:

    Owner : Windows Home Server User
    Organisation : Family
    User : Administrator
    Operating System : Microsoft Windows Server 2003 Professional 5.02.3790 Service Pack 2
    Report Date : Thursday 31 December 2009 at 12:57

    System Summary
     Mainboard : Shuttle FN78S
     Chipset : nVidia GeForce 8200
     Processor : AMD Athlon 64 X2 4800+ @ 2500 MHz
     Physical Memory : 2048 MB (2 x 1024 DDR2-SDRAM )
     Video Card : Standard VGA Graphics Adapter
     Hard Disk : SAMSUNG (200 GB)
     Hard Disk : SAMSUNG (250 GB)
     Hard Disk : SAMSUNG (1000 GB)
     DVD-Rom Drive : LITE-ON DVDRW LH-20A1P
     Network Card :  MCP77 Ethernet
     Operating System : Microsoft Windows Server 2003 Professional 5.02.3790 Service Pack 2
     DirectX : Version 9.0c

    After the WHS has dropped off the network it is still possible to ping loopback and so the TCP stack seems to be still fine.  There are no errors in the event logs.  The only thing is I have no found a server driver for the network card and I am using the XP driver. I have done the obvious things such as wire everything into one switch and then I changed the switch to see if it was a switch problem.

    Network card driver info:

    Name [00000008] NVIDIA nForce Networking Controller 
    Adapter Type Ethernet 802.3 
    Product Type NVIDIA nForce Networking Controller 
    Installed Yes 
    PNP Device ID {1A3E09BE-1E45-494B-9174-D7385B45BBF5}\NVNET_DEV0760\4&19D259B6&1&00 
    Last Reset 31/12/2009 12:38 
    Index 8 
    Service Name NVENETFD 
    Driver c:\windows\system32\drivers\nvenetfd.sys (1.00.02.06776, 52.75 KB (54,016 bytes), 30/12/2009 12:07)

    I notice from the the thread above that others with the same chipset as my hardware have the same problem.  Anyone able to shed some light on what may be the cause of this problem?

    Thursday, December 31, 2009 1:43 PM

All replies

  • It's most likely to be a network driver or hardware issue. Check the results of ipconfig /all on the server while it's reachable from your network, and after it's dropped off, and also test connectivity using ping before and after.

    You can also simply try obtaining an inexpensive PCI NIC and disabling the motherboard NIC. I happen to hate Realtek NICs and like Intel...
    I'm not on the WHS team, I just post a lot. :)
    Thursday, December 31, 2009 11:30 PM
    Moderator
  • IPCONFIG /ALL before and after the server has dropped off the network is identical.  The TCP stack appears to be fine as you can ping loopback.  If I disable and renable the NIC then the problem still remains (but when the NIC is disabled you cannot ping loopback).  If you do not run backup then you do not get any issues.  I am going to see what happens if I try to transfer large amounts of data to and from the shares to see if it is an issue when the NIC is put under load.  However it is a very strange error that I can only put down to some bug somewhere. 

    Are there any articles on exactly how the backup feature of WHS works?  Is there are special agent or a TCP port or anything that is different from directly copying large amounts of data to and from the server?

    I am sure I could solve this by using a a reliable card like a D-Link DGE-528T but call it professional curiosity but I would like to know why this happens.  What's under the hood that is causing this to drop off the network?

    Happy new year!
    Steve

    -------------------------------------------------------
    Steve Lane MCP, MCDST, CCNA, CISSP, CompTIA A+, CompTIA Security+, MBCS
    PC PAL (Leicester South)
    http://www.pcpal.co.uk

    Friday, January 1, 2010 4:05 PM
  • Next step is to try ipconfig /release followed by ipconfig /renew on the server after it's dropped off the network (and assuming it's configured via DHCP, even if it has a DHCP reservation). But I think you'll be happier in the long run if you assume the built-in nVidia networking is just worthless (not that others have, as you mention above, tried and failed to get it working) and replace it with something that works. :)

    Regarding documentation, take a look at the various marketing pieces and technical briefs available through the Windows Home Server section of the Microsoft web site.
    I'm not on the WHS team, I just post a lot. :)
    Friday, January 1, 2010 6:09 PM
    Moderator
  • Thanks for the response and help Ken.  However this machine has a fixed IP address.  As a techie of some 15 years with a post grad qualification in computer science I was looking for something a little more in depth than just "ipconfig"!  I don't want to be dismissive but believe me I have done all the basics.

    Replacing the network card will for sure solve the problem but that is not the point.  Why should I have to shell out more money and use a slot in my computer?  There must be a reason for the failure and I want to know that reason.  It is not sufficient for me to just to replace the network card and not know the reason for the failure. I was looking for a way of debuging the error to find a fix even if I have to write some code.  This is clearly a bug with the WHS backup and the NV network driver.  I have run the server for a while now without running backup and there have been zero errors. I would like to know exactly how the backup process works , what agents are involved and so forth.  I am going to do some research on technet and MSDN.  But to save time does anybody have a document that details everything to do with the backup in WHS? Why in particular would the backup process cause the NIC to drop off the network (but appear normal)? Is there any source code available?  If I can find a fix, I am sure it will save others in the future.

    My hunch is that the network drivers might be badly written and there might be an issue with buffers. 

    Is there anyone from the Microsoft server team that can comment?

    -------------------------------------------------------
    Steve Lane MCP, MCDST, CCNA, CISSP, CompTIA A+, CompTIA Security+, MBCS
    PC PAL (Leicester South)
    http://www.pcpal.co.uk

    Sunday, January 3, 2010 11:06 AM
  • Steve Lane,

    Your not the only one that is having this problem. I am getting it  as well and I have fixed IP addresses as well. The problem seems to have just popped up within the last 2 days or so. Not sure what caused the problem. I restarted the WHS once, and then did a chkdsk  with a fresh restart. Seemed to solve the problem for about 24 hours, until the problem returned and am getting a little frustrated with it.

    I recently did a fresh reinstall(long story, well kinda short, ends with me being dumb) and installed all the service pack updates. So the WHS is very clean in many regards. All old data was copied back to the shares, installed a couple of my standard apps (WinRar, SmartFTP, etc.), freshly installed my Add-Ins(and reduced the total running by a great deal). And still I am confused on whats going on.

    -Alex Pummer
    -----------------
    Average dude that's been using the PC since DOS 3.0
    Sunday, January 3, 2010 12:01 PM
  • ...
    There must be a reason for the failure and I want to know that reason.
    ...

    While I have some small amount of sympathy, what my answer really comes down to is this: "The nVidia nForce network 'adapter' and drivers are garbage." I would say the same about a Realtek network adapter. If you have either on your motherboard, my honest advice is to adopt a practical approach and use something that is known to work instead.

    As for your experience, if you have experience in this area, please let us know what you've already tried up front, because for the most part the people who are using Windows Home Server don't have that experience, and therefore don't know to try the simple stuff first.

    As for fixing/patching it yourself, there is no source code available. I'm sure it's considered a trade secret (or perhaps it's patented; I'd go that way, to be honest). You could dig out your debuggers, disassemblers, etc. and reverse engineer the backup tools, but I don't think you'll find the issue that way. I honestly think it's the nVidia drivers, which means it's not going to get fixed. Microsoft won't fix nVidia's code, and those drivers are ancient so nVidia won't fix them.

    The available documentation from Microsoft that will be even remotely useful to you is reachable through the link I posted previously. You can also reach out to your partner contacts and see if you can get any internal assistance, but I would kind of doubt you'll get a lot.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, January 3, 2010 3:57 PM
    Moderator
  • Update to my post that I made....

    Oddly enough I uninstalled Microsoft OneCare and installed Avast! 4Pro and everything so far has been smooth sailing. It(OneCare) was doing odd stuff for a while, like turning off the Firewall, not registering as a Virus scanner in the security panel. Also never really realized how much of a performance hit it really was. Went with Avast because I needed something for the WHS as well. Turned out that in my case, my workstation was at fault and the WHS was perfectly fine. Even the Event Log showed very little if any problems on the WHS and a slew of odd errors and warnings on my Vista machine.

    -Alex Pummer
    Monday, January 4, 2010 4:36 AM