locked
Project Web App > Project Site Provisioning Settings > cannot change default web RRS feed

  • Question

  • Good Afternoon,

    I have Project Server 2010 installed on SharePoint 2010 and Windows Server 2008 R2. Database server (SQL Server 2005 SP3) is installed on another machine. EPM is working great for the past few weeks but I wanted to change the default web application from using the PWA web application to another dedicated web application for project sites. I created the new web application and created a site collection using the project site template. But when I attempt to change the web application in project site provisioning settings, I cannot change the default web application to the new web application, it only displays the original web application for PWA.

    Ideas?

     

     

    Wednesday, August 4, 2010 7:35 PM

Answers

  • That's a good question - and something I've looked at before but never got
    far with.  I just tried it in a virtual environment, and as far as I can
    tell, the option to provision to the second Web App appears after I provision
    a new PWA site in the second Web App.
     
    Conclusion....there's something about provisioning PWA that allows you to
    use it.  Not sure what, but that's the only thing that worked after I associated
    the Project Server Service App, and activated the Project Server features
    on the site collection.
     
    I suppose you can always just provision a throwaway PWA instance...?
     
     

    Andrew Lavinsky [MVP] Twitter: @alavinsky
    Tuesday, February 1, 2011 2:21 PM

All replies

  • Not to ask a stupid question, but can you confirm that you have unchecked
    the option to restrict project sites to the default site collection?
     
     
    - Andrew Lavinsky
     
    > installed on another machine. EPM is working great for the past few
    > weeks but I wanted to change the default web application from using
    > the PWA web application to another dedicated web application for
    > project sites. I created the new web application and created a site
    > collection using the project site template. But when I attempt to
    > change the web application in project site provisioning settings, I
    > cannot change the default web application to the new web application,
    > it only displays the original web application for PWA
    >
     
     
    Wednesday, August 4, 2010 8:04 PM
  • Hi Andrew, Yes the checkk box is unselected.
    Wednesday, August 4, 2010 8:11 PM
  • Hello EPM_Merlin,

    You have to register the new template using  STSADM or Blue Powershell. Ha!  I don't know why I called powershell as BLUE powershell.

    Anyway, there is a command that registers the template and then you will see it as a choice.

    Cheers!

    Michael Wharton, MBA, PMP, MCT


    Sincerely, Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA www.WhartonComputer.com
    Wednesday, August 4, 2010 8:34 PM
  • Hi Michael, but I'm not adding or modifying the template, just adding a different web application other than the original "default" one listed that is for PWA. I have done this dozens of times in the 2007 solution and always been able to click on the drop down and see all web available web applications.
    Wednesday, August 4, 2010 9:13 PM
  • Did anyone ever uncover a solution to this?  I am experiencing the same problem as described in the original post.
    Monday, January 31, 2011 3:20 PM
  • In order to move PWA from one web app to another you will have to unprovision the first instance and reprovision a new PWA instance against the existing databases


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Monday, January 31, 2011 7:08 PM
  • I'm not actually trying to move PWA.  I'm trying to host the project sites from a different web app.  So the PWA content database would be hosted from http://server:123/pwa and the project sites would be hosted from http://server:456/pwa

    I'm attempting to do this during an upgrade from 2003 to 2010.  I accomplished this exact configuration in 2007 (thread: WSS Relinking), but cannot get it in 2010 due to the limitation of only one web application being available in the Project Site Provisioning Settings page.

    Is this not possible anymore?  Can a non-PWA web application be selected as the default for project sites?

    Thanks.
    Jason

    Tuesday, February 1, 2011 12:55 PM
  • That's a good question - and something I've looked at before but never got
    far with.  I just tried it in a virtual environment, and as far as I can
    tell, the option to provision to the second Web App appears after I provision
    a new PWA site in the second Web App.
     
    Conclusion....there's something about provisioning PWA that allows you to
    use it.  Not sure what, but that's the only thing that worked after I associated
    the Project Server Service App, and activated the Project Server features
    on the site collection.
     
    I suppose you can always just provision a throwaway PWA instance...?
     
     

    Andrew Lavinsky [MVP] Twitter: @alavinsky
    Tuesday, February 1, 2011 2:21 PM
  • Hi EPM_Merlin I too have had experience in the past where I was able to see all web applications in choosing where to create a project site.  Aside from the provisioning of a dummy PWA have you found a better way to fix this? I imagine there must be some sort of hidden feature which needs to be activated (like what has to be done for taxonomy to work). Anyway if you have found an answer to this question other than PWA provisioning I'd like to know.

    Thanks,

    Thursday, October 11, 2012 5:31 PM