none
How to restore a computer using Windows7 DVD. RRS feed

  • General discussion

  • Because the Windows7 installer seems to have better driver support than the Computer Restore CD, I figured out which files were required and how to get the client restore wizard to run from the Windows7 installer.

    1. You must use a Windows7 32-bit disc or bootable thumb drive.
    2. Copy this list of files from the Computer Restore CD to a thumb drive:
      backupapi.dll
      clfs.sys
      clientrestorewizard.exe
      itss.dll
      partnermanager.dll
      restorecdinit.exe
      transportserviceproxy.dll
      vfpodbc.dll
      whsdriversetip.exe
    3. From Windows7 setup, choose Repair this computer. If it offers a windows installation, click in the space below to unhighlight it then click next. Open a command prompt and locate your folder created above.
    4. Register the .dll files and run restorecdinit.exe. I did it with this simple .cmd file:
      @echo off
      for %%a in (*.dll) do regsvr32 /s %%a
      restorecdinit.exe

    This still allowed for loading drivers just like the normal restore CD.
    This worked for me in testing, but I was curious if it would help anyone with some of the more 'difficult' hardware. (for instance realtek nics)

    -timotl

    • Changed type Ken WarrenModerator Sunday, December 20, 2009 11:20 PM This is a "how to" article
    Saturday, December 19, 2009 4:33 PM

All replies

  • Very helpful! I'll have to give that a try over the holidays.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, December 20, 2009 11:21 PM
    Moderator
  • Wow
    I have been trying on and off for a month to restore my Acer Aspire One (with a realtek nic)
    from a WHS backup.  Just to make sure I could.  I tried many drivers but none worked.
    Removing the hard drive from my Acer is very difficult and I am not willing to do that
    just to test a work a round.  My Acer was upgraded from XP to Win7 HP a few moths ago. 

    Thanks timotl!!

    I did not follow all of timotl’s instructions but it worked!

    1.  I copied the files per timotl from the Computer Restore CD to a USB thumb drive.
      backupapi.dll
      clfs.sys
      clientrestorewizard.exe
      itss.dll
      partnermanager.dll
      restorecdinit.exe
      transportserviceproxy.dll
      vfpodbc.dll
      whsdriversetip.exe
    2.  I hit F8 on my Acer during boot to access the Win7 hidden partition.
    3.  I followed the prompts to do a system repair.
    4.  I opened a cmd window.
    5.  I changed directories to the D:  (thumb drive)
    6.  I executed restorecdinit.exe.
    7.  I followed the normal WHS client restore menus.
    8.  I actually did a restore of the Acer C: drive from my last WHS backup.
    9.  Booted Acer and all is well.

    I could not get the following command to work but went ahead with restorecdinit.exe any way:
    @echo off
    for %%a in (*.dll) do regsvr32 /s %%a
    restorecdinit.exe

    My faith has been restored in my HP475 WHS.

    It is not a backup unless you know you can restore from it.

    Thanks again,
    Mr-Rich

    Saturday, January 30, 2010 8:59 AM
  • I don't know how you managed to work all this out but I wish Microsoft would learn a lesson from this! I've been quite happily backing up my partner's PC on a daily basis saying you never know when something might go wrong. I've just spent the last 2 days looking like a muppet as my words rang true and a Microsoft update rendered her computer unbootable. Try as I might I could not see the Windows Home Server using the restore CD even though I knew it still to be running from my other machines. I tried every trick in the book to return her computer to service but without any luck. I've read so many articles on so many websites and tried so many different ideas but without any luck.

    And then I stumbled across your post. Nothing to lose so I tried it.... the ITSS.DLL failed to register but other than that it is working flawlessly, I'm currently half way through restoring her computer. She'll be so happy when she returns from her night shift... well, maybe not too happy about the shift, but at least her computer will work.

    THANK YOU SO MUCH. :)

    Rob.
    Saturday, February 27, 2010 8:05 PM
  • Considering the restore disk was created even before Win 7 was out, it is to be expected. Here's looking forward to WHSv2 (ala Vail) to rectify this :)
    Tuesday, March 2, 2010 11:50 PM
  • Unfortunately this isn't working for me. I feel I've tried pretty much everything possible to get restore working but it just isn't happening. It's a real disappointment, as I really value WHS but this is a significant part of the software and it isn't working. God help those with no technical knoweldge who have a WHS and need to restore.

    I've got an Atheros L1 Gigabit Ethernet 10/100/1000 NIC on an Asus P5K (hardly a rare motherboard). Trying to restore Vista 32bit. I've used the restore folder from the WHS Backup, the latest Vista32 drivers from Asus and I've also tried the method listed here, using Win7 32bit boot from USB - none of these methods work for me.

    Using the method in this thread, I'm getting the following error:

    registering components failed with exit code 3 command: regsvr32 /s x:\windows\system32\itss.dll

    Nevertheless, I can still run restorecdinit.exe and homeserverwizard.exe and it still won't find my server. I have also tried after disconnecting my internet connection and renaming the local domain to Workgroup on my router - no dice.

    Any suggestions anyone has are more than welcome.

    Tuesday, April 20, 2010 4:09 PM
  • Just trying the WHS X:\Files restore disk (easy enough to Google it)

    Tuesday, April 20, 2010 8:13 PM
  • Looks like some of what I wrote is out of date or harder to follow than other solutions.
    I'm not sure if the x:\files cd was available then. I hadn't heard of it anyway.

    I've also heard that the driver pack that Tranquil put together is pretty good.
    http://www.wegotserved.com/2010/03/29/tranquil-pc-release-network-driver-pack-for-windows-home-server/

    -timotl

    Tuesday, April 20, 2010 8:23 PM
  • This is a rather old post, but it helped me to restore a drive with which I was having trouble.  I've used the restore with no issues in this past, but this PC has given me grief where I just couldn't get to the home server.  I found this post and tweaked your solution a little.  simply took the HDD out of the machine I wanted to restore, used my USB to ATA cable (that sucker comes in handy) and connected it to my perfectly fine Win7 PC.  I then registered the files you mention above and ran the restore wizard, presto everything worked great.


    Thanks for the tip.

    Friday, November 11, 2011 1:37 AM