locked
Import Solution Missing Dependency on SiteMap RRS feed

  • Question

  • Hello,

    We're importing a solution from one CRM 2013 on-premise environment to a new one. We keep getting solution import error "The following components are missing in your system and are not included in the solution."


    It says that the components are required in the SiteMap. I tried removing it from the SiteMap by modifying the customization.xml, re-zipped the solution but still getting this error again.

    Any idea on how to kill this dependency? Thanks much.


    • Edited by triangular Tuesday, January 20, 2015 1:15 AM
    Tuesday, January 20, 2015 1:13 AM

Answers

  • Hi,

    Looks like you have added this entty in the sitemap. On the screen where you customize the new entity there's a section on the General tab called 'Areas that display this entity'. Uncheck if you hav checked any--> publish the entity again--> Export the solution --> try reimporting.

    Thanks,

    Prasad

    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question

    • Marked as answer by triangular Tuesday, January 20, 2015 10:47 PM
    Tuesday, January 20, 2015 3:45 AM

All replies

  • Hi,

    Looks like you have added this entty in the sitemap. On the screen where you customize the new entity there's a section on the General tab called 'Areas that display this entity'. Uncheck if you hav checked any--> publish the entity again--> Export the solution --> try reimporting.

    Thanks,

    Prasad

    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question

    • Marked as answer by triangular Tuesday, January 20, 2015 10:47 PM
    Tuesday, January 20, 2015 3:45 AM
  • Thanks Prasad, we found the solution in the Default Solution, deleted it , re-exported the solution and the import was successful.
    Tuesday, January 20, 2015 10:47 PM