locked
Reports error RRS feed

  • Question

  • Hi,
    I have CRM 4.0 deployed.
    I am facing a strange problem. When i try to open a report i get the following error:
    The permissions granted to user 'servername\IUSR_servername' are insufficient for performing this operation. (rsAccessDenied)
    The solution i found was to uncheck the "Enable anonymous access" in the Disrectory Security of the CRM website. But then, the new problem is that CRM for Outlook lost connection.
    If i recheck it, the connection is restored but the reports don't open.
    What needs to be done?
    Thanks in advance
    Tuesday, May 5, 2009 7:03 AM

Answers

  • Hi,
    The solution was to uncheck the "Enable Anonymous Access" from the CRM website and enable it only on the _imgs folder.
    Regards
    • Marked as answer by ms_crm Wednesday, May 6, 2009 10:00 AM
    Wednesday, May 6, 2009 10:00 AM

All replies

  • does your security rights on user allows for report view/read?
    SSRS data connector installed?
    Rollup?
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Tuesday, May 5, 2009 7:12 AM
  • Hi,
    Thank you for your answer.
    My secirity rights allow me to view reports.
    I don't have SSRS connector(no need)
    Update Rollup 2 is installed.
    Any idea?
    Tuesday, May 5, 2009 7:17 AM
  • Try installing rollup 3!
    Try opening a report with that user on the http://servername/reports and see if he/she has right in SSRS!
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Tuesday, May 5, 2009 7:38 AM
  • Hi, I tried unchecking "Enable Anonymous Access" and opening http://servername/reports, it didn't open normally (as if the user doesn't have privileges). Then when i rechecked it and opened the site, it opened normally. When unchecked, I ran the diagnostics on my laptop and got the error: "The Web address (URL) specified for the installation (http://servername/CRM) is not responding. Diagnostic tests that require connectivity will not be run. Verify the specified Web service address and check for connectivity." How to fix this?
    Tuesday, May 5, 2009 7:59 AM
  • Hi,
    The solution was to uncheck the "Enable Anonymous Access" from the CRM website and enable it only on the _imgs folder.
    Regards
    • Marked as answer by ms_crm Wednesday, May 6, 2009 10:00 AM
    Wednesday, May 6, 2009 10:00 AM