locked
Debugging MPI app in VS2008 RRS feed

  • Question

  • Having some trouble MPISHIM. Everytime I run a debug on my MPI app, I get the following:

    MPISHIM: Unable to connect to devenv on machine '****'
    MPISHIM: Unable to connect to devenv on machine '****'
    MPISHIM: Unable to connect to devenv on machine '****'

    (i ran mpiexec with -n 3)


    I'm currently running Vista Home Premium. Msvsmon is running with the -noauth flag on. Any ideas? Having no luck researching it on the net. 
    Thursday, February 26, 2009 1:14 AM

Answers

  • Are you debugging on Windows HPC cluster? If so, can you try below steps?
    1. add VS2008 devenv.exe process to your firewall exception list.
    2. set your project's mpi network security mode (in debugging property sheet) to be "Accept connections from any address".
    3. disable unused network interface on all of your computer nodes.
    4. disable IPv6 on network interfaces of your development machine.
    5. make sure no one else is using VS2008 on your development machine at the same time.

    Hope it helps!
    Keshuang
    Thursday, March 26, 2009 5:08 AM
  • It is usually caused by the multi ip addresses of your machine, and mpishim only uses the first ip address entry to do communication instead of trying all of them. We have a bug tracking this for the VS2010.
    Thursday, March 26, 2009 12:44 PM

All replies

  • most likely you need to open the ports on the client machine for visual studio. add and exception for Visual Studio in your client machine firewall settings.

    .Erez
    Sunday, March 8, 2009 8:24 PM
  • Tried that already. I also tried adding port 135 directly. Still not working... Any other ideas?
    Monday, March 16, 2009 8:54 AM
  • Are you running the processes on your local machine (i.e., the same machine where Visual Studio is running)?
    Wednesday, March 25, 2009 10:35 PM
  • Are you debugging on Windows HPC cluster? If so, can you try below steps?
    1. add VS2008 devenv.exe process to your firewall exception list.
    2. set your project's mpi network security mode (in debugging property sheet) to be "Accept connections from any address".
    3. disable unused network interface on all of your computer nodes.
    4. disable IPv6 on network interfaces of your development machine.
    5. make sure no one else is using VS2008 on your development machine at the same time.

    Hope it helps!
    Keshuang
    Thursday, March 26, 2009 5:08 AM
  • It is usually caused by the multi ip addresses of your machine, and mpishim only uses the first ip address entry to do communication instead of trying all of them. We have a bug tracking this for the VS2010.
    Thursday, March 26, 2009 12:44 PM
  • Hi, all:

    I'm having the same problem on my office development PC. I followed all the steps here. But all failed. Does anyone have a solution? My PC configuration is:

    Windows XP Sp2, Microsoft Compute Cluster pack installed, I'm using MPI .net with visual studio 2005.

    I have a home PC with same configuration but vs 2008. I can launch the cluster debugger there. So this problem really puzzles me.

    Thanks in advance.


    Jianhua
    Thursday, July 23, 2009 2:25 PM
  • To Jianhua Jiang:

    Here is a way to diagnostic your vs2005. Try to launch remote debugger through "Tool->Attach" to attach a remote process on your targeted machine. If you succeed, that means the network configuration is ok. Else, you will get an error message telling you the issue.

    Another thing: In vs2008 sp1, you are able to select the property "Debugger Type" to be "Managed Only" for MPI .net. But in vs2005, no such feature. So I suppose debugger will failure to attach to the managed process.
    Saturday, August 1, 2009 7:35 AM
  • Hi all,

    I am having the same problem, running Winxp with dual core x86. I can attach processes in Visual studio but that is very tedious.

    Is there any hope this problem will be fixed with the upcoming visual studio version? I followed all advice above but the problem seems to be a different one.

    if anyone has a further suggestion please share! In case you need more information to reproduce this, please let me know!

    BenjaminI
    Monday, September 14, 2009 6:51 PM
  • Hi, BenjaminI
    Can you explain more on the symptom? We need below information:
    1. What is your version of Visual Studio?
    2. What is the error when you use the mpi debugger? (MPISHIM: Unable to connect to devenv on machine '****'?)
    3. Can you attach to a remote process (running on your computenode) from your dev machine?

    Thanks!
    Tuesday, September 15, 2009 12:36 AM