locked
Can I use .NET 3.0? RRS feed

  • Question

  • Will WHS ship with the .NET 3.0 runtime?

     

    I would like to use WCF in the app I plan to run on the server.

    Wednesday, April 25, 2007 9:01 PM

All replies

  • You may be able to install the .Net Framework 3.0 runtime, but I would expect it will ship with 2.0, the version it has now. If you need 3.0, you should probably try installing it and see if it causes any problems.
    Wednesday, April 25, 2007 9:23 PM
    Moderator
  • I did a Windows Update on WHS tonight and it installed .Net 3.0 automatically.
    Wednesday, April 25, 2007 10:34 PM
  • It is already installed (Windows Update did it automatically).

     

    However, if I cannot rely on it being installed "out of the box" I hesitate to use it.

     

    Thanks!

     

    Mark

    Wednesday, April 25, 2007 10:58 PM
  • I would expect that out of the box everyone will have automatic updates turned on, as such you can bet the farm that everyone will have .net 3.0.
    Thursday, April 26, 2007 12:01 AM