locked
Excel reports in Hosted EPM environment RRS feed

  • Question

  • EPM in the Cloud, that's a great strategy! Or from a hosting provider, fine!

    Unfortunately, the SQL Server that hosts the ProjectServer_Reporting-database is properly secured, and cannot be reached via the internet connection. So the ODC's to produce Excel reports cannot get access, neither can Exports from Web-based Excel Services reports to the Excel client on the workstation.

    For OLAP_cubes there is a solution ("msmdpump.dll"), is there some solution of that kind for Excel reports as well? Or is there being worked on?

    On behalf of my customers: THANKS!

    Wednesday, August 11, 2010 8:16 PM

Answers

  • I have worked on a similar request.

    In this case we cannot open SQL server port to the public network, so you have to use Excel services application to access the reports over the web.

    If you want in Excel, you can use 'Download a Snapshot' option in the BI report.

    So that you can save the data into excel sheet on the client machine for review.


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Thursday, August 12, 2010 7:55 PM

All replies

  • I have worked on a similar request.

    In this case we cannot open SQL server port to the public network, so you have to use Excel services application to access the reports over the web.

    If you want in Excel, you can use 'Download a Snapshot' option in the BI report.

    So that you can save the data into excel sheet on the client machine for review.


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Thursday, August 12, 2010 7:55 PM
  • I've had the same experience using Project Server 2010 in a hosted environment.  This is making the creation or use of Excel Services almost unusable for users.

    Is this a design flaw in Sharepoint's Excel Services architecture, or in the design of the Project Server 2010 ODCs, this dependency on an direct connection to the SQL Server? 

     

    Thursday, August 12, 2010 9:27 PM