locked
Creating Build Type in TFS RRS feed

  • Question

  • Hi,

     

    I am successfully able to create a team project in tfs.networkmashups.com. Also I am able to add solution to the source control.

     

    Now, I want to create a build type for a team project in Visual Studio 2005. I opened the "New Team Build Type Creation Wizard" from the menu "Build -> New Team Build Type".

    1. I entered the build type name.
    2. In "Select and order solutions to build" I choosed a solution from "All solutions under Team Project" workspace.
    3. In the "Select configurations to build" I selected "Debug" from the drop down list and Platform as "Any CPU".
    4. In the "Select build location" what is machine name that I should enter in the first box.?
    5. In the "Drop location" box what should be the name of the server and the share?

    Please guide me as to what I need to do in steps 4 and 5.

     

    Thank you

    Vikram

     

    Monday, April 9, 2007 12:52 PM

All replies

  • Hi Vikram,

     

    You can find this information if you go to the Project details page on the Sandbox Portal. After logging into Sandbox, Go to My Projects -> Click 'more info' link for the team project. You will see the Build information under the Build Server Configuration section.

     

    Please note that you would have to specify the full V-Root path.. (this is what you would provided while creating new virtual dir in Manage Resources)

     

    However, due to some security problems, the TFS bulids would not work as desired. So, I would suggest you to do a Visual Studio build of your project & move/upload your binaries, config files etc using the 'File Manager' utility in Manage Resources.

     

    Thanks,

    B.

     

     

    Wednesday, April 11, 2007 11:50 PM
  • Hi,

     

    I followed your suggestion and I created virtual directory and uploaded the binaries, config files etc using the file utility manager.

     

    After doing that I tried to browse the page. But I got this following error page:

     

    Server Error in '/Demo' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

     

    I modified the web.config to change the customErrors mode to On, Off and RemoteOnly. But nothing seems to work.

     

    What might be the problem here?

     

    Thank you

    Vikram

    Saturday, April 14, 2007 11:16 AM
  • Did you set the ASP.NET settings in Manage Resources??

     

     

    Wednesday, April 18, 2007 7:26 PM
  • Hi,

     

    I have done some settings in ASP .Net settings.

     

    Please let me know if any specific settings that need to be made.

     

    Thank you

    Vikram

    Thursday, April 19, 2007 4:33 AM
  • Hi Vikram,

     

    Are you able to host/view your service in Sandbox? Please let us know if you still have any issues..

     

    Thanks,

    Tuesday, March 18, 2008 11:38 PM