locked
OneCare Firewall and MS VirtualPC 2007 RRS feed

  • Question

  • Hi,

     

    I am sure this has been asked and answered, I just cannot find it.

     

    I am working on Microsoft Virtual PC 2007 (VPC) with my laptop and OneCare. The only way I can allow my VPC to connect to the Internet (either by connecting directly to the NIC or through NAT) is to disable the firewall).

     

    There must be something I am missing in the firewall configuration to achieve this in a safer manner.

     

    Anyone?

     

    Matt

    Thursday, February 21, 2008 12:33 PM

Answers

  • OK, It looks like this is not OneCare. I disabled the firewall and started a ping -t. Once the ping responded I started the firewall and the ping kept going.

     

    If I do find the root cause I'll post back.

     

    Sorry for the runaround and thanks for the help!

     

    M

    Sunday, February 24, 2008 5:19 PM

All replies

  • Hi, Matthew, I don't believe this has been asked before.

    I've been using VPC 2007 with all flavors of OneCare since 1.0 and have never had a problem with it. It should be recognized automatically by the firewall.

    Open OneCare, click on Change Settings and the advanced button on the firewall tab.

    In the list of Programs, I have Virtual PC 2007 shown as allowed and I didn't put it there, it was automatically recognized and allowed.

    If it doesn't appear in your list, add it. Click Add, then browser to the location of Virtual PC.exe (c:\Program Files\Microsoft Virtual PC\Virtual PC.exe in my case) and then select the option to allow it to connect to "any computer..."

    Do you have the firewall set to "notify me when..." only or is "Always ask..." also checked?

    Let me know what happens.

    -steve

     

    Thursday, February 21, 2008 12:59 PM
    Moderator
  • Oh, and another question - is this OneCare running *in* a VPC or is OneCare on the Host OS?

    My answer above is for OneCare running on the Host. If the Guest is running *in* a VPC and is running OneCare, technically that's an unsupported configuration, though I've got it running in 2 virtual machines (OS is XP) on two different physical hosts without a problem.

    -steve

     

    Thursday, February 21, 2008 1:02 PM
    Moderator
  • OneCare is running on the host, not the guest.

    VPC is set to allow. (6.0.156)

    Notify is checked, Always ask is unchecked.

     

    I should have also mentioned that my host is Vista Ultimate.

     

    M

     

     

    Thursday, February 21, 2008 1:27 PM
  • The machine in front of me right now is Vista Home Premium, its running OneCare, and there is a guest PC with unfettered access running in VPC 2007.

    Hmmmm.....

    What's the NIC on the PC? You said you've tried setting the NIC in the guest as the physical NIC. How many network adapters appear on the host in the Network and Sharing Center? Are any shown as unidentified? If so, disable them and see if the guest can get network access.

    -steve

     

    Thursday, February 21, 2008 1:49 PM
    Moderator
  • The NIC is wireless. Only 2 NIC (not counting the VPN and Vmware connections) one Wireless, one wired. None inidentified.

     

    M

     

    Thursday, February 21, 2008 2:27 PM
  • Is the VMWare connection running concurrently? And the VPN connections?

    In OneCare, change settings, configure network on the firewall tab. Do you have it set as "Home or Work?" Is it showing multiple networks?

    -steve

     

    Thursday, February 21, 2008 4:52 PM
    Moderator
  • Only the VPC is running, not Vmware. No active VPN connections.

     

    The wireless network is set to "Home or Work", though I notice the ICS is off, should it be ON for this to work?

     

    Thanks for chiming in!

     

    M

     

    Friday, February 22, 2008 12:43 PM
  • If you are using NAT in VPC, you would want to set ICS to on and allow it in the OneCare firewall, but it should work with selecting the wireless adapter in the VPC and simply allowing VPC (which *should* have been automatically recognized, as it has been on several machines I am using VPC and OneCare on...) in the firewall exceptions.

    I'll ping the Firewall PM for ideas.

    You might want to try OneCare Support.

    -steve

     

    Friday, February 22, 2008 3:10 PM
    Moderator
  • OK, It looks like this is not OneCare. I disabled the firewall and started a ping -t. Once the ping responded I started the firewall and the ping kept going.

     

    If I do find the root cause I'll post back.

     

    Sorry for the runaround and thanks for the help!

     

    M

    Sunday, February 24, 2008 5:19 PM
  • I look forward to reading your findings - no need to apologize.

    -steve

    Monday, February 25, 2008 1:27 AM
    Moderator