locked
Windows Home Server 2011 not displaying 'Server Folders' or 'Hard Drives'. Persistent "Refreshing the list of items" RRS feed

  • Question

  • My Windows Home Server 2011 is not displaying 'Server Folders' or 'Hard Drives' any longer. It did previously, but I may have messed something up. 

    I was in the process of adding shared folders.
    I clicked the 'Add a folder' task under the 'Server Folders' tab
    The process to add the folder never finished even after I left it overnight.
    So I clicked on the red X to close the Dashboard.
    It warned me: 'If you close the Dashboard, you will also close the windows that are listed. Any unsaved changes in those windows will be lost.'
    My window for adding the folder was listed.
    I clicked the 'Close Dashboard' button.
    When I started the dashboard again, I clicked on the 'Server Folders and Hard Drives' group.
    Both the 'Server Folders' and 'Hard Drives' tabs display: "Refreshing the list of items" 
    I let the system sit for several hours before closing the dashboard and restarting the machine.
    I tried this 2 more times each time letting the dashboard sit while displaying "Refreshing the list of items" for several hours before restarting the machine.
    I let the machine sit overnight while displaying "Refreshing the list of items" as well. Still no change.

    At this point, I'm afraid I messed something up by canceling the Add a Folder task, but not sure how to recover things at this point. Is there something I can do so that the Server Folders and Hard Drives will show again?
    Thursday, May 16, 2013 2:28 PM

Answers

  • Try running "chkdsk /r" on all your hard drives.

    I'm not on the WHS team, I just post a lot. :)

    • Marked as answer by Andy Qi Tuesday, May 28, 2013 9:43 AM
    Thursday, May 16, 2013 7:19 PM

All replies

  • Strange - do you have a server backup you could revert to?

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Thursday, May 16, 2013 2:33 PM
  • I do not have a backup. All my data is on drives separate from the server drives though. I am just trying to avoid reinstalling the OS for something that shouldn't be a problem to begin with.
    Thursday, May 16, 2013 2:45 PM
  • Try running "chkdsk /r" on all your hard drives.

    I'm not on the WHS team, I just post a lot. :)

    • Marked as answer by Andy Qi Tuesday, May 28, 2013 9:43 AM
    Thursday, May 16, 2013 7:19 PM
  • Did you ever resolve this.... I've got the same issue. I added new storage. Moved some of the shared folders without issue. The 3rd folder I tried to move 'hanged', so I cancelled the process..... Now all my folders and drives are missing from the WHS dashboard.

    The data is still there if I go to the server directly, but the folders are no longer visible in the dashboard or the homegroup - help!??

    Wednesday, August 14, 2013 10:16 AM
  • Did you ever resolve this.... I've got the same issue. I added new storage. Moved some of the shared folders without issue. The 3rd folder I tried to move 'hanged', so I cancelled the process..... Now all my folders and drives are missing from the WHS dashboard.

    The data is still there if I go to the server directly, but the folders are no longer visible in the dashboard or the homegroup - help!??


    **UPDATE** Looks like chkdsk had not run properly on the c:drive (boot drive). I forced a run during restart and now all the folders have come back.
    Wednesday, August 14, 2013 3:41 PM