none
Problems Accessing Home Server Console RRS feed

  • Question

  • I just got my server Tuesday and have been struggling with it the rest of the week.  I have a Linksys Wrt300n router and a laptop with Vista Home Prem. that I am using.  Connecting the server was a piece of cake.  Folders showup right away and I can access them.  BUT I can not access the server console unless I force my laptop a static IP address.  This then takes away my internet connection.  I have to switch back and forth and it is getting annoying. 

     

    Has anyone experienced this? Is it the router? Is it Vista?

    Friday, January 25, 2008 7:01 AM

Answers

  • Yeah, the hosts file is for DNS lookups, lmhosts is for NetBIOS lookups. NetBIOS is the older standard of name resolution, but it's still used inside LANs by Windows for a lot of things. WHS being one of them.

     

    I don't know enough about Vista to really troubleshoot name resolution issues at this depth. If lmhosts isn't prepopulating the NetBIOS name cache, it could be that there's still a file extension on lmhosts.

     

    One more thing to try, adding the address to HOSTS as well.

     

    1) Same as above, but this time add the following line to HOSTS (don't create a new file, just save your changes to the existing one):

     

    192.168.1.101 hpserver.san.rr.com

     

    2) Save changes, reboot.

    3) Ping again

     

    Monday, January 28, 2008 4:50 AM
    Moderator

All replies

  • What IP address, subnet mask, default gateway and DNS servers are your client and server being assigned?

     

    Friday, January 25, 2008 7:56 AM
    Moderator
  • Well, it's not Vista per se. You have installed the Connector software on your Client computer? The latest version of this might well be the version that's available in the Shared Folders\ Software\ Home Server Connector Software folder on your Client's desktop.

    If you have, give us some more info and I'm sure people can get it figured out.

     

     

     

    Colin

     

    Friday, January 25, 2008 5:40 PM
  • When I have it set to obtain IP automatically:

    Client IP: 192.168.1.102

    Server IP: 192.168.1.101

     

    The subnet mask : 255.255.255.0

    Defauly Gateway: 24.152.xxx.x

     

    DCHP server enabled.

     

     

    Sorry for the late respone.  For some reason, my threads do not show up on my account. 

     

    Any help is GREATLY appreciated.

    Monday, January 28, 2008 2:24 AM
  • Definitely something up with the configuration of your router (I assume that's where the DHCP is coming from).

     

    Your default gateway should be in the same LAN segment as your client (in your case 192.168.1.x). That 24.x address is probably the external IP address of your router. You sure that's the address being assigned by DHCP as your gateway?

     

    What's the inside address of your router? If you're going to statically assign addresses, you'll need to set the inside address of your router as the default gateway (and usually DNS server as well); that should give you internet access.

     

    Monday, January 28, 2008 2:29 AM
    Moderator
  • Oh boy....I am afraid I am in over my head here.

     

    I am positive that is the default gateway listed on my router.  I just rechecked.  How do I change that up?

     

    Here is what is on my router's status section:

    Connection Type Automatic Configuration - DHCP    
          Internet IP Address:  24.152.xxx.xxx    
        Subnet Mask:  255.255.254.0  
        Default Gateway:  24.152.166.1  
          DNS1:  207.69.188.185    
          DNS2:  207.69.188.186    
          DNS3:  207.69.188.187    
          MTU:  1500

     

    Monday, January 28, 2008 2:34 AM
  • No worries Smile The configuration of the internet side of your router isn't the issue. The problem is what the router is handing out to your clients via DHCP.

     

    Information to gather:

    1) Can you access the DHCP server configuration on your router? What is it set to provide to your clients?

    2) What do your clients get assigned by DHCP (IP, subnet, gateway, DNS)? You can see those numbers by going to Start --> Run --> CMD and typing "ipconfig /all" without the quotes

    3) What IP, subnet, gateway and DNS do you assign when you're giving your clients a static address?

    Monday, January 28, 2008 2:41 AM
    Moderator
  • Thanks Sam

    1) I can access the router home page.  all I can find is DHCP Server Enabled with a DHCP Reservations button.

    2)IP=192.168.1.102, subnet=255.255.255.0, gateway and dhcp server both=192.168.1.1

    3) When I assign, I assign the IP to be 192.168.1.50 and the subnet auto fills in.  Then for dns I do 207.69.188.187

    Monday, January 28, 2008 2:51 AM
  • Can you check the server as well?

     

    You can log into the desktop of WHS using Remote Desktop. Click Start --> Run --> MSTSC, type in your server's name and connect.

     

    Is the server set with a static or DHCP assigned address? What are its IP, DNS, gateway addresses?

     

    Monday, January 28, 2008 2:55 AM
    Moderator
  • This might be another can of worms. 

    When I do that, it will not accept the server name, only the address 192.168.1.1.  When I attempt to log into the computer, it says I must log on through the terminal services right blah blah blah

     

    Monday, January 28, 2008 3:02 AM
  • Ok, well your problem is that your Windows Home Server has the same IP address as your router. Stuff won't work in that configuration Smile

     

    Did you statically configure the IP address on WHS, or did it come like that?

     

    The only way to change the address is to use remote desktop to get in (are you using the WHS administrator account and server password?) or connect a monitor and keyboard to it.

     

    You'll want to change the server's address to something other than .1, or set it to use DHCP.

     

    Monday, January 28, 2008 3:06 AM
    Moderator
  • Well, it is a HP media smart that came with its own software.  I can't seem to remote login nor can I attach a monitor and keyboard.  I didn't set anything on it.  Nor is there a defined admin account on it.  Just a single password to access the control panel.

     

    So the router is 192.168.1.1 and the server is 19.168.101.  Do those count as the same?  Sorry for the ignorance in this matter.  This is all very very new to me.

     

    Monday, January 28, 2008 3:11 AM
  •  petegiella wrote:
    When I do that, it will not accept the server name, only the address 192.168.1.1.

     

    Ok, so you said there that you can only connect to the server with MSTSC using that address. Where are you seeing the .101 address?

     

    And the user account is "Administrator", you just don't enter it when you connect to the console.

    Monday, January 28, 2008 3:13 AM
    Moderator
  • I can connect to it, but can't log into it because of that stupid error.

     

    I see the .101 address on the router home page.  It lists everything connected.  2 Laptops, 1 printer, and the server.  Everything is .101-.104

     

    Monday, January 28, 2008 3:16 AM
  • I'm still confused about your internal addressing, then.

     

    1) When you use MSTSC, can you connect to 192.168.1.101? What do you get?

    2) When you use MSTSC, can you connect to 192.168.1.1? What do you get?

    3) When you use MSTSC, can you log into the server using Administrator as the username, and the WHS console password?

     

    Monday, January 28, 2008 3:21 AM
    Moderator
  • Sam, you are a genius.  And I am an idiot.  When it was asking me to login to the server, I was using my user account instead of administrator, as you said above in #3.  So now i am logged in to the server.

     

    1) I get the server login screen, which I now am remotly logged into.

    2) 192.168.1.1 is my router home page.

    3) Now i can.

     

    Monday, January 28, 2008 3:27 AM
  • Doing ipconfig/all on server shows me:

     

    DHCP Enabled.....yes

    Autoconfiguration Enabled....yes

    IP address 192.168.1.101

    subnet mask....255.255.255.0

    Default gateway...192.168.1.1

    DHCP Server.....192.168.1.1

    DNS.....207.69.188.187

    Monday, January 28, 2008 3:30 AM
  • Progress Smile

     

    So that's all fine, you shouldn't have any issues connecting to your server. What is your server's name, by the way? "SERVER"?

     

    More questions:

     

    1) Can your server browse the internet (remote desktop into WHS and open IE)?

    2) Can your client browse the internet when it's using a DHCP address (i.e. not static)?

    3) From your client (using a DHCP address), ping your server. Start --> Run --> CMD, type "ping servername" without the quotes, where servername is the name of your server. Do you get 4 successful responses back? What IP address does it resolve to?

    4) Ping the server again, but this time use its IP address. "ping 192.168.1.101". Do you get 4 successful responses?

     

    Monday, January 28, 2008 3:38 AM
    Moderator
  • It is just called HPSERVER

     

    1) Wow, this is kinda cool.  I can access the internet through the WHS.

    2) I can with the client as well with Obtain automatically.  If I set it to static, I CAN NOT acess the internet

    3) When I type "ping HPSERVER", without quotes, it says pinging hpserver.san.rr.com and I get 4 "request timed out"
    Monday, January 28, 2008 3:44 AM
  • Sorry...forgot this one.  If I ping using 192.168.1.101, I get 4 successful responses.

     

    Monday, January 28, 2008 3:47 AM
  • Ok, so the problem looks like name resolution.

     

    Your router appears to be assigning a primary DNS suffix to your internal machines. Can you verify that? On the client machine, start --> run --> cmd, ipconfig /all, and check the Primary DNS Suffix.

     

    Monday, January 28, 2008 3:50 AM
    Moderator
  • Yes, for Primary DNS Suffix, it says san.rr.com

     

    Also, when pinging "HPSERVER" the full line said pinging HPSERVER.san.rr.com [209.86.66.95]

     

    Not sure if that number is important.

     

    Monday, January 28, 2008 3:53 AM
  • Rather than mess around with your router settings, lets do a nice name resolution hack (from days of yore).

     

    On your client computer:

     

    C:\windows\system32\drivers\etc\lmhosts.sam

     

    1) Open that file with notepad.

    2) scroll down to the bottom

    3) add the following new line:

     

    192.168.1.101     hpserver         #PRE

     

    4) Save the file

    5) Rename it to lmhosts (without the .sam at the end, very important)

    6) Reboot your client computer

    7) Try pinging HPSERVER again

     

     

    Monday, January 28, 2008 3:59 AM
    Moderator
  • now this is just weird.  It says I do not have rights to save in that folder

     

     

    Monday, January 28, 2008 4:04 AM
  • Oh, you're using Vista. It's protecting you from yourself Smile Let me think about another way to do this.

     

    Monday, January 28, 2008 4:08 AM
    Moderator
  • HAHAHAHA

     

    Monday, January 28, 2008 4:10 AM
  • Here we go. It's credential elevation time: http://geekswithblogs.net/thibbard/archive/2006/12/13/ChangingYourHostsFileInVista.aspx

     

    Code Snippet

    Changing your hosts file in Vista

    By default, if you try to modify your hosts file in Vista, it will not let you save it.  It tells you that you don't have permission.  To successfully modify the hosts file, run notepad.exe as an administrator and open the file.

    1)  Browse to Start -> All Programs -> Accessories
    2)  Right click "Notepad" and select "Run as administrator"
    3)  Click "Continue" on the UAC prompt
    4)  Click File -> Open
    5)  Browse to "C:\Windows\System32\Drivers\etc"
    6)  Change the file filter drop down box from "Text Documents (*.txt)" to "All Files (*.*)"
    7)  Select "hosts" and click "Open"
    8)  Make the needed changes and close Notepad.  Save when prompted.

     Check out Where's Tim, real-time GPS on Google Maps!

     

     

    Except replace HOSTS with LMHOSTS.SAM.

    Monday, January 28, 2008 4:13 AM
    Moderator
  • Whoopsies.  I accidentally changed the original file. But changed it back. I hope that is OK.  I also saved the new lmhosts filewith changes as a text file.  Is that correct?  restart now?

     

    Monday, January 28, 2008 4:23 AM
  • No problem with creating a new file.

     

    The new lmhosts file cannot have a file extension, though. That's important. You might have to turn on viewing file extensions in Folder Options (or whatever Vista's nasty, hidden equivalent is) to see the .txt extension.

     

    Very important that its lmosts, not lmhosts.sam or lmhosts.txt, the file type should say "File" or something similar (not "Text Document" or whatever).

    Monday, January 28, 2008 4:27 AM
    Moderator
  • Got it.  Thanks for putting up with me Sam.

     

    Restarting now.

     

    Monday, January 28, 2008 4:28 AM
  • No problem at all.

     

    Monday, January 28, 2008 4:30 AM
    Moderator
  • OK.  All restarted. 

     

    Monday, January 28, 2008 4:35 AM
  • Can you ping HPSERVER from your client now?

     

    Monday, January 28, 2008 4:36 AM
    Moderator
  • Nope.  Still wants to ping hpserver.san.rr.com

     

    Monday, January 28, 2008 4:37 AM
  • Start --> Run --> CMD, type "nbtstat -c" (hopefully that exists on Vista). Anything in the cache?

     

    Monday, January 28, 2008 4:39 AM
    Moderator
  •  

    no names in cache for bluetooth connections

    no names in cache for local area network

    then some table for wireless area connection.

     

     

     

    You know, during one of many hours on the phone with hp tech support on this issue, they wanted me to change the hosts file in that same directory as the lmhosts file.

    Monday, January 28, 2008 4:43 AM
  • Yeah, the hosts file is for DNS lookups, lmhosts is for NetBIOS lookups. NetBIOS is the older standard of name resolution, but it's still used inside LANs by Windows for a lot of things. WHS being one of them.

     

    I don't know enough about Vista to really troubleshoot name resolution issues at this depth. If lmhosts isn't prepopulating the NetBIOS name cache, it could be that there's still a file extension on lmhosts.

     

    One more thing to try, adding the address to HOSTS as well.

     

    1) Same as above, but this time add the following line to HOSTS (don't create a new file, just save your changes to the existing one):

     

    192.168.1.101 hpserver.san.rr.com

     

    2) Save changes, reboot.

    3) Ping again

     

    Monday, January 28, 2008 4:50 AM
    Moderator
  • SAM,

    If you are ever in San Diego, I owe you a beer.  Two beers.  The host file change worked.  It pinged suucessfully, and I can access the console now. 

     

     

    Thanks soooooo much.

     

    Monday, January 28, 2008 4:59 AM
  • What happens if you ping hpserver

    that should work, or the name you gave your server.

     

    I

     

    Monday, January 28, 2008 5:00 AM
  •  Darkone3 wrote:

    What happens if you ping hpserver

    that should work, or the name you gave your server.

     

    "Should" being the operative word here Smile

    Monday, January 28, 2008 5:01 AM
    Moderator
  • gives me 4 successful replies!!!

     

    Monday, January 28, 2008 5:03 AM
  •  petegiella wrote:

    SAM,

    If you are ever in San Diego, I owe you a beer.  Two beers.  The host file change worked.  It pinged suucessfully, and I can access the console now. 

     

     

    Thanks soooooo much.

     

     

    No problem. HOSTS is sort of a hacky workaround, you shouldn't really have to do it.

     

    The issue here is that your router is set to pass through DNS settings from your ISP, which really isn't the greatest way to set things up. Normally, your router shouldn't be assigning you a DNS suffix; if one is present, Windows helpfully assigns that to the end of any network names you try to access - in your case, that's breaking things.

     

    So you can either leave the HOSTS file in place (its not gonna hurt anything) or contact your ISP and work out with them how to set up your router to handle DNS queries for your clients.

    Monday, January 28, 2008 5:04 AM
    Moderator
  •  petegiella wrote:

    Oh boy....I am afraid I am in over my head here.

     

    I am positive that is the default gateway listed on my router.  I just rechecked.  How do I change that up?

     

    Here is what is on my router's status section:

    Connection Type Automatic Configuration - DHCP    
          Internet IP Address:  24.152.166.241    
        Subnet Mask:  255.255.254.0  
        Default Gateway:  24.152.166.1  
          DNS1:  207.69.188.185    
          DNS2:  207.69.188.186    
          DNS3:  207.69.188.187    
          MTU:  1500 1500

     

     

    Sorry I just join this party, and you are not hearing each other. You post a page from your Linksys router and this is correct. Sam however wants to know the values that the WRT300N is passing to your Vista and this would be found by doing } Start (menu} | All Programs | Accessories | Command Prompt | and typing in config /all [Enter}

     

     

    Monday, January 28, 2008 5:07 AM
  • Dark, it's working now Smile

     

    Monday, January 28, 2008 5:10 AM
    Moderator
  •  Sam Wood wrote:
    Dark, it's working now Smile

     

    So I see congratulations!

     

    Now if I could just figure out how to get ieSpell to work here,  

    Monday, January 28, 2008 5:18 AM