locked
System tray icon is gone since PP1 installation RRS feed

  • Question

  • Since installation of PP1 my WHS icon in the system tray is gone. My server and connection software works well but I cannot get my tray icon back. After reinstalling WHSConnector it is back but after a reboot it is gone again. Which program do I have to run in the startup folder?

    Saturday, August 23, 2008 7:15 PM

Answers

  • Hi,
    Since the original post, I've been doing some reading, and I found this. It could be worthwhile having a check and see if it applies to your situation.

    Colin
    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by tt - n Monday, September 8, 2008 7:35 PM
    Sunday, September 7, 2008 7:49 PM
    Moderator
  • Great tip, Colin. Solved the problem thanks to the Ostuni workaround:

    "Francesco Ostuni further mentioned that the same can be done through Control Panel, Add or Remove Programs, on the left side: Add/Remove Windows components; select Networking Services, click on the Details... button, remove the checkmark for the UPnP User Interface, then click on OK."

    All my icons are back. No other problems encountered (so far).

    Many thx
    Monday, September 8, 2008 7:34 PM

All replies

  • Hi,

    If your server is using DHCP, it could be that your Client(s) have just lost your server. To check, on the Client, navigate to the C:/Program Files/Windows Home Server, and run the program - 'Discovery.exe'. This will search your network and re-set the connections.

    If that doesn't fix it, have a look through the logs to see if there is anything obvious, and post back for more help.

     

    Colin

     

    Saturday, August 23, 2008 7:30 PM
    Moderator
  • Thanks for reply. My connections are OK, server works ok as well. I ran "discovery.exe" without problems but still no system tray icon. I checked my logs but no errors or strange things in there. Any other suggestion?

     

    TT

     

     

     

    Saturday, August 23, 2008 7:51 PM
  • TT,

    In your Startup folder, there should be a shortcut to the Windows Home Server Connector, is that still there?  If so, call up Task Manager, and check that the WHSTrayapp.exe shows in Processes. If it does, use task manager to kill it, then try running the shortcut in the Startup folder again.

     

    Colin

     

    Saturday, August 23, 2008 8:14 PM
    Moderator
  • Thx, Collin. Your suggestion works. My shortcut in the Startup folder creates the icon. But after a PC reboot the icon is still gone. I have no other programs in my startup folder. Do I need to delete an autostart program somewhere else?

     

    TT

    Saturday, August 23, 2008 8:58 PM
  • You can try deleting and recreating the shortcut in startup. It shouldn't make a difference, but...
    Sunday, August 24, 2008 3:03 AM
    Moderator
  •  tt - n wrote:

    Thx, Collin. Your suggestion works. My shortcut in the Startup folder creates the icon. But after a PC reboot the icon is still gone. I have no other programs in my startup folder. Do I need to delete an autostart program somewhere else?

     

    TT,

    Just wondering: do you have "Hide inactive icons" set for the Notification Area (Windows taskbar properties)

    Is the console icon set for "Show"?

    Theo.

    Sunday, August 24, 2008 3:25 PM
    Moderator
  •  Theo van Elsberg wrote:
     tt - n wrote:

    Thx, Collin. Your suggestion works. My shortcut in the Startup folder creates the icon. But after a PC reboot the icon is still gone. I have no other programs in my startup folder. Do I need to delete an autostart program somewhere else?

     

    TT,

    Just wondering: do you have "Hide inactive icons" set for the Notification Area (Windows taskbar properties)

    Is the console icon set for "Show"?

    Theo.


    Same situation here too.
    Same temporary fix works.
    I do have hide inactive icons checked but the WHS Tray Icon is not on the list to hide at all after a reboot.

    Where do you set the icon to 'show'?
    Monday, August 25, 2008 7:48 AM
  •  

    Hi,

     If you 'right-click' in the area of the Icons on the RH side of the Taskbar, you will get a pop-up menu which will give you the customisation options. Selecting this will give you the choices of inactive, show or hide.

     

    Colin

    Monday, August 25, 2008 8:48 AM
    Moderator
  •  Colin Hodgson wrote:

     

    Hi,

     If you 'right-click' in the area of the Icons on the RH side of the Taskbar, you will get a pop-up menu which will give you the customisation options. Selecting this will give you the choices of inactive, show or hide.

     

    Colin



    Thanks Colin, I knew that but the problem is that after a reboot the icon isn't shown in the list of things to hide or show.

    It's gone  Sad
    Monday, August 25, 2008 10:07 AM
  • Same with me. The windows home server icon disappears after a reboot. There is an inactive icon for "Windows Home Server Network is healthy" in the list of the system tray (opened by right clicking) which it marks as "always show" (but it actually doesn't show, it appears to be inactive). Strange that it here does not show the green WHS icon but just the yellow "folder" icon. And still no WHS icon in the real system tray.

    I only have this problem at one of my network pc's. Not at any other. All run on Windows XP Home SP2/3.

    Can anyone explain why it shows the "folder" icon and not the green WHS icon?

    Many thx
    Sunday, September 7, 2008 7:26 PM
  • Hi,
    Since the original post, I've been doing some reading, and I found this. It could be worthwhile having a check and see if it applies to your situation.

    Colin
    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by tt - n Monday, September 8, 2008 7:35 PM
    Sunday, September 7, 2008 7:49 PM
    Moderator
  • Great tip, Colin. Solved the problem thanks to the Ostuni workaround:

    "Francesco Ostuni further mentioned that the same can be done through Control Panel, Add or Remove Programs, on the left side: Add/Remove Windows components; select Networking Services, click on the Details... button, remove the checkmark for the UPnP User Interface, then click on OK."

    All my icons are back. No other problems encountered (so far).

    Many thx
    Monday, September 8, 2008 7:34 PM
  • Hi,

    Glad you found an answer.
    Itmight help others, as I've now seen a few people with the same problems.

    Good luck,

    Colin
    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Monday, September 8, 2008 7:50 PM
    Moderator