locked
​ msmoney.exe - bad image error - atl80.dll RRS feed

  • Question

  • I cant resolve this issue.  

    windows\winsxsx86_microsoft.vc80.atl_1fc8b3b9a1e18e3b_8.0.50727.6195_none_d1cb102c435421de/atl80.dll is either not designed to run on windows or contains an error. Try installing the program again using the original installation media or contact your <g class="gr_ gr_22 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="22" id="22">sytem</g> <g class="gr_ gr_23 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="23" id="23">administractor</g> or the software vendor for support. Error status 0xc000020.

    Wednesday, September 27, 2017 4:09 PM

All replies

  • This doesn't look like an error from the  Microsoft Money program.  But maybe one of the forum members can help anyway.  To give them some more to go on:

      - what version of Windows are you using?

      - what version of Money were you using or installing?

      - was it installed from a disk or a downloaded file?  Which one?

      - what are you doing when the error occurs?


    Bill Becker

    Wednesday, September 27, 2017 6:08 PM
  • Bill thank you so much for trying to help me!

    My windows os build is windows 10 pro, version 1607, 14393.1715, 64bit

    I reinstalled the sunset version on the website.  USMoneyDlxSunset, file version 6.0.2800.1168, product <g class="gr_ gr_105 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="105" id="105">verson</g> 17.0.120.3817

    I downloaded it. 

    <g class="gr_ gr_168 gr-alert gr_tiny gr_spell gr_inline_cards gr_run_anim ContextualSpelling multiReplace" data-gr-id="168" id="168">i</g> get this error when I try to start the program.

    thank you thank you for your help!!

    Thursday, September 28, 2017 3:57 PM
  • That is the correct installation file for US Money Plus Deluxe Sunset.  It may be that the atl80.dll system file has become corrupt.  But before trying to fix that, I suggest trying something simpler first:

      - uninstall Money

      - delete the downloaded Money Sunset installation file

      - re-download the Money installation file

      - reinstall  Money

    If you still get the error, you can have a look at this link: 

    https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

    where there is a description of how to scan your Windows installation for missing or corrupt system files and repair them.

    Let us know how you make out.

    Note that once Money Sunset is up and running there is a file replacement that you need to do.  This "sticky" post describes it:

    https://social.microsoft.com/Forums/en-US/d28d6921-1f01-430f-b33e-f5a3ec47077b/important-patch-for-money-plus-maybe-20062007-mnyob99dll?forum=money


    Bill Becker


    • Edited by Bill Becker Friday, September 29, 2017 2:49 PM
    Thursday, September 28, 2017 5:02 PM
  • I followed these steps but still I get the same error :-(
    Friday, September 29, 2017 1:53 PM
  • Um, - which steps?  Did you run the DISM tool and the sfc tool as described in the link that I provided above?  What results were reported?

    Also, just to  help us understand your situation, do you get this error when you are installing Money or when you open your Money.mny file?  What happens if you open the Sample.mny file that is in your C:\Program Files (x86)\Microsoft Money Plus directory?


    Bill Becker

    Friday, September 29, 2017 3:05 PM
  • <g class="gr_ gr_55 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" data-gr-id="55" id="55">Yes</g> I ran both tools and everything was 100% ok.  <g class="gr_ gr_105 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="105" id="105">Money</g> will install just fine.  it says "money is <g class="gr_ gr_345 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del" data-gr-id="345" id="345">rea</g>, but when it tries to open I get that error.  I wish I could just rename atl80.dll to atl80.dll.old but I don't have permission even though I am the admin of this computer.  I just tried opening sample.mny and it gave me the same error.
    Friday, September 29, 2017 5:50 PM
  • I ran both tools and everything was 100% ok.  Money will install just fine.

     I wish I could just rename atl80.dll to atl80.dll.old but I don't have permission even though I am the admin of this computer. 

    Open Windows Explorer, or whatever it is called, by right-clicking the launch icon, and choosing RunAsAdministrator.

    If that does not work, you could run a command window as administrator, and rename in that command window.

    Friday, September 29, 2017 6:02 PM
    Moderator
  • You could try downloading and installing Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update . This may overwrite atl80.dll with a good copy.

    See MS11-025: Description of the security update for Visual C++ 2005 SP1 Redistributable Package: June 14, 2011

    Otherwise, if you can extract atl80.dll from the security update package try the steps in the answer at file in system32 and winsxs corrupted - how to fix?

    Saturday, September 30, 2017 1:03 PM