locked
Installation Cancelled RRS feed

  • Question

  • Hi

    New PC and I'm getting the Connector 'installation cancelled' popup when it is about 95% complete.  The Server Dashboard shows the PC but offline. I have searched various forums and tried different solutions but without success.  3 other PCs connected to the Server ok running Win 7 and Vista.  As others have said frustrating and time wasting, but I will keep trying.

    Any suggestions please.

    Steve

    Thursday, May 7, 2015 5:42 PM

All replies

  • How are you installing the connector - <servername>/connect?

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Thursday, May 7, 2015 9:28 PM
  • Yes, http//servername/connect. It is initially connecting to the server ok then rolls back just as it gets to the end of the process.
    Friday, May 8, 2015 7:46 AM
  • Hi Steve,

    Following 2 articles provided possible solutions for this issue:

    https://technet.microsoft.com/en-us/library/computer-connection-support-2.aspx#BKMK_ConnectorIssuePwd

    Verify and modify SYSTEM account permissions for all the server folders
    Open the Windows Home Server 2011 Dashboard.
    Click Server Folders and Hard Drives, and then click Server Folders.
    Right-click a server folder, and then click Open the folder. This launches Windows Explorer, which displays a list of all folders and files that are contained within that server folder.
    Right-click a server folder in the tree, and click Properties.
    On <serverfoldername> Properties page, click Security.
    Verify that the Full control permissions is set to Allow. If not, click Edit to change the permissions for the SYSTEM account.

    http://social.technet.microsoft.com/wiki/contents/articles/3941.sbs-2011-troubleshooting-client-deployment.aspx#You_receive_the_error_ldquo_The_installation_is_canceled_The_Windows_Server_Connector_has_encountered_an_unexpected_error_rdquo

    Commonly Task Scheduler task image is located in : C:\Windows\System32\Tasks, please delete related corrupted image in this folder and see if the issue occurs.
     
    Delete related registry item in the following location.
     
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks
     
    Please locate to related folder with the same ID displayed on the error message, and delete this item.
     
    Note: Pay attention to back up your registry before doing any modification.

    If issue still exists, you can collect the log file, upload it so that we can help to have a check. Thanks.

    Windows Server Solutions Log Collector Tool

    http://www.datazx.cn/en-us/download/details.aspx?id=27567


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, May 9, 2015 8:18 AM
  • Hi Shaon.

    Thanks for the suggestions.

    1. After a reboot and running the connector, I initially cannot connect to the server. Message "cannot connect the computer to the server because another software installation is in progress, or the computer has a restart pending ......".  Another post suggested editing the registry HKEY_LOCAL_MACHINE / SYSTEM / Current Control Set / Control / Session Manager / PendingFileRenameOperations to PendingFileRenameOperations2.  This solves this problem.

    2. Suggestion 1, on the server all folder permissions are all ok. No effect.

    3. Suggestion 2, tasks deleted.  No effect.

    4. Downloaded Log Collector Tool will not run, message "An unknown error prevented the Log Collector program from running.

    5. Using Event Viewer / Administration Events, I get the error message MsiInstaller ID 1023 "Product WHS2011 Connector - Update 'Update Rollup for Microsoft Windows (KB275014) could not be installed. Error code 1603".  This refers to a log fie in C:\Program Data but this directory does not exist.

    Hope this helps to find a solution.


    • Edited by t-stag Saturday, May 9, 2015 4:22 PM
    Saturday, May 9, 2015 4:22 PM
  • I finally solved it by reinstalling the OS, setting up networking and file sharing, then running the connector.

    All the updates and other applications are installed afterwards.

    :)

    Friday, May 22, 2015 7:22 AM