none
ASP.NET Core 3 Web Application, Azure App Service, and a ANCM In-Process Handler Load Failure RRS feed

  • Question

  • Hey MSDN folks,

    I am really new to working with all of these different technologies so pardon me if I am missing some knowledge. In any event, I have a bit of ASP.NET MVC architecture under my belt but I have yet to really grasp the framework, tooling, or what the scaffolding of any given ASP-type web application is doing.

    tl;dr;

    At the moment, I am working on hosting an ASP.NET CORE (3) web application with Azure and I have setup a plan for the App Service. The project is very simplistic and I just want to get it to run from Azure so it can field requests. The problem, is that it builds fine on my machine but when I publish it to Azure I am met with an HTTP Error 500.0 denoting that I am probably missing one of these requirements:
    • The specified version of Microsoft.NetCore.App or Microsoft.AspNetCore.App was not found.
    • The in process request handler, Microsoft.AspNetCore.Server.IIS, was not referenced in the application.
    • ANCM could not find dotnet.

    I think the issue boils down to that I am not doing something with IIS properly either on my local machine or in the cloud.
    I will change the logging level of the application as suggested in error message I am getting when I hit the web page AND I have configured a service for Application Insights on Azure so hopefully that will help my case. I have tried a number of StackOverflow suggestions regarding web configs and such but those just regenerate on build.

    Any help would be so, so, greatly appreciated as this is a portfolio piece for me and I spent a fair amount of time working on it - I think I may have just missed something basic. Thank you.


    Thursday, February 14, 2019 7:45 PM

Answers

  • Hi EvanRicard,

    This forum discuss and ask questions about issues regarding the very core of .NET, since your issue is more related to asp.net core, I would suggest that you could post your issue on asp.net core forum for suitable support.

    https://forums.asp.net/1255.aspx/1?ASP+NET+Core

    Thanks for you understanding.

    Best regards,

    Zhanglong


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by EvanRicard Friday, February 15, 2019 3:15 AM
    Friday, February 15, 2019 1:47 AM

All replies

  • Hi EvanRicard,

    This forum discuss and ask questions about issues regarding the very core of .NET, since your issue is more related to asp.net core, I would suggest that you could post your issue on asp.net core forum for suitable support.

    https://forums.asp.net/1255.aspx/1?ASP+NET+Core

    Thanks for you understanding.

    Best regards,

    Zhanglong


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by EvanRicard Friday, February 15, 2019 3:15 AM
    Friday, February 15, 2019 1:47 AM
  • Absolutely, I will, thank you Zhanglong.
    Friday, February 15, 2019 3:15 AM