locked
Fresh CRM 4.0 issue RRS feed

  • Question

  • Hi, have just installed a new instance of CRM 4.0 professional, on a server 2008 box with SQL 2008 server installed, all seemed to go ok, but when i get to the first page, i cannot add anything, so if i try and add a new account/user etc it just comes up with an error screen each time i press save or save and close.  The only user i have at the moment is the system administrator,  the domain already has a crm 4.0 instance on a separate server that is fine. i pretty much did default for all service accounts etc on install.

    Any help on this issue would be much appreciated.

    Regards

    Chris

    Wednesday, February 19, 2014 5:03 PM

All replies

  • I'd start by enabling tracing to see if that gives a useful error message.

    Can you view data (there won't be much, but there will be at least one user), but not create any records ?


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Wednesday, February 19, 2014 9:58 PM
    Moderator
  • can u paste some screenshot ?
    Wednesday, February 19, 2014 10:00 PM
  • Can you check on your user form, if you have been set to Administrative Access or ReadOnly access?

    HTH

    Sam


    Dynamics CRM MVP | Inogic | http://inogic.blogspot.com| news at inogic dot com

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Thursday, February 20, 2014 8:43 AM
  • Could be an issue with connecting to the DC.  You can try using Kb954811 to Add Prefered DC key if this is the issue.


    Jason Peterson

    Thursday, February 20, 2014 8:58 AM
  • Hi, thanks for the replies, user is showing full access, will have a look at the kb article am guessing it could be that, just seems odd that i cannot create or add any new accounts, customers or users?  would not be sql permissions maybe.

    The error comes up as Error, an error has occured box, then it says try again, if not contact forum or microsoft

    Thanks again

    Chris


    Friday, February 21, 2014 11:15 AM
  • Hi Again, have looked at the kb article and i have applied all rollups and still the same issue, we only have one DC also, not sure what else it can be, may have to ditch the vm and start from scratch to see if it was anything to do with the upgrade from server 2003 to server 2008.

    Any other suggestions?

    Cheers

    Chris

    Monday, February 24, 2014 12:18 PM
  • Hi Again, only user i have is set to full access not administrative, tried to change this but cannot set it to administrative, comes up with the same error. have tried adding logged in admin user to new groups but no luck, have changed the attribute in registry but still same, not sure what else to try other than trash it and start fresh on new vm

    Cheers

    Chris

    Monday, February 24, 2014 4:23 PM
  • Hi,

    You said the CRM machine is in VM, check your network adapter is in bridge or NAT. check the access to ping AD.

    To add a user in CRM the user must be in AD or create a new user again.

    Check the time is getting sync in CRM with AD server.

    please provide us the error log details from event viewer

    Thanks.  


    Vinay Kumar.


    Tuesday, February 25, 2014 9:00 AM
  • Did someone add the account running the CRM AppPool to the organization as a user?  This will cause access issues for users.

    If you create a new vanilla org, are you able to access that new org without issues?  This will help determine if it is just the org or something with Dynamics CRM itself.


    Jason Peterson

    Tuesday, February 25, 2014 9:01 AM
  • Hi,

    Check the privilage accounts on AD and the ID's of Sql server , your VM should have been added automatically to the groups if not add them and try to perform your activity


    401

    Tuesday, February 25, 2014 4:47 PM