locked
CUPS 6.0.4, CUCM 6.1.2, OCS 2007, MOC 2007 - No phone system connection RRS feed

  • Question

  • Hi all! First post here. Let me introduce myself first. I'm a student from Belgium doing an internship at Ferranti together with another classmate of mine. Our task is to get a unified communications environment working. We've set up communication between OCS, Exchange, AD and CUCM so far. IM, Voicemail and Calender integration are working great. We've stumbled upon one big problem tho. We can't get CUCM, CUPS and OCS to work together properly! Seeing we're students we don't got much background on this subject so we read some guides to implement this. Saddly to no avail.

     

    We've done some research about the problem but can't seem to find a solution.

     

    First of all, let me explain what we did:

     

    We installed CUCM 6.1.2 and CUPS 6.0.4. We deployed a SIPtrunk between them which I THINK is working fine (any tool to troubleshoot this?). We used the troubleshoot page on presence and got ride of all the problems there. Next step was to deploy a connection between OCS and CUP. We deployed a CTI gateway, set up ACLS with the IP adress of our OCS server. Next we did some configuration on the OCS side. Setting some front end properties like a static route in the routing tab as domain we filled in our domain (being corp.ferranti.be) as IP adress we filled in the ip adress of the CUP and set it up to use TCP over port 5060. On the host authorization tab we filled in the IP adress of our CUP aswel.

     

    Next we enabled our users to use RCC.

    • As Server URI: sip:userID@presence.corp.ferranti.be
    • As Line URI: tel:IPphoneNumber;phone-context=dialstring

     

    We made sure that the users in CUCM and OCS are the same.

     

    Thinking everything would work fine we launched MOC on the clients and got the No Phone System Connection error.

     

    I'm thinking our OCS can't make a connection to CUP, hence the No phone system connection. Or am I wrong here?

     

     

     

     

     

     

    EDIT: Applied a sniffer to our network. It showed NO packet flow from OCS to CUP whatsoever. Only our own ping packages from CUP to OCS showed up.

    Thursday, September 18, 2008 8:49 AM

All replies

  •  

    Applied a sniffer to our network. Don't know if this helps, but we've noticed NO packet flow from OCS to CUP except for our own ping packages from OCS to CUP.

    Thursday, September 18, 2008 1:00 PM
  • Make sure your registry settings are correct on the client (or group policy)

     

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Communicator

     TelephonyMode = 2

     

    Also, on CUPS, verify that you have added the OCS server to the incoming/outgoing ACL lists.
    Monday, September 22, 2008 6:23 PM
  • Hi

     

    If you entered "corp.ferranti.be" for the static route between OCS and CUPS, and you put "@presence.corp.ferranti.be" as Server URI domain for your users, this is wrong and you won't get any packet as you said.

    The static route needs to be exactly the same as the Server URI domain: the simplest way for you is to modify your static route to "presence.corp.ferranti.be", associated to the CUPS IP.

    In fact there is no need to put an existing domain, it could be blabla.blabla as long as it is the same on both parameters...of course something meaning is better Wink

     

    Wednesday, September 24, 2008 5:45 PM
  •  

    Hey! Thanks for the replies! We've got a step further in the problem. My sniffer can see an INVITE packet going to CUPS which on his turn responds with a 401 SIP unauthorized packet and an error on MOC saying "Cannot obtain authorization for phone integration". I've checked the settings in CUPS, everything is set to a non-secure SIP profile, user ID's match those in AD and OCS and ACL's are set on CUPS. So I guess the problem is OCS? Does it demand security? 

     

    I've also changed the static route to match the server URI as described in this guide:

    http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/pbx/interop/notes/617030nt.pdf

     

    Actually, I followed that guide from page 1.

     

    Thanks in advance!

     

    Regards

     

    Dimitri.

    Thursday, September 25, 2008 7:14 AM
  •  

    You can add more than one static route for cups under the front end Routing tab.  I would add the cups server by name, then the domain and finally the ip address. 

     

    for instance:

     

    SIP:.*@cups01.domain.local

    SIP:.*@domain.local

    SIP:.*@10.10.10.10

     

    If it starts working, then back out each one until it breaks. 

     

    Also, verify that DNS is enabled on the CUPS server.  I've seen CUPS installed without DNS which can cause all sorts of issues trying to integrate into OCS.  This is enabled during the installation, but can be turned on at the console after the fact.

    Thursday, September 25, 2008 12:17 PM
  •  

    I'll try that and keep you posted. One question tho? Wouldn't enabling DNS on CUPS mess up my DNS server wich is running on a W2k8 server?
    Thursday, September 25, 2008 12:34 PM
  • Hi

     

    There is also an option on CUPS where you need to enable each user for MOC (in CTI Gateway if I remember).

    Matt is right for the DNS, I had this pb one time. You need to define the IP address of the DNS server you use, you don't need to enable DNS service on CUPS, no risk to mess up your DNS.

    Thursday, September 25, 2008 5:16 PM
  • No, this will not affect DNS on your win2k8 box.  CUPS only has provisions for DNS client, not server. 

    Thursday, September 25, 2008 7:34 PM
  •  

    Sorry, maybe I did not caught all the scenario, but have you already setup TCP on OCS in order to allow it to communicate with CUPS? for default there is only TLS.

     

    Thursday, September 25, 2008 8:12 PM
  • I just dealt with this issue yesterday. To solve it I had to allow CTI control of all phones on the CUCM server otherwise we got unauthorized errors on all clients.

    HTH<

    Tim

     

    Thursday, September 25, 2008 8:45 PM
  •  

    Hey all!

     

    Again thanks for the replies, I finally feel we're getting somewhere. We had a power outage at the company this night which screwed some of our systems. Doing our best to get them up again.

     

    To answer on some of your questions:

     - I indeed made the TCP connection between OCS and CUP. Correct me if i'm wrong but it's the static route you set on OCS pointing to CUPS right? We got communication between CUP and OCS, but we're always getting the 401 SIP unauthorized packet back from CUP. MOC shows us an error "Cannot obtain authorization for phone integration".

     

     - I will check my CUCM settings, but something tells me I already did that

     

    Again thanks for the replies, I know as a student you got to learn stuff, but looking at the same error screen for more than one week isn't really productive. I hope that that I clarified some of the questions you had? I'll post an update as soon as we got to test things out.

     

    Regards,

     

    Dimitri

     

    Friday, September 26, 2008 10:28 AM
  •  

    Hi,

     

    Try this for host authorization

     

    1.      Add the following Authorized Hosts:

    a.       FQDN: cups.domain.local

    b.      Enable both: Throttle as Server and Treat as Authenticated

    And

    a.       IP: cups ip

    b.      Enable both: Throttle as Server and Treat as Authenticated

    Configuring OCS to allow TCP(5060) connections from Gateway

    1.      Open Office Communications Server 2007 console

    2.      Navigate to Front Ends folder

    3.      Right click your user ocsxxxx.domain.local

    4.      Choose Properties

    5.      On tab General click Add

    6.      For IP Address leave: All

    7.      For Transport: TCP

    8.      For Port: 5060

    9.      Finish the task

    10.  Restart the Front End Services

    Friday, September 26, 2008 10:33 AM
  • HI all! It's been a while. We were kinda bussy setting things up after some major issues due to a power outage.

     

    We seem to have progressed a step, don't know if it's in the good direction tho.

     

    So here's what we've done. We checked the DNS settings on the CUP server.

    Adding a primary DNS on CUP gave the following lines:

     

    "Executed command unsuccessfully"

    "ip.cups already exists."

     

    After this we added the following Authorized Hosts on OCS:

     

    a.       FQDN: cups.domain.local

    b.      Enable both: Throttle as Server and Treat as Authenticated

     

    And

     

    a.       IP: cups ip

    b.      Enable both: Throttle as Server and Treat as Authenticated

     

    We also configured OCS to allow TCP connections (as described above) and we checked if CTI control was enabled on the CUCM server for all phones. After doing this we checked if things were looking different. They infact did! We can see an INVITE going from OCS to CUP followed by a few responses from CUP which are followed with a CANCEL going from OCS to CUP. My guess is that OCS reached a timeout for the INVITE.

     

    Now I don't know if this is a step in the right direction? Another strange thing. If I modify my static route to a 5060 port on OCS I get the UNAUTHORIZED packets again from CUP.

     

    Regards,

    Dimitri

     

    EDIT:

     

    added a small picture from my packetsniffer

     

     

    Monday, October 6, 2008 8:18 AM
  • I am not sure if you have found the solution. I have CUCM 6.1.1.2000-3, CUPS 6.04, and MOC 2007 with RCC enabled. I have seen this type of error in our environment when we have shared-line DN more than 3 devices. CUPS doesn't know which phone to control. Also, if you have more than 1 CTI device (IP Communicator) with same DN, it will also throw out this authorization error. Make sure you restart Cisco UP Sync Agent.

     

    Thanks

    Yuichu

    Saturday, October 18, 2008 9:19 PM
  • Hey all,

    I wrote a blog that goes through a lot of these "no phone system connection" errors & how to troubleshoot them. Hope this helps.

     

    Regards,

    Matt

     

     

    Wednesday, October 22, 2008 6:05 PM
  • If a line is shared more than twice, here are some guidelines to direct Presence:

     

    Cisco Unified Presence Deployment Guide

    Release 6.0(1)

     

    Enter the Tel URI.

    Cisco recommends that you use the following format for the TEL URI:

    tel:xxxx;phone-context=dialstring

    where

    xxxx also specifies the directory number that the CTI Manager reports to Cisco Unified Presence as

    the calling or called number when a call gets placed.

    phone-context=dialstring enables the MOC client to control one of the devices that are associated

    with the directory number.

    If you enter the device ID, the MOC client can only control that particular device; for example:

    tel:xxxx;phone-context=dialstring;device=SEP0002FD3BB5C5

    If you enter the partition, the MOC client specifies the partition for the directory number; for example:

    tel:xxxx;phone-context=dialstring;device=SEP0002FD3BB5C5;partition=myPartition

    If you do not enter the device ID in the TEL URI, CTI Gateway determines the devices that are associated

    with the line directory number. If only one device is associated with the line DN, CTI Gateway uses that

    device.

    If you do not enter the device ID in the TEL URI and two devices are associated with the line DN (shared

    line), CTI Gateway uses the following rules to select a device:

    If one of the two devices is Cisco IP Communicator and its status is registered, CTI Gateway uses

    that device.

    If one of the two devices is Cisco IP Communicator, but it is not registered, CTI Gateway uses the

    alternate hard device.

    If two hard devices exist on the shared line, CTI Gateway monitors the two devices while making a

    call on the shared line. When the user answers, CTI Gateway monitors that device.

    If more than two devices are associated with a line DN, you must specify the desired device in the TEL

    URI.

     

    Cheers,

     

    Dan

    Monday, November 3, 2008 7:04 PM
  • What about if a "Please Wait... Waiting for the file to update." message stays up on the screen after the moc client has been logged in?

     

    Other quick tests were also done, dnd presence and ip phone presence is visible on the cipc and 7961 but no data in the Cisco UP SIP Proxy type sdi window ?

     

    Hey thanks very much for the RTMT comment I sure this will be very useful.

     

    Cheers,

    Dan

     

    Monday, November 3, 2008 8:21 PM
  • Hi all! I know I let you in th dark for quite some time now, but we managed to get our problem solved by following matt's blog. Everything is working fine for us at the moment.

     

    I'd like to thank all of who contributed to our solution.

     

    I do however have another question tho. I've set up enterprise voice with PBX integration, running pretty smooth. Our only question is. Is it possible to let users use their MOC to answer calls? The only thing we can do with MOC place a call to a number, CUP makes both your IP phone and MOC ring on both sides, but if we click the "answer call" option from moc we pick up our IP phone.. So no sound comming out of my laptop / pc speakers, but sound comming out of the IP phone's speaker.

     

    Is there any solution to the problem above you might know? Is it a simple option in presence? Or is this just the way the system works? No workarounds or anything?

     

    Regards,

    Dimitri.

    Monday, December 1, 2008 2:49 PM
  • That is simply how RCC works.  To enable Enterprise Voice (using MOC as a phone) you would need to deploy a Mediation server and configure direct SIP between OCS and CUCM.

    Tuesday, December 2, 2008 1:22 AM
    Moderator
  • So in combination with CUP I suppose?

    Tuesday, December 2, 2008 10:45 PM
  • CUPS would only be needed if you are employing any features of RCC, whether just using the standard RCC mode or moving to the newer Dual Forking with RCC mode, which is basically Enterprise Voice + RCC.  The newer 7.x version of CUCM supports this dual-mode better than 6.x versions from what I've read and seen.

     

    Basically, if you want only RCC, then you need CUPS but don't need an OCS Mediation server.  If you want EV then you only need a Mediation server, not CUPS.  To run in dual-mode you'll need both servers.

     

    Wednesday, December 3, 2008 1:59 PM
    Moderator
  • Hi people my name is zackMoz I have the same problem as ferdimi but instead of using ocs2007 and moc2007 im using CUPC 1.2(2 or 4). can someone hep me please?
    Wednesday, March 4, 2009 7:43 AM
  • Hi Zack,

    Best you try the forums on Cisco.com. This is a MSFT forum and unless it is Microsoft related your not going to get much help.

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Wednesday, March 4, 2009 3:17 PM