none
Visual Studio 2017 PowerShell Tools - PS debugger doesn't work RRS feed

  • Question

  • I have loaded PowerShell Tools for Visual Studio 2017, on using Community version, and another one using Professional version.

    Community version debugger hitting breakpoints works correctly. Sometimes it fails, but most of the time it works.

    VS 2017 Professional level will hot stop on breakpoints, it just runs to the end of the script.

    Internet folks have different experiences, a couple have said that the PS debugger was setup for VS 2015, and not for VS 2017.

    The PS Extension says Visual Studio 2017, so I'm assuming it should work with VS 2017, but it doesn't.

    Any ideas on how to get it to work?

    Is there another PS extension out there that does work?

    Note: Category selection below does not have VS or PowerShell...I have no idea what category to select.

    I'll guess at Community Participation Center.

    Can someone forward or alert me how to get it to go to VS and or PS people?


    Richard Loba

    Monday, March 12, 2018 6:37 PM

All replies

  • Hi Mke,

    If this issue is related to the PowerShell debugging, you could post this issue to the Github site here:

    https://github.com/adamdriscoll/poshtools/issues

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 16, 2018 10:04 AM