locked
Sync only work if the client table has less than 270 records RRS feed

  • Question

  • Hi,

    I dont know why the sync doesn't work when I sync a set of tables where there is one has more than 270 records from Windows Mobile 6 to PC (a server). However if there are less than 270 records it works without any issue.

    My sync service is hosted with IIS 7 using ASP.NET service. Initially, I hosted it as a WCF service, but I changed it to ASP.NET service because of the above problem and the problem still persists.

    I follow the instruction from msdn which help me to setup a sync service with Microsoft Sync Framework 1.0, perhaps I may miss a pre-step or 2, but if I really am missing a step, the sync wouldn't be working at all.

    Do I need to setup something in the Web.config file?

    Please help me with this issue, and sorry for my English.

    Thank you very much

    Sam

    PS: one more thing when the sync fail to sync, it throws WebException as an inner exception and TargetInvokationException as a general exception.
    Tuesday, January 12, 2010 7:46 PM

Answers

  • Hi Sean,

    Thank for your reply. Yes I followed this http://msdn.microsoft.com/en-us/library/cc488004.aspx to setup WCF sync service, and I even changed it to ASP.NET service. The sync work as long as there are 270 records or lower. I think I found the problem, I didn't add these code of settings:
    <bindings>
         <basicHttpBinding>
            <binding name="Binding1"
                  
                   receiveTimeout="00:01:00"
                   sendTimeout="00:01:00"
                   openTimeout="00:10:00"
                   closeTimeout="00:10:00"
                   maxReceivedMessageSize="165536" <--- this will increase the number of records, it was 65536
                   maxBufferSize="165536"
                   maxBufferPoolSize="524288"
                   transferMode="Buffered"
                   messageEncoding="Text"
                   textEncoding="utf-8"
                   bypassProxyOnLocal="true"
                   useDefaultWebProxy="true" >
                  <security mode="None" />
             </binding>
         </basicHttpBinding>
      </bindings>

    However, I have another unknow problem that the sync sometime is hang after the first sync. I made some change on IIS 7 which is hosting the service, but does it also affect the setting in web.config or the entire service?

    Sam
    Wednesday, January 13, 2010 3:42 PM

All replies

  • Sam,

    Have you tried going through the following walkthrough:
    http://msdn.microsoft.com/en-us/library/cc488004.aspx

    This is also a good thread to assist in troubleshooting:
    http://social.microsoft.com/Forums/en-US/uklaunch2007ado.net/thread/8698a0ce-25a4-4ac7-a4fb-c9f2492010dc

    Regards,
    Sean Kelley
    Senior Program Manager
    Microsoft
    • Proposed as answer by Sean_Kelley Wednesday, January 13, 2010 6:59 AM
    Wednesday, January 13, 2010 6:59 AM
  • Hi Sean,

    Thank for your reply. Yes I followed this http://msdn.microsoft.com/en-us/library/cc488004.aspx to setup WCF sync service, and I even changed it to ASP.NET service. The sync work as long as there are 270 records or lower. I think I found the problem, I didn't add these code of settings:
    <bindings>
         <basicHttpBinding>
            <binding name="Binding1"
                  
                   receiveTimeout="00:01:00"
                   sendTimeout="00:01:00"
                   openTimeout="00:10:00"
                   closeTimeout="00:10:00"
                   maxReceivedMessageSize="165536" <--- this will increase the number of records, it was 65536
                   maxBufferSize="165536"
                   maxBufferPoolSize="524288"
                   transferMode="Buffered"
                   messageEncoding="Text"
                   textEncoding="utf-8"
                   bypassProxyOnLocal="true"
                   useDefaultWebProxy="true" >
                  <security mode="None" />
             </binding>
         </basicHttpBinding>
      </bindings>

    However, I have another unknow problem that the sync sometime is hang after the first sync. I made some change on IIS 7 which is hosting the service, but does it also affect the setting in web.config or the entire service?

    Sam
    Wednesday, January 13, 2010 3:42 PM
  • However, I have another unknow problem that the sync sometime is hang after the first sync.
    I have to manually to restart the service after each sync in order for the next sync to work. Is there a setting that allow me to flush the connection after a sync? does timeout is the one can get rid of this problem?
    Wednesday, January 13, 2010 4:47 PM