locked
Mitel LBG and OCS 2007 - Communicator "Cannot connect to the phone system." RRS feed

  • Question

  • I've gone through the installation documentation over and over. The installation says I must use TLS for OCS 2007, but Mitel said we don't, as long as we change the Front End properties to TCP 5060.

    The settings I'm playing with are:

    LBG
    On the ICP tab:
    IP Addres: [IP of PBX]
    Remote CC SIP URI: sip: [default username for LBG on the PBX]@[PBX].[LBG Server].[FQDN]

    In the AD tab, I've added our primary domain controller.

    OCS
    Front End Properties
    Routing tab:
    Domain: [PBX].[LBG].[FQDN]
    IP Address: [IP of LBG]
    Transport: TCP
    Port: 5060

    Host Auth tab:
    [Entry with IP for LBG] Throttle as Server: Yes; Treat as Authenticated: Yes.
    [Entry with LBG.FQDN] Throttle as Server: Yes; Treat as Authenticated: Yes.

    User Options
    Enable RCC
    Server URI: sip: [default username for LBG on the PBX]@[PBX].[LBG Server].[FQDN] - this is identical to the RCC SIP entry on the LBG server.
    Line URI: tel:[4 digit extension]; phone-context=mitel.com

    Does anyone see anything obviously wrong? This is the format that the Mitel documentation says should be followed.

    Thanks all. I feel like I'm beating my head into a wall with this.
    Tuesday, September 22, 2009 3:00 PM

All replies

  • Update:

    Mitel has informed me of the following:

    1. 3300 MUST be pingable by hostname & hostname.FQDN. This requires a DNS entry.
    2. ALL references to the 3300 & LBG are CASE SENSITIVE! (I knew the 3300 references were, but not LBG).
    3. Under User Options / Line URI: phone-context=[FQDN] - not mitel.com

    None of these things have helped. But just as an update - the finer points of this install aren't mentioned in the install guide.

    Wednesday, September 23, 2009 2:31 PM
  • Update:

    OCS
    Front End Properties
    Routing tab:
    Domain: [PBX].[LBG].[FQDN] is incorrect. It should be [LBG].[FQDN]

    Finally making a tiny bit of progress. Communicator still "Cannot connect to the phone system," but now the more verbose error is "The call control server may be temporarily unavailable." That sounds better than the previous error of "An unidentified error has occurred."

    Still cracking at this...
    Wednesday, September 23, 2009 4:05 PM
  • Hi kpoland,

    Did you ever geta ny where with this?  I am having the same issue.

    Many thanks,

    Bara
    Friday, October 30, 2009 5:24 PM
  • Yes, Bara. This issue is resolved.

    We were able to use TCP between LBG and OCS.

    The correct syntax for LBG SIP URI is:

    [LBG service account username]@[PBX].[LBG].domain

    The entire SIP URI is case sensitive and must match the SIP URI on OCS for the users properties.

    Also, it is imperative that the LBG service account be given correct access on the 3300.

    For a Mitel 3300, this means:

    Check the rights for the LBG service account on the 3300 - turn the "application" setting for that user to "true."
    If it created a MiXml user, also change that "application" setting for that user to "true." (this only happend on our first 3300, probably due to all the testing. None of our other 3300's created a MiXml user at all, and we didn't end up needing it at all)
    Make sure HCI/MiTAI is turned on/enabled on the 3300.
    Make sure the username & password you are using for the LBG setup matches the username & password for the service account that you've created.
    Friday, October 30, 2009 7:09 PM