locked
Remote use of server control panel RRS feed

  • Question

  • I am accessing my whs 2011 server remotely. I have win7 on host machine with ie9. I go to server and get message about certificate error. Bypass then log in. I am able to send and recieve files, browse folders, see all the computers on the server that are backing up.  My problem is that when I click on the server icons connect button and try to connect to it i get a message that i cannot verify that the server is a legitamate machine and it refuses to connect.  If at all possible I need to be able to controll this machine remotely. I tried to kill all settings in browser about checking certificates. Still will not connect. Any ideas?
     
    Wednesday, July 4, 2012 2:53 PM

Answers

  • Rather than using Remote Access on your local network (that's for access from the Internet), install the connector Software on your Client machine and access your server via the Dashboard.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.


    • Edited by Phil Harrison Wednesday, July 4, 2012 3:13 PM
    • Marked as answer by Sean Zhu - Wednesday, July 11, 2012 7:11 AM
    Wednesday, July 4, 2012 3:13 PM
  • Wouldn't wonder me much, since Windows Server 2008 R2 as well as IE on the client are pretty caring a lot about security, so not using a domain name (which also implicates a certificate associated for this domain) might explain the situation.

    Remote desktop: I feel your wording "opened port" not matching.

    • Did you FORWARD a dedicated port (be it 3389 or some other) to port 3389 on the server?
    • Did you use the account InternalServername\Administrator for logging in via RDP?
    • Did you configure RDP to allow connections from all machines (in system properties/Remote on the server)?
    • Did you use the RDP client, and if you used a different port, would it work with externalname.homeserver.com:port as target in the RDP client?

    Best greetings from Germany
    Olaf

    • Marked as answer by Sean Zhu - Wednesday, July 11, 2012 7:12 AM
    Friday, July 6, 2012 2:41 PM

All replies

  • Rather than using Remote Access on your local network (that's for access from the Internet), install the connector Software on your Client machine and access your server via the Dashboard.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.


    • Edited by Phil Harrison Wednesday, July 4, 2012 3:13 PM
    • Marked as answer by Sean Zhu - Wednesday, July 11, 2012 7:11 AM
    Wednesday, July 4, 2012 3:13 PM
  • Im sorry I may not have mentioned, I am accessing the server remotely from the internet side. I set up the router at the remote location and it allows me through. I am able to connect to the server. I am not able to administrate the server remotely. I see the icon for the server in the computer list. I click the connect button beside this, and i get a box that says you are logging in as administrator...etc. I click go and it tries to connect, then a box pops up that says i cannot confirm the identity of the server at xxx.xxx.xxx.xxx internet address. then it terminates the remote desktop connection. It does not kick me out of the server "home" screen.  I also tried to just use remote desktop and it will not make connection.
    When i am at the location where the server lives, I use the control panel and it works well. I do have to connect to server locally using remote desktop connection on local network to monitor antivirus software. This cannot be controlled by the server control panel. When I connect in this manner I have no problems and it works well. I need remote access to controll it because I will be 350 miles from server for periods of time and need to be able to remote control it.  I would like to just RD into it like using server 2000 or 2003.
    • Edited by J. Walding Thursday, July 5, 2012 4:21 AM
    Thursday, July 5, 2012 4:15 AM
  • Accessing WHS via Remote Desktop is an unsupported scenario and therefore blocked by Windows Firewall. (At least it was in WHS 1.)

    To gain that possibility anyway (and open another chance for hackers and malware to enter your network) you would have to check and if necessary change the Windows Firewall exception for RDP to allow access from all networks and forward the appropriate port in the router (or another selected port) to the RDP port 3389 on the server.

    Also in Remote Settings of your WHS verify, if it allows remote connections from computers running any version of Remote Desktop (on System properties/Remote tab).

    For the web access to the server:
    Do you use Internet Explorer as your browser and is the homeserver.com website added to Trusted Sites zone?

    Best greetings from Germany
    Olaf

    Thursday, July 5, 2012 5:58 AM
  • The mentioned ports are open in router firewall. I can rdp other desktops direct before adding the home server.  Settings in server allow for remote desktop. I am using internet explorer 9, and in the settings i have added the server address as a trusted web site. I would also like to mention that i do not have a web domain for the server. I am connecting "raw" by just entering https://xxx.xxx.xx.x in the browser address bar. As I say I can get in as a user and share files etc. but can not connect to server and control it.
    Thursday, July 5, 2012 10:23 PM
  • Wouldn't wonder me much, since Windows Server 2008 R2 as well as IE on the client are pretty caring a lot about security, so not using a domain name (which also implicates a certificate associated for this domain) might explain the situation.

    Remote desktop: I feel your wording "opened port" not matching.

    • Did you FORWARD a dedicated port (be it 3389 or some other) to port 3389 on the server?
    • Did you use the account InternalServername\Administrator for logging in via RDP?
    • Did you configure RDP to allow connections from all machines (in system properties/Remote on the server)?
    • Did you use the RDP client, and if you used a different port, would it work with externalname.homeserver.com:port as target in the RDP client?

    Best greetings from Germany
    Olaf

    • Marked as answer by Sean Zhu - Wednesday, July 11, 2012 7:12 AM
    Friday, July 6, 2012 2:41 PM