none
Restore to new system RRS feed

  • Question

  • I just upgraded my MB from an abit IP35Pro to Gigabyte GA-EP45-ND3P, Processor from E6750 to Q9550 and with new disk drives etc.  I tried to use the WHS Restore CD to restore the operating system from the "old" system to the new one but the restore program cannot find the HomeServer.  Short of reinstalling the operating system and all the applications does anybody have an idea on why the Restore Program is having trouble finding the HomeServer on my in-house network.  Does it have anything to do with device drivers for the new hardware?  I see there was another post concerning drivers but the Gigabyte board has been around for awhile so I thought WHS would have its device drivers available?  I have used the restore program several times to save the day on "old systems" without a problem.  Help would be greatly appreciated.
    Thursday, July 23, 2009 10:37 PM

Answers

  • ...
    Does it have anything to do with device drivers for the new hardware?
    ...
    Yes. The Windows Home Server restore CD includes drivers for some common hardware, but not for absolutely everything under the sun, so it's possible that there are drivers (network, most likely) missing for your new motherboard.

    In any case, Windows Home Server restore will probably not be able to restore your old computer to your new one, even if you have the correct device drivers for the new computer. The backup that would be restored would contain the device drivers for the old computer, and would in all probability not boot fully on the new computer.

    The recommended way to migrate from one set of hardware to another is a fresh operating system installation. Then you'll restore data only, using the single file restore method.

    I'm not on the WHS team, I just post a lot. :)
    Friday, July 24, 2009 2:45 AM
    Moderator
  • I'm now unconfused.  I did what you suggested and it works.  So the instructions in the FAQ section are a little mis-leading since it talks about the Bare Metal Restore CD and tells how to handle the Realtek drivers.  The instructions follow the Restore CD exactly?!  Anyway, thanks for setting me on the right path.
    • Marked as answer by Ken429 Sunday, August 9, 2009 11:06 AM
    Sunday, August 9, 2009 11:05 AM

All replies

  • ...
    Does it have anything to do with device drivers for the new hardware?
    ...
    Yes. The Windows Home Server restore CD includes drivers for some common hardware, but not for absolutely everything under the sun, so it's possible that there are drivers (network, most likely) missing for your new motherboard.

    In any case, Windows Home Server restore will probably not be able to restore your old computer to your new one, even if you have the correct device drivers for the new computer. The backup that would be restored would contain the device drivers for the old computer, and would in all probability not boot fully on the new computer.

    The recommended way to migrate from one set of hardware to another is a fresh operating system installation. Then you'll restore data only, using the single file restore method.

    I'm not on the WHS team, I just post a lot. :)
    Friday, July 24, 2009 2:45 AM
    Moderator
  • Yes, I know it may not work but I saw some stuff on another forum that said the change between P35 and P45 may not cause a critical problem and I would get a chance to update the drivers after the system was restored.  I'll try it with Acronis and let you know how it turned out.  Anyway, the real question is - will the restore work on the new system after I have done a fresh install of the operating system?  It would seem that IF the network driver is the problem then how do I update the restore CD with the new driver(s)?
    Friday, July 24, 2009 10:21 AM
  • I was telling you to start from scratch on the new system, and use the single file restore mode to get your data back.

    There is no supported way to add drivers to the Restore CD. Windows Home Server bare metal restore (the Restorer CD) includes the ability to load drivers from e.g. a flash drive; for a system that's been backed up all the required drivers are in every backup, in a folder named Windows Home Server Drivers for Restore. For a scenario such as yours, you'll have to extract and supply network and storage drivers for your new hardware yourself. The storage drivers are relatively easy; your motherboard should include instructions for preparing an F6 floppy; you can do as they suggest and put the results on a flash drive instead. For the network drivers, often you can just download the correct driver package from the manufacturer's web site, unzip it, and put that on your flash drive.




    I'm not on the WHS team, I just post a lot. :)
    Friday, July 24, 2009 3:16 PM
    Moderator
  • Ok.  Thank you for the speedy response.  I'll try putting the network drivers that came with the MB on a flash drive and see what happens.   I'm pretty sure that the network drivers are my problem since the latest version of the Acronis boot CD finds all the computers on my network.  If someone from the WHS team is watching in on this conversation please come up with a periodic update of the Restore Program (CD) that would include the latest and greatest drivers?  Like I said earlier the Restore CD has saved me from a fresh install disaster several times.
    Friday, July 24, 2009 4:40 PM
  • ...
    please come up with a periodic update of the Restore Program (CD) that would include the latest and greatest drivers? 
    ...
    This probably won't happen. It's slightly more possible for the next version of Windows Home Server than the current one, but i wouldn't expect it in that version either.

    Your scenario (hardware migration) was not, I believe, a design goal for Windows Home Server. In addition, the Restore CD uses WinPE 2.0, and only has the drivers that are included with that. There's no need for more; the Restore CD has a means of adding drivers for systems that don't have drivers "in box" on the Restore CD, and Windows Home Server has a means of extracting drivers from a backup for your use with the Restore CD. 

    I'm not on the WHS team, I just post a lot. :)
    Friday, July 24, 2009 5:26 PM
    Moderator
  • Well I ended up; taking the easy way out and installed a fresh version of Windows 7 RC.  I installed the WHS connector software and it seems to work for manual backups.  Strange things happened last night when it was to backup automatically which is probably a W7/WHS issue that I will need to pursue.  However, the standalone Restore CD still does not find the WHS on the network.  So... my Gigabyte board must have some unique network chip "Realtek RTL 8168C(P)/8111C(P)" that I will have to supply the driver if I ever need to use the Restore CD.

    • Proposed as answer by Tom Scales Monday, July 27, 2009 10:56 AM
    Monday, July 27, 2009 10:44 AM
  • Ken, for Realtek drivers see this post in the FAQ section.
    I'm not on the WHS team, I just post a lot. :)
    Monday, July 27, 2009 2:58 PM
    Moderator
  • I'm back...  I gave up on Windows 7 for now since Nero 7's Recode runs at about half speed under Windows 7 so I now have a Vistia Home Premium running on the Gigabyte UD3P system.  All is well, except the CD Recovery program.  I have tried putting the XP NIC drivers from the Gigabyte MB CD on a USB thumb drive and have failed.  I have tried down loading the XP NIC drivers from the Gigabyte web site and have failed.  I have tried putting the ZIP file containing the drivers on the USB thumb drive and have failed.  WHS CD Recovery program keeps coming back with the "No Drivers Found" message or something like that.  I am pretty sure I adhered to the above mentioned instructions but I must be missing something.  Any ideas out there on what I'm doing wrong.  I'm almost ready to install a floppy drive on this system! 
    Friday, August 7, 2009 11:10 AM
  • I'm back...  I gave up on Windows 7 for now since Nero 7's Recode runs at about half speed under Windows 7 so I now have a Vistia Home Premium running on the Gigabyte UD3P system.  All is well, except the CD Recovery program.  I have tried putting the XP NIC drivers from the Gigabyte MB CD on a USB thumb drive and have failed.  I have tried down loading the XP NIC drivers from the Gigabyte web site and have failed.  I have tried putting the ZIP file containing the drivers on the USB thumb drive and have failed.  WHS CD Recovery program keeps coming back with the "No Drivers Found" message or something like that.  I am pretty sure I adhered to the above mentioned instructions but I must be missing something.  Any ideas out there on what I'm doing wrong.  I'm almost ready to install a floppy drive on this system! 

    It probably doesn't work because XP drivers don't work on Vista.  ;)  Look for a Vista driver (32-bit version) for your NIC.
    Friday, August 7, 2009 1:14 PM
    Moderator
  • Now I'm really confused!  I am running Vista 64-bit on a Gigabyte UD3P motherboard.  The motherboard uses Realtek RTL 8168C(P)/8111C(P) NIC chips.  Vista and the WHS software that runs under Vista work ok.  My minor problem is the WHS standalone CD Recover Program does not like the NIC chips on the new MB.  Somewhere somebody told me that WHS is WinXP(Server 2003) based and I need Win XP drivers for the CD Recover boot program??  See all the verbage leading up to this post.  Is that wrong?
    Friday, August 7, 2009 4:07 PM
  • I'm now unconfused.  I did what you suggested and it works.  So the instructions in the FAQ section are a little mis-leading since it talks about the Bare Metal Restore CD and tells how to handle the Realtek drivers.  The instructions follow the Restore CD exactly?!  Anyway, thanks for setting me on the right path.
    • Marked as answer by Ken429 Sunday, August 9, 2009 11:06 AM
    Sunday, August 9, 2009 11:05 AM