locked
Problem downloading .lsabs and .dabs for address book sync

    Question

  • Hi everybody.

    I have been working on the address book sync issues, and have wound up here.

    My communicator error is " Synchronizing with the corporate address book has not been configured by your system administrator. Contact your system administrator to configure this feature."

    • I can browse to the URL for the abs from my client PC, and I can see the .lsabs and .dabs files.
    • I cannot download them. "Zero sized file" or "Internet explorer cannot display this page"
    • I can download the txt files in the directory.
    • I have added the mime types to IIS at the IIS root  level and restarted IIS.
    • In the IIS logs I can see the lsabs and dabs files being downloaded, http 200
    • The IIS logs show the file size (bytes sent) as 0 bytes. (exact log entry below)
    • The files do have size as reported when viewing the directory
    So I tested the mime type setup.
    • I have copied a .lsabs file and renamed it with a .BBB extension.
    • Without a mime type, the bbb files give a 404.3 error in the IIS logs.
    • With a mime type added, the bbb files download.

    So I am stuck. Why do these files download, or appear to download with a size of 0?

    Should I be able download these properly?



    #Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status sc-bytes cs-bytes
    2009-06-09 07:04:14 W3SVC1 10.60.250.130 GET /Abs/Int/Handler/F-0c09.lsabs - 443 - 10.60.16.51 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+2.0.50727;+InfoPath.2;+MS-RTC+LM+8) 200 0 0 0 268

    Thanks in advance for any help.
    Dave



    Tuesday, June 9, 2009 7:34 AM

Answers

  • Hi Matt

    Thanks for that, a very handy trick.

    Yes, the url is populated. I followed the link, which opened in Firefox rather than IE where i have been testing until now.
    Firefox gave me an SSL error. I had assumed my cert was ok, as IE was not prompting for anything, and the IIS logs made me think it was happy.

    Anyway, i reverted to a previous snapshot of the server, ready to work on the certificate issue.

    As soon as I reverted to the snapshot, the address book worked. I am sure it had not been working when I took the snapshot. I am confused, but happy its now working.

    Anyway, thanks for you help.

    Cheers
    Dave
    • Marked as answer by Dave Francis Tuesday, June 9, 2009 11:20 PM
    Tuesday, June 9, 2009 11:20 PM

All replies

  • If this is R2, hold down the CTRL key while clicking on the Communicator icon in the system tray, the select 'Configuration Information'.  See if the ABS URLs are populated.
    • Marked as answer by Dave Francis Tuesday, June 9, 2009 11:17 PM
    • Unmarked as answer by Dave Francis Tuesday, June 9, 2009 11:17 PM
    Tuesday, June 9, 2009 1:43 PM
  • Hi Matt

    Thanks for that, a very handy trick.

    Yes, the url is populated. I followed the link, which opened in Firefox rather than IE where i have been testing until now.
    Firefox gave me an SSL error. I had assumed my cert was ok, as IE was not prompting for anything, and the IIS logs made me think it was happy.

    Anyway, i reverted to a previous snapshot of the server, ready to work on the certificate issue.

    As soon as I reverted to the snapshot, the address book worked. I am sure it had not been working when I took the snapshot. I am confused, but happy its now working.

    Anyway, thanks for you help.

    Cheers
    Dave
    • Marked as answer by Dave Francis Tuesday, June 9, 2009 11:20 PM
    Tuesday, June 9, 2009 11:20 PM
  • I am getting the exact same error.  The ocs icon in the tray looks ok for a while after logging in, but after a while the red exclamation point shows up.  If you try to view the details of the error, you get:

    " Synchronizing with the corporate address book has not been configured by your system administrator. Contact your system administrator to configure this feature."

    I have never seen the galcontacts.db file in the %userprofile%\Local Settings\Application Data\Microsoft\Communicator  folder.  Does anyone have any solutions ideas for this?  We are getting desperate!
    Wednesday, September 2, 2009 3:30 PM
  • With the R2 client the Galcontacts.db file is actually located one folder deeper than the path shown above; there will be a separata folder for each user that has signed-in to OCS.

    Is this client connecting internally or externally?
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Wednesday, September 2, 2009 4:27 PM
    Moderator
  • We need more info on your problem but there are a couple of fixes for this issue. We just need to know more info about how you are setup.
    Mitch Roberson |MCITP:Enterprise Server Admin, Messaging |MCTS:OCS with Voice Achievement |MCT
    Thursday, September 3, 2009 2:50 PM
  • I have the same problem in 2 pcs, one is Vista X64 and the other Windows 7 x64. With XP or Vista 32 I don´t have that issue. Mayve teh problem is with X64. Is your pc x64?
    Friday, September 4, 2009 4:43 PM
  • All

    just for info there has been an update on some things with the client. So now instead of the client immediatly starting the download of the galcontacts.DB it can wait up to 90 min I believe is the time frame. This prevents larger companies from having problems when all users log on in the morning and try to pull the address book down.

    I believe the client version is .37 that is setup this way. So there may be some times it downloads immediatly and other times it takes the full 90 min. it is supposed to be a random time that it takes place. You can change the registry key to make it happen immediatly.

    http://support.microsoft.com/kb/972403

    Hope that helps.


    Mitch Roberson |MCITP:Enterprise Server Admin, Messaging |MCTS:OCS with Voice Achievement |MCT
    Friday, September 11, 2009 6:26 PM