locked
How do you permanently disable shadow copies on WHS? RRS feed

  • Question

  • Hey all!

    Quick question... How do you permanently disable shadow copies on WHS? I have disabled shadow copy in the properties panel. I have deleted the scheduled shadow copy tasks in settings and from within the control panel via scheduled tasks. It just keeps coming back. I can't even set the schedule differently.

    In case you are interested in why, I think I have figured out that shadow copy is contributing, if not to blame for some storage balancing issues that I am having (balancing never stops, very high disc and CPU usage). Specifically demigrator using 50% of my processor constantly (Athlon X2 4600 65W). I have been tracking this issue on a daily basis and when I delete the shadow copies my issues stop.

    I first started investigating the issue a couple of months ago when my electric bill jumped up $40.00 a month. I originally disabled demigrator service completely after monitoring the CPU usage and seeing demigrator was the culprit.

    Through trial and error, I got to the point where I re-enabled demigrator and deleting my shadow copies and my issues stopped completely. After a week or so the issues mentioned above started happening again as shadow copies started to build up. After deleting them again my storage balancing issues, high CPU and disk usage stop. I don't want to have to do this every week. I also wonder if this is why HP disables shadow copy on there MediaSmart servers?

    Any help would be greatly appreciated!

    Just an FYI... I do not have folder duplication on any shares. I have 2 WD 750 gig drives in which only 66% of the secondary drive is used and 1% on the primary drive. Also 2 gigs of RAM.

    THX Again!!!
    Wednesday, January 23, 2008 2:54 AM

Answers

  • @pnapp1

     

    Nice Work! I think you should post your findings on Windows Home Server Connect Feedback site. I really think WHS team should look into this.

     

    You may well be right about HP. It does bother me though that no one from HP steps in tells us why they did this, and I'm pretty sure they're actively monitoring this forum.

     

    Instead of deleting the shadow copies you could also try setting a limit to the size

     

    If you want to permanently disable shadow copies I think in regedit you have to go to  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes, then select a Volume, and set Key SnapPeriod to 0. Current setting will probably be 43200000 (milliseconds is 12h)

     

    Perhaps someone with a HP MediaSmart (Ken?) can check this key for HP system (and try enabling it and see what this does to the box!!)

    Wednesday, January 23, 2008 5:05 AM
    Moderator
  • First, the registry key brubber mentions is only set to a value other than 0 on the D: partition. On the HP MediaSmart Server, it's 0 for all partitions.

    I've played around with it in the past; it doesn't seem to help the situation with buggy shadow copies on multi-disk servers, and the exact value doesn't seem to affect the frequency with which shadow copies are taken, so for the time being the best advice I could give would be to give it a try and see what happens. If your server eats your files, well, standard disclaimers apply. Smile
    Wednesday, January 23, 2008 5:40 AM
    Moderator
  • See my post of 12:40 AM EST; changing the value to something other than the default of 43,200,000 milliseconds won't change the frequency or timing of shadow copies. You can turn them off or on with that registry value; that's it.
    Wednesday, January 23, 2008 4:57 PM
    Moderator

All replies

  •  pnapp1 wrote:
    Hey all!

    Quick question... How do you permanently disable shadow copies on WHS?

     

    You can't.  It's controlled by a service that is part of WHS.

     

     pnapp1 wrote:
    I have disabled shadow copy in the properties panel. I have deleted the scheduled shadow copy tasks in settings and from within the control panel via scheduled tasks. It just keeps coming back. I can't even set the schedule differently.

    In case you are interested in why, I think I have figured out that shadow copy is contributing, if not to blame for some storage balancing issues that I am having (balancing never stops, very high disc and CPU usage). Specifically demigrator using 50% of my processor constantly (Athlon X2 4600 65W). I have been tracking this issue on a daily basis and when I delete the shadow copies my issues stop.

     

    I haven't seen that on mine (and mine setup is about the same as yours).  The only time I've seen it constantly balancing is when the file filter misses a file as it arrives on WHS.  Apparently, it keeps trying to migrate the file to a secondary drive, but can't.

     

     pnapp1 wrote:
    I first started investigating the issue a couple of months ago when my electric bill jumped up $40.00 a month. I originally disabled demigrator service completely after monitoring the CPU usage and seeing demigrator was the culprit.


    Through trial and error, I got to the point where I re-enabled demigrator and deleting my shadow copies and my issues stopped completely. After a week or so the issues mentioned above started happening again as shadow copies started to build up. After deleting them again my storage balancing issues, high CPU and disk usage stop. I don't want to have to do this every week. I also wonder if this is why HP disables shadow copy on there MediaSmart servers?

    Any help would be greatly appreciated!

    Just an FYI... I do not have folder duplication on any shares. I have 2 WD 750 gig drives in which only 66% of the secondary drive is used and 1% on the primary drive. Also 2 gigs of RAM.

    THX Again!!!

     

     

    Wednesday, January 23, 2008 3:10 AM
    Moderator
  • @pnapp1

     

    Nice Work! I think you should post your findings on Windows Home Server Connect Feedback site. I really think WHS team should look into this.

     

    You may well be right about HP. It does bother me though that no one from HP steps in tells us why they did this, and I'm pretty sure they're actively monitoring this forum.

     

    Instead of deleting the shadow copies you could also try setting a limit to the size

     

    If you want to permanently disable shadow copies I think in regedit you have to go to  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes, then select a Volume, and set Key SnapPeriod to 0. Current setting will probably be 43200000 (milliseconds is 12h)

     

    Perhaps someone with a HP MediaSmart (Ken?) can check this key for HP system (and try enabling it and see what this does to the box!!)

    Wednesday, January 23, 2008 5:05 AM
    Moderator
  • Since you can't disable it, you could always setup a job to delete all shadows.  Using vssadmin you could submit the following:

     

    VSSAdmin Delete Shadows /All

     

    This should delete all shadows from all volumes.  Then schedule it for every 12 hours starting at 12:15 AM.  This should get them shortly after they are created at midnight and noon.

     

    Thanks

     

    Wednesday, January 23, 2008 5:20 AM
  •  SQL_Guru wrote:

    Since you can't disable it, you could always setup a job to delete all shadows.  Using vssadmin you could submit the following:

     

    VSSAdmin Delete Shadows /All

     

    This should delete all shadows from all volumes.  Then schedule it for every 12 hours starting at 12:15 AM.  This should get them shortly after they are created at midnight and noon.

     

    Thanks

     

    Like I said before, I think you can disable it permanently.

     

    Having said that I think your solution is also OK.

     

    However instead of VSSAdmin Delete Shadows /All I would personally try VSSAdmin Delete Shadows /Oldest and start the job after one or two days before the critical number of shadow copies has been reached. This way you still retain a number of shadow copies.

    Wednesday, January 23, 2008 5:37 AM
    Moderator
  • First, the registry key brubber mentions is only set to a value other than 0 on the D: partition. On the HP MediaSmart Server, it's 0 for all partitions.

    I've played around with it in the past; it doesn't seem to help the situation with buggy shadow copies on multi-disk servers, and the exact value doesn't seem to affect the frequency with which shadow copies are taken, so for the time being the best advice I could give would be to give it a try and see what happens. If your server eats your files, well, standard disclaimers apply. Smile
    Wednesday, January 23, 2008 5:40 AM
    Moderator
  • Thanks Ken!

     

    I have just set all to 0 on my box, so in about 6 hours I will know of it works

    Wednesday, January 23, 2008 5:50 AM
    Moderator
  • A reboot would probably be useful. I don't know if the component (I would guess the storage manager service) that uses that registry entry will pick up a changed value other than when it starts up.

    Oh, yes: I would be somewhat surprised if shadow copies are causing a problem with Drive Extender. DE only works on certain folders that WHS knows about; it shouldn't touch anything else, including the hidden system folder where the shadow copy data is stored.
    Wednesday, January 23, 2008 1:22 PM
    Moderator
  •  brubber wrote:

    Thanks Ken!

     

    I have just set all to 0 on my box, so in about 6 hours I will know of it works

    Well it works.

     

    No shadow copies @ 12.00 today. Will leave it like this for another 12h to see if also the 0.00 shadow copy is skipped. After that I'll try setting it to 6 hours, just to see if then makes shadow copy every 6h

    Wednesday, January 23, 2008 2:35 PM
    Moderator
  • See my post of 12:40 AM EST; changing the value to something other than the default of 43,200,000 milliseconds won't change the frequency or timing of shadow copies. You can turn them off or on with that registry value; that's it.
    Wednesday, January 23, 2008 4:57 PM
    Moderator
  • Thanks Ken and guys! I will keep an eye on this and let you know if I find anything else.

    THX Again!!!
    Thursday, January 24, 2008 5:21 PM
  •  Ken Warren wrote:
    See my post of 12:40 AM EST; changing the value to something other than the default of 43,200,000 milliseconds won't change the frequency or timing of shadow copies. You can turn them off or on with that registry value; that's it.

     

    Long time ago I set this value to 6 hours. Never bothered to look at it again, since it's not really an issue and I thought Ken would be right. However today I noticed that my box actually takes snaphots every 6 hours, so you can actually set snaphot frequency using this registry key.

    Thursday, February 21, 2008 11:17 PM
    Moderator
  • Nifty, and amusing, brubber. I believe you, but I when I checked with Microsoft on that issue, they confirmed that it's an on/off switch., not a timer. Which corresponded with my observations where I set a range of different values and got copies every 12 hours. Smile

    I wonder if there are just a few "magic numbers", and everything else acts as an on/off switch?
    Friday, February 22, 2008 3:27 AM
    Moderator
  • Ken,

     

    I agree it's funny. I have the key value set to 21600000 for D partition only, others are set yo 0.

     

    I was also convinced you were right, (thought I even checked this), but never bothered to set the key to it's original value and now I just stumbled over it.

     

    I'll send you screenshot by E-mail.

     

    Even MS is not always right

     

     

     

    Friday, February 22, 2008 8:08 AM
    Moderator
  • Disabling Volume ShadowCopy Services

    The initial release of Windows Home Server used Volume ShadowCopy Services to support Previous Versions functionality for files stored in Shared Folders on the home server. Windows Home Server triggered a snapshot every 12 hours, enabling users to access previous versions of files stored in Shared Folders on a home server, through the Previous Versions functionality available in some Windows client operating system editions.

    The new media editions of Windows Home Server Power Pack 1 ship with Volume ShadowCopy Services for home server Shared Folders turned off.  If you purchased the initial version of Windows Home Server and upgraded to Power Pack 1, then this feature is still turned on and may take up considerable storage space on your home server.  The amount of space taken up by ‘System’ in the Server Storage pie chart includes the space used by volume shadow copies, which in some cases can be significant.

     

    *       Disabling Volume ShadowCopy Services and reclaiming the disk space

     

    1.     Run mstsc.exe to start a Remote Desktop Connection session to your home server.

    Caution

    Be careful when using a Remote Desktop Connection to your home server. You can damage Windows Home Server functionality if you use it incorrectly.

     

    2.     Open a Command Prompt, Click Start, Run and type CMD

    3.     To delete all of the existing volume shadow copy snapshots and reclaim the disk space used by the snapshots, type vssadmin delete shadows /all

    4.     To disable the Windows Home Server storage manager service from taking future snapshots, type regedit

    5.     Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes.

    6.     Find a sub key which has a MountPoint value equal to D:

    7.     Under that key set the value of SnapPeriod to 0


    WHS OEM patched - 1.6 TB
    • Proposed as answer by NicholasA Friday, July 2, 2010 1:16 PM
    Sunday, March 29, 2009 4:38 AM