locked
Fixed! Unable to start backup service RRS feed

  • Question

  • Hi Gang,

    While running the Beta, I ran into the issue that other's have encountered with suddenly being unable to backup their machines.  I ended up buying the RTM and upgrading the server - but still no joy.

    Some of the other threads mentioned that you have to remove all of your old backups and then re-install the connector software.  I did this but in the end, I had a bunch of files that I was unable to delete due to a connected file handlers.

    Reinstalling the connector software on the client bought me nothing.  Rebooting the server always resulted in the "backup service is not running".

    In the end, the fix was to download a freebie called "Unlocker" from http://ccollomb.free.fr/unlocker/ and then manually remove the file hadnlers and delete the files.  Once this was done - bingo! - all was well in with my homeserver.

    It makes sense that once a lock exists that WHS is going to have problems with whatever machine created the file.  However there should be a way to either remove the lock without having to resort to minor surgery.  I say minor surgery because I've seen where other guys have re-installed the OS to fix this problem.  That's major, major surgery.

    Also since a lot of the clients are wireless, you can expect to have a few files that suddenly are left hanging (not to mention my 4 year old hitting the power button on my desktop). 

    Anyway hope this helps someone else...
    Friday, October 26, 2007 4:16 AM

All replies

  • The WHS toolkit contains an option to completely flush and reset backup database. Didn't get round to testing it yet, but I guess it will work fine. Your situation would have been a very good test, since that would have told us if the cleanup option from the toolkit can also handle messed up reparsepoints (they probably cause the invalid file handle errors)

    Friday, October 26, 2007 7:26 AM
    Moderator
  • I have this same problem and the toolkit didn't work. I get an error that it can't stop the backup service because it is not running. Yeah, like duh. That's why I'm trying to fix it. Kind of a silly error to block it on.

     

    cannot stop whsbackup service on computer

     

    system.componetmodel.win32exception: The service has not been started

     

    For the guy how fixed this manually, what files do I need to delete on the server?

    Sunday, October 28, 2007 10:18 PM
  • It depends whether you want to try and preserve any backups. If not I think you best use the instructions in this thread:

     

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1744726&SiteID=50 

     

    Please read the whole (lengthy) thread, not everybody had to perform all steps listed in the Original Post, and it's certainly informative.

     

    If you want to preserve backups you should checkout eventlogs, these will probably tell you which files are causing problems. The following thread gives you some idea on how to proceed:

     

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=2294698&SiteID=50

     

    If you're not really sure what you're doing try and get assistance from MS. AFAIK The problems with inconsistencies in the backup database is one of the issues that was supposed to be fixed in RTM, so I guess they will be interested in new cases with apparently similar symptoms 

    Monday, October 29, 2007 4:01 AM
    Moderator
  • Ironically (because just a few days ago I posted that I didn't have any database inconsistencies), my server rebooted unexpectedly while I was installing a fax driver, and when it came back up, not only did I have the DBI, but the Backup Service would NOT restart.

     

    And, because it wouldn't start, I couldn't run the database clean up tool in the toolkit.

     

    So I followed your hints, and all worked well - only having to use 4, 5, and 6 of the "ten step method."

     

    Thanks for posting your link - the tool deleted three files I couldn't delete or rename because of "invalid file extensions."

     

    So, yes, your post helped someone else.

    Monday, November 19, 2007 10:49 PM