none
RDPDD.dll failed to load

Answers

  •  

    The problem is with the size of the session image space.  The session image space is shared by the display drivers and printer drivers.  If the sum of the drivers (rdpdd is an additional display driver) gets too big then there is no room left to load.

     

    If you increase the size of the session image space then you can run remote desktop.

    Add the following registry key:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

    "SessionImageSize"=dword:00000020

     

     

    Friday, July 11, 2008 10:10 PM
  • Issue with latest CERTIFIED nvidia driver 175.16 and 175.19

    Roll back to 169.21

     

     

    from

     

    http://blogs.technet.com/brad_rutkowski/archive/2008/01/04/systemroot-system32-rdpdd-dll-failed-to-load.aspx

     

     

    Great info!  I had Nvidia 175.16 driver version as well and could not remote into my PC.  Once I installed driver version 6.14.11.6921 (12/5/07), I was able to remote into my PC.

    Thanks for the help!

    Les

    # re: \SystemRoot\System32\RDPDD.dll failed to load @ Monday, June 23, 2008 1:06 PM

    The Nvidia driver 175.19 released today has no resolution for this issue. My PC is only one of over 300 with Nvidia GeForce 6200 TM (but the only one with XP SP3), RDP is an often used feature. So we must avoid to install/build in this and the former driver over/in our RIS or WDS image for XP with integrated SP3 installations. Thank you NVidia :-(

    Reinhard

    Reinhard

    # re: \SystemRoot\System32\RDPDD.dll failed to load @ Tuesday, June 24, 2008 11:57 AM

    install nvidia drivers 169.21 if you want remote desktop to work, nvidia still doesn't know how to make proper drivers and apparently microsoft doesn't know how to test drivers either.

    silicon

    Thursday, July 10, 2008 4:07 PM
  • I had the same problem. It turned out to be the ATI video driver I installed. I put the XP version on there since I couldn't find one for Server 2003. It seemed to go on and work just fine except for that error which totally prevents you from using RDP. Smile

     

    Friday, September 21, 2007 5:38 AM

All replies

  • Hi,

    Can you try this:

    Start - run - cmd - SFC /SCANNOW

    What you see in your event viewer if the above do not fix the issue.

    My best.
    Friday, September 14, 2007 4:01 PM
  • When i Start SFC /SCANNOW, It keeps asking for the Servicepack 2 CD that i dont have.

    I didnt know there was a SP2 ???

     

    Saturday, September 15, 2007 6:53 PM
  • Hi,

    If you run that from your client pc (as you are now from that popup info), put your OS cd, if from WHS, put the WHS cd.

    But I thought the problem from your client, try the client pc first.


    My best.

    Saturday, September 15, 2007 7:22 PM
  • Hi

     

    I did run it at the WHS box local loged in as administrator. When asks for SP2 CD ill put the WHS CD in and it says this is the wrong CD. Then it asks for the install CD... Works now.

     

    First log:

    The system file c:\program files\common files\microsoft shared\web server extensions\50\isapi\_vti_adm\admin.dll could not be copied into the DLL cache. The specific error code is 0x000004c7 [The operation was canceled by the user.

    ]. This file is necessary to maintain system stability.

     

    Second log:

    Windows File Protection file scan completed successfully.

     

    But stil the same error.

    Application popup: : \SystemRoot\System32\RDPDD.dll failed to load

     

    Sorry but this problem i have is on the WHS box when local logon as administrator and look in the Event logs / system.

    It apears when i make local RDP connection from my laptop or MCE box to the WHS box. All windows firewalls are of (using hardware firewall). It did work perfectly till now... I Installed WHS and leave it running, no extra software installed, auto update is on.

    So my question is: what happend???

     

    Regards

    Sunday, September 16, 2007 10:29 AM
  • Hi,

    That win 2003 server issue and been solved in some update, ok, try this:

    Login to your whs server directly as admin, Start - run - tsadmin.exe

    Click on your server name, then on "RDP-Tcp (listener) right click and reset and in any rdp-tcp# is open.

    Restart the server, and see if that solve the issue.

    My best.
    Sunday, September 16, 2007 7:41 PM
  • Hi,

     

    That i'll tryed all ready. Results : the issue didnt solve.

     

    Regards.

     

     

     

     

    Monday, September 17, 2007 9:02 PM
  • I recently had the same problem with Win 2003 Server R2. What I discovered by trial and error was .Net 3.0 Framework seemed to be the cause. I un-installed it and it worked fine. To test this theory, I installed a freash copy of the OS and installed every update, minus .NET Framework 3.0. I tested RDP to the server and had no problems. I installed the Framework and experienced the same problem - Clients would try to connect and then the connect button would regain focus. Do you have .NET Framework 3.0 installed?

     

    • Proposed as answer by Mulvie Friday, May 1, 2009 1:51 AM
    Wednesday, September 19, 2007 11:15 PM
  • I have Framework 3.0 installed on one of the WHS servers I have set up, and I can use Remote Desktop and the console to connect just fine. So I don't think that's it.
    Thursday, September 20, 2007 2:08 AM
    Moderator
  • Thanks!

    I don't doubt that it may not be the Framework 3.0 in all cases and in fact I have another machine where it works fine, but for this particular install, it seems to be the culprit for whatever reason. I thought it might be something else to try for the originator of the post.

    Thursday, September 20, 2007 12:39 PM
  • Hi,

    Seem like the Hotfix 910362 by Microsoft solve this issue, the problem, I can not find it.

    Maybe you last hope to upgrade to SP2 (if it not installed already, since that a knowing bug tho) or reinstall WHS.

    But better to reinstall WHS.

    My best.
    Thursday, September 20, 2007 4:05 PM
  • I don't think KB910362 is a hotfix for for this specific problem. AFAIK this (RDPDD not loading) is a very rare problem.

    Furthermore hotfixes for very rare problems that have not been fully tested are generally not publicly available. You will have to contact MS to get it, and you'll probably only get it if they are convinced you really need it.

     

    I would try extracting RDPDD.dll from the install DVD or copy it from another machine running WHS / W2K3.. I think Carlma's suggestion is also worth testing.

     

    If this does not solve your problem server reinstall as suggested by abobader is probably your best option.

     

     

    Thursday, September 20, 2007 7:26 PM
    Moderator
  • Hi all,

    Hmm, reinstall WHS wasnt on my list because 390gig of data that after a reinstall unacceseble is.. i still hope there is a fix for this issue.

    Did try to reinstall SP2 or extract the DLL but all no effect... Btw, a view days befor i did got some connection error at the client (Laptop) that says "encryption error, remote desktop will close" then ill start it again... no problem.

    Thanx for all the support so far.

     

     

    Best regards

     

     

    Thursday, September 20, 2007 8:46 PM
  • Looking through the application event logs on your WHS server, do you see where RDPDD.dll begins experiencing failure? Are there any other failures grouped or near the time it begins to fail?
    Thursday, September 20, 2007 8:48 PM
  • I had the same problem. It turned out to be the ATI video driver I installed. I put the XP version on there since I couldn't find one for Server 2003. It seemed to go on and work just fine except for that error which totally prevents you from using RDP. Smile

     

    Friday, September 21, 2007 5:38 AM
  • Hi Aaron,

     

    Thank you my friend... This solves the problem.

     

    Best Regards

     

     

    Friday, September 21, 2007 5:45 PM
  • Thank you so much, I had the same problem for my Windows Server 2003 lab-server and RDP worked after removing the Windows XP drivers for my ATI Radeon 9600 video card.

     

    Anyone found a driver that works with RDP?

     

     

    Friday, September 21, 2007 6:07 PM

  •  Aaron Oneal wrote:
    I had the same problem. It turned out to be the ATI video driver I installed. I put the XP version on there since I couldn't find one for Server 2003. It seemed to go on and work just fine except for that error which totally prevents you from using RDP.

     



    Bought a cheap ATI card to drive a 3rd monitor so didn't care about the drivers and just used the ones that came with XP.  This driver was pretty far down on my list of culprits that was killing my RDP but after upgrading to ATI's drivers it resolved my problem.

    Thanks Aaron!
    Friday, September 28, 2007 3:47 AM
  • Hi Carl,
    your post solved my problem (although WinXPPro, SP2, all updates, no special SW). The funny thing is that I installed four (4) equal PCs side by side !!! and just one got this error. Searched a lot in Forums - but you've got it for me!
    Thanks a lot!!!
    ->
    Friday, November 16, 2007 9:52 AM
  • Issue with latest CERTIFIED nvidia driver 175.16 and 175.19

    Roll back to 169.21

     

     

    from

     

    http://blogs.technet.com/brad_rutkowski/archive/2008/01/04/systemroot-system32-rdpdd-dll-failed-to-load.aspx

     

     

    Great info!  I had Nvidia 175.16 driver version as well and could not remote into my PC.  Once I installed driver version 6.14.11.6921 (12/5/07), I was able to remote into my PC.

    Thanks for the help!

    Les

    # re: \SystemRoot\System32\RDPDD.dll failed to load @ Monday, June 23, 2008 1:06 PM

    The Nvidia driver 175.19 released today has no resolution for this issue. My PC is only one of over 300 with Nvidia GeForce 6200 TM (but the only one with XP SP3), RDP is an often used feature. So we must avoid to install/build in this and the former driver over/in our RIS or WDS image for XP with integrated SP3 installations. Thank you NVidia :-(

    Reinhard

    Reinhard

    # re: \SystemRoot\System32\RDPDD.dll failed to load @ Tuesday, June 24, 2008 11:57 AM

    install nvidia drivers 169.21 if you want remote desktop to work, nvidia still doesn't know how to make proper drivers and apparently microsoft doesn't know how to test drivers either.

    silicon

    Thursday, July 10, 2008 4:07 PM
  •  

    The problem is with the size of the session image space.  The session image space is shared by the display drivers and printer drivers.  If the sum of the drivers (rdpdd is an additional display driver) gets too big then there is no room left to load.

     

    If you increase the size of the session image space then you can run remote desktop.

    Add the following registry key:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

    "SessionImageSize"=dword:00000020

     

     

    Friday, July 11, 2008 10:10 PM
  • Thanks for the registry key! That's what fixed it for me. I was going through one of those "Cascade failure" moments trying to fix another software problem, upgraded the NVidia video drivers, then remote desktop wouldn't work. Aggggg!
    Sunday, July 13, 2008 9:46 PM
  •  

    Thanks for sharing this with us.
    Sunday, July 13, 2008 10:09 PM
  • Thanks for sharing this with us! 
    Sunday, July 13, 2008 10:12 PM
  • Very glad I found this post.  Adding the SessionImageSize key fixed the issue for me!  Thanks all.

    Wednesday, August 13, 2008 11:23 PM
  • I had the exact same problem. I removed .NET Framework 3.0 and it solved the issue.  

     

    Thanks for the tip,

     

    Ray

    Thursday, August 21, 2008 5:42 PM
  • Bingo. Excellent info rtay.
    Searching online for 'SessionImageSize' returns a large number of hits from NVidia and 3D forums that all repeat the same message; set this value to allow RDP sessions to work with certain versions of NVidia drivers.

    Thanks for the info. You've saved me from having to run up and down the stairs in my house ;)
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, September 13, 2008 1:35 PM
  • .NET Framework for me too...
    Monday, December 15, 2008 7:33 PM
  • I know this is an old thread, but I though I'd add this incase someone else runs across it.

     

    A quick fix, rather than rolling back to the previous version is to disable hardware acceleration on the video card, as this is what caused the issue. With it disabled, RDP works fine.

     

    Monday, January 26, 2009 6:54 PM
  •   I agree with you!
    z.ii
    Friday, February 6, 2009 9:32 PM
  • I ran into the same problem with a machine that was working fine until I installed .Net 3.5 sp1.  Why the framework would affect the Remote Desktop service is beyond me???
    Friday, May 1, 2009 1:54 AM
  • Thanks to rtray.  The registery entry fixed up my rdpdd.dll failed to load issue and enabled terminal services on the whs console to now accept basic RDP sessions from machines on the LAN.

    I contribute my issue on a newly installed NVidia 7200GS.  My old 7100 was toast.  Rebuilt the WHS from scratch with the new video card, this is when the issue was discovered.

    Thanks again rtray.
    Sunday, June 7, 2009 10:06 PM
  •  

    The problem is with the size of the session image space.  The session image space is shared by the display drivers and printer drivers.  If the sum of the drivers (rdpdd is an additional display driver) gets too big then there is no room left to load.

     

    If you increase the size of the session image space then you can run remote desktop.

    Add the following registry key:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

    "SessionImageSize"=dword:00000020

     

     


    I was unable to Remote Desktop and Remote Assist.  Comptuers that were having this problem were missing this registry key.  Adding the above solution and then rebooting fixed it. 

    Thank you rtray!
    Tuesday, June 9, 2009 5:30 PM
  • Many thanks to all.  I know its an old thread, but helped greatly.  NVIDEA driver rollback fixed it in a minute after an hour of frustration!
    Wednesday, October 21, 2009 1:31 PM
  • FIX:

     

    1) added the reg key

    2) run sfc /scannow

    3) update to latest nvidia driver

    4) reboot

    5) resolved !!!

    • Proposed as answer by gvekhande Wednesday, June 16, 2010 8:34 AM
    Friday, April 23, 2010 5:47 PM
  • The problem has been resolved by-

    1) Add registry key

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

    "SessionImageSize"=dword:00000020

    2) Copy newer version rdpdd.dll file to C:\Windows\System32\

    3) Start - run - cmd - SFC /SCANNOW

    4) System Restart


    Wednesday, June 16, 2010 8:37 AM
  •  

    The problem is with the size of the session image space.  The session image space is shared by the display drivers and printer drivers.  If the sum of the drivers (rdpdd is an additional display driver) gets too big then there is no room left to load.

     

    If you increase the size of the session image space then you can run remote desktop.

    Add the following registry key:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

    "SessionImageSize"=dword:00000020

     

     


    It's works for me =)

    Thaks a Lot! ;-)

    Thursday, November 4, 2010 12:31 PM
  • Had similar issue not being able to RDP to my WHS (w2k3 x86 server) machine, guessed it was due to updates as had not changed anything on the box.

    Event viewer showed one of three following errors on each reboot.

    Cannot load illegal module: C:\WINDOWS\system32\TSDDD.DLL

    Cannot load illegal module: C:\WINDOWS\system32\Drivers\rdpwd.SYS

    Cannot load illegal module: C:\WINDOWS\system32\Drivers\tdtcp.SYS

    Tried all of the above suggestions in this thread and nothing worked. After checking on what the latest updates had been installed on my machine by sorting on the directories in C:\Windows\ this one was the culprit, $NtUninstallKB2653956$. MS have a fixed to address the issue caused by this hotfix.

    http://support.microsoft.com/kb/958476

    After applying this it fixed my RDP issues.

    Saturday, April 21, 2012 6:24 PM