locked
CRM 3.0 Database does not upgrade to 4.0 RRS feed

  • Question

  • Hi All

    I have a problem upgrading two CRM applications to CRM 4.0.

    I have two CRM 3.0 Application on 2 seprated server. (Because CRM 3.0 does not support multi organization)
    I call them CrmApp1 && CrmApp2  on  AppServer1 && AppServer2.

    Both databases are on a same server called "DBServer".

    at the first step, I Upgraded the CrmApp1 on AppServer1 To CRM 4.0. Everything is OK. Application and its related database upgraded successfully.

    Then I tried to Upgrade the CrmApp2 on AppServe2.  At the last Step of the Setup Wizard all settings shown for the setup is correct, including database, metabase , DatabaseServer,ReportServer,  etc.

    But it upgrades ONLY the application on AppServer2 and connects it to the previously upgraded DB (I mean DB of the CrmApp1).
    DB of the App2 is NOT upgraded and has NO change!!! When I open the localhost:5555 on the AppServer2, it opens the CrmApp1 !!!!!

    In the Organization Table of the MSCRM_CONFIG Database, there is only one row named CrmApp1.
    How can I upgrade the second application?

    any idea?

    Thanks in advance.
    Javad Asadipour

    Saturday, January 30, 2010 7:01 AM

Answers

  • Hi Javad,

    i would try the following. Install the secend crm3 in a different sql-server and make the update of the database on the secend server. After the update, save the database and restore it on the frirst sql server. Then start the deployment manager and import the secend database in crm4.
    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Saturday, January 30, 2010 7:46 AM

All replies

  • Hi Javad,

    i would try the following. Install the secend crm3 in a different sql-server and make the update of the database on the secend server. After the update, save the database and restore it on the frirst sql server. Then start the deployment manager and import the secend database in crm4.
    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    Saturday, January 30, 2010 7:46 AM
  • Hi Michael,

    It seems working.

    Thank you very much, I've never get an answer as soon as this one!

    Thanks again,
    Javad Asadipour






    Saturday, January 30, 2010 8:10 AM