WHS 2011 Server Backup Fails on \$Extend\$RmMetadata\$TxfLog\ access denied RRS feed

  • Question

  • This was discussed in a related topic in May, however no satisfactory resolution was recorded. My symptoms are as follows:

    I have backups scheduled to run at 12:00 PM (noon) and at 11:00 PM. This is outside the client backup window from 12:00 am (midnight) to 5:00 am. The client backups are running successfully and most of the server backups are also running fine, except that every 2 or 3 cycles, I receive an error saying that some files were missed. The Windows Application log contains the error below and when I investigate, I find that the file containing the missed files contains files named $Extend\$RmMetadata\$TxfLog which seem to be part of the transactional file system. This wouldn't be too bad, except that the next backup after this event is detected takes about 12 hours to complete, it's as if a whole new baseline is needed.

    I"m running a home build WHS 2011 server running on a Gigabyte H57M-USB3 motherboard using an Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz and 8 GB of memory. I run 4 2 TB hard drives, 2 are Seagate ST3200542AS drives and 2 are Western Digital WD20EARS drives. The operating system is installed on one of the Seagate drives.

    Does anybody have any suggestions how I can continue to run scheduled server backups but avoid having every third or fourth backup damaged by failed attempts to access these files?


    Error in backup of H:\$Extend\$RmMetadata\$TxfLog\ during write: Error [0x80070005] Access is denied.
    Error in backup of H:\$Extend\$RmMetadata\$TxfLog\$TxfLog.blf during write: Error [0x80070005] Access is denied.
    Error in backup of D:\$Extend\$RmMetadata\$TxfLog\ during write: Error [0x80070005] Access is denied.
    Error in backup of D:\$Extend\$RmMetadata\$TxfLog\$TxfLog.blf during write: Error [0x80070005] Access is denied.


    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-Backup" Guid="{1DB28F2E-8F80-4027-8C5A-A11F7F10F62D}" />
      <TimeCreated SystemTime="2011-10-18T01:19:48.729440000Z" />
      <Correlation />
      <Execution ProcessID="4192" ThreadID="3888" />
      <Security UserID="S-1-5-18" />
    - <EventData>
      <Data Name="BackupTime">2011-10-18T01:13:57.167222500Z</Data>
      <Data Name="FailedVolumeNames">H:,D:</Data>
      <Data Name="BackupFailureLogPath">C:\Windows\Logs\WindowsServerBackup\Backup_Error-17-10-2011_22-13-57.log</Data>

    Tuesday, October 18, 2011 12:17 PM

All replies

  • Unfortunately, I have been struck with these as well. I will get ridiculously long backup times, like 3-4 hours, and the disk space of the backup only increased by a 100 MB. In other words, nothing really changed from the previous backup, yet it takes forever. Sometimes the backup finishes successfully, other times I get a message about how some items were missing, but returned status is something like: 0 (!!). Probing thru the log files in c:\windows\logs\windowsserverbackup I find some log files. On the unsuccessful backups, I get similar messages as above, but only for one of the data drives that I am backup up (E:). It happens to also have the client backup databases, so maybe that is part of the problem??


    Error in backup of E:\$Extend\$RmMetadata\$TxfLog\ during write: Error [0x80070005] Access is denied.
    Error in backup of E:\$Extend\$RmMetadata\$TxfLog\$TxfLog.blf during write: Error [0x80070005] Access is denied.

    Monday, November 7, 2011 8:17 PM
  • Same here, I've been having this issue from the beginning and see the exact same errors when I logon to the Windows Server Backup Console.

    (You don't get to this level of error description from the WHS Dashboard).

    In my situation, it happens once every 1-2 weeks, so less often, but still the next backup after the error takes forever.

    I've never found a way to explicitely exclude those files as they are reserved by the OS somehow.

    Would love to solve this too.

    Thursday, November 10, 2011 12:47 PM
  • It is indeed quite puzzling. Reading up online, it seems like there is an alternating "full" and "incremental" backup schedule. In my case, the "full" backup takes many hours to run, even though very little data has changed. Perhaps this is just what it does, and it shouldn't bother me. The long backup always completes successfully. The quick "incremental" backup is the one that completes with the above errors. I happened to be looking at the dashboard this morning as the "incremental" backup was completing, and the status went from "finishing backup" to "successful", then flashed to "unsuccessful". I am inclined to believe that the backup was successful, but there is some sort of glitch at the end. I'm a home user, not a server administrator, so don't know where to look from here.

    When I look at the Windows Logs under System, I consistently get a FilterManager Error (Event ID: 3) right when the backup finishes: Filter Manager failed to attach to volume '\Device\HarddiskVolume10'. The volume will be unavailable for filtering until a reboot. The final status was 0xc03a001c. Have absolutely no idea what this is, as it occurs consistently at the end of every backup, whether reported as successful or not (ie. it occurs at the end of both the "full" and "incremental" backups).

    Friday, November 11, 2011 3:14 AM
  • +1 on this. Exactly the same symptoms. Fails on incremental backup. Manual backup always succeeds. Full backup (which always seems to be done following the unsuccessful incremental backup) always succeeds.

    Looks like many people have the same problem. Come on Microsoft, please fix this as it is obviously a bug!

    Tuesday, November 22, 2011 8:57 AM
  • Interesting observation. I changed my backup device from being a 2TB External USB 3.0 hard-drive (Seagate GoFlex) to an internal 2TB SATA hard-drive. Since switching, I have not had any unsuccessful backups. I don't know how to differentiate between the supposed "full" and "incremental" backups. I run the backup once a day at 10:30am. They pretty much all take about 2-1/2 hours to complete, even though next to nothing has changed in the data being backed up. This is confirmed as the backup drive is only incrementally increasing in utilization. Could it have something to do with the external hard-drive?? Maybe it appears disconnected at some point to the backup program. I did notice that when the errors occurred, the job would finish with successfull, then a second later flash to Incomplete.

    Wednesday, November 23, 2011 1:32 AM
  • The difference between full and incremental backup can, in my situation, be easily identified by looking at the backup times.
    When everything runs fine, the backup time is less than 10 minutes and I consider this the incremental backup.
    Most of my backup times are that short. 
    When all disks fail with the above mentioned error, the total backuptime for my set is 7 hours, as it does full backup after failure apperently.
    When only 1 disk fails, the backup time is shorter.
    Maybe your system somehow never gets to doing the incremental?

    My backup drive is also on a USB (2.0) connection, maybe there is some issue with external (USB) drives and these special system files.
    The most obvious solution would be to exclude them from backup, I can't think of a reason those file system log files would be needed in case of a restore.
    However the UI doesn't let you do that.

    Wednesday, November 23, 2011 8:09 AM
  • Once I moved to the internal drive, I have not had any failed backups. Looks like an issue with the external drive. Not sure why it doesn't like my USB 3.0 connection, and why only every other one is reported as failed (even though it appears to have backed up okay).
    Tuesday, November 29, 2011 9:30 PM
  • I too have seen similar errors when using a USB 3.0 drive for Server backups which went away again when, in my case, I reverted back to using an internal SATA or an external eSATA drive. I agree the backups appear fine even though an error is generated. In one instance, at the end of a backup I momentarily received a Red Alert that a backup drive was not connected and then it reverted to a "Successful" status.

    Has anyone provided feedback to Microsoft via Connect?


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Wednesday, November 30, 2011 12:56 PM
  • Similar server backup errors here. I rotate two 2TB USB3 external drives, using the same specifically designated drive  each Monday  for offsite storage.

    The cited error occurs only on the first backup when I return the offsite drive to the server.

    This has happened since May, I believe. Several times I've needed to access a file from one of the backups, which I did with no problem.

    Monday, December 5, 2011 3:58 PM
  • Sigh +1 on this.

    I'm currently running backups from my new HP MicroServer to a WD SES drive over USB 2.0 and seeing this. This happens on every other backup for me (the nightly...which may overlap the client backups)...we'll try that first.

    This error has been reported multiple times with several suggestions but nothing definite:

    - Move the server backups outside the PC client backup time window (this will be my first attempt)

    - Move off of USB to SATA...I have an eSATA dock on order that I'll try next.

    - Manually run backups from administrator instead of scheduling (this seems like a pain...same as WHS 1.0)...if this works I may try to schedule the backups using the admin account.

    Every time the system does the full backup it takes several hours...the HP uServer is nice (but not fast).

    Never had this problem with WHS 1 :)

    • Edited by jmbraben Thursday, December 8, 2011 2:22 AM
    Thursday, December 8, 2011 2:12 AM
  • All,
    I am going to bolt my comments onto this thread to get them "in front" of Microsoft ... feel free to tell me to post to my own thread if you don't think that they relate.
    First up, Geoff Coupe has done a lot (and I mean a lot) of work documenting WHS 2011 issues. My system operates similar to his (unfortunately). He has a backup related blog here that details similar backup issues to what you are discussing:
    My latest concern is ...
    I don’t understand why backing up my WHS 2011 C:\ (system) drive (28GB) and my D:\ (client backups) (202GB) – a total of 230GB … uses 700GB on my Server Backup drive. I thought that the client backups were incremental backups (from my understanding of V1 … each daily backup just stores the differences from yesterday – and additionally common files between client computers are only backed up once – which explains why the client backup is so small)?

    Any comments welcome ...


    Saturday, December 10, 2011 8:58 PM
  • Update on this.

    I moved the server backup outside the PC client backup time window, and at first did not seem to make a difference, but than all was good after a few days.

    But then I had to start playing around a few weeks later, and the problem recurred. I'm not sure what action triggered it, but I'm thinking one of the following:

    - Unmount/Remount the backup drive (doubtful)
    - use Windows Server Backup recovery dialog via RDP to look for a file to recover (more suspicious).

    I'll see if it "calms down" again and if I can duplicate it with one of the above.


    Wednesday, January 11, 2012 2:31 PM
  • Aussie,

    Looking at server backup details within a console, here's my information.

    After 40 backups, I'm only using 30.6Gb for incremental data...my guess is that backing up your client backups is the problem...as these client backup files are monolithic and change with each backup, that is where all of your incremental data is coming from (I don't backup the client backups).


    Wednesday, January 11, 2012 2:40 PM
  • Yeah ... I concur ... but the Server Client backup of all my clients is also incremental (it saves files every day) ... and the total is ~300GB. It irks me that because of the method that is apparently used on the server, (pretty much) every server client backup file is updated every day ... So the Server Backup, in dong incrementals of the incrementals, really seems to burn space.

    One alternative; on V1, I would manually copy all of the files to an external drive ... and many hours later ... I would have a "Server Backup" the same size as the client backup.

    I postulate that MS has "fixed" this (hours of copying) by doing incremental backups ... so the backup only takes a short period ... but it burns space like it is going out of style because every file changes every day. And it burns up the whole backup disk ... which then releases warnings like it is going out of style ... If this is all a good idea ... (rhetorically now) why do I get warnings?

    I guess that better minds than mine have deduced that this is a good thing! But I feel the WHS 2011 is more complex than V1 ... and less user friendly. Lets hope the next update makes it a lot, lot better.

    Friday, January 13, 2012 2:15 AM
  • Since I didn't have the Intel Storage drivers installed, but was running from the default Sata drivers, I thought this might bring a possible solution in my scenario.

    It didn't help. After installing the Intel Storage drivers, I still every now and then get this error on the incremental backup.

    It mostly fails for all of my (4) External Sata drives and not on the system drive.

    So I'm still in the same situation hoping Microsoft will check in to this thread and provides some suggestions.

    Wednesday, February 15, 2012 1:46 PM
  • Another victim of the

    Error in backup of E:\$Extend\$RmMetadata\$TxfLog\ during write: Error [0x80070005] Access is denied.

    I was hoping that the Update 2 for WHS 2011 may have done something under the covers that meant this error would go away. Sadly there is no change after the update - after the update my backup this morning failed as usual!!

    • Edited by Daedelus Thursday, February 16, 2012 9:35 AM
    Thursday, February 16, 2012 9:35 AM
  • I have been fighting the server backup issue for months.  I started with an external USB 2.0 drive and every few days got errors.  I then switched to a hard disk in an external enclosure using eSATA.  Same result.  Usually the message is One or more selected items were not included in Server Backup....  The scheuled backup did not finish successfully and returned the following error code: 0.

    I move the nightly backup to 2:30 AM since my client backups start at 12:00 AM.  Didn't help.

    It's obvious there is a problem in the Microsoft software.  I don't understand why MSFT takes so long to address these type of issues when multiple people on multiple forums post the same issue.

    Microsoft: Please focus on getting this fixed!  Isn't this a basic function that the server should perform?  Kind of like going to a bakery and being told they don't make bread.  Fix this please!


    Saturday, March 31, 2012 2:44 PM
  • Has anyone posted this on the Connect Site?
    If this bug was filed where others could add comments, files and information it would be addressed better than the forums.
    Saturday, March 31, 2012 4:10 PM
  • Don, there are multiple posts on the Connect Site.



    Saturday, March 31, 2012 4:28 PM
  • Can you point me to the connect bug links please?
    Saturday, March 31, 2012 6:09 PM
  • Automatic Backup Failed With Errors With No External Alerts | Microsoft Connect:


    WHS 2011 - Server Backup did not finish | Microsoft Connect:


    I see two both closed.  Got any active ones?

    Saturday, March 31, 2012 6:28 PM
  • Here's one, although it is closed.  Closed doesn't mean it's solved, right?



    Saturday, March 31, 2012 6:34 PM
  • Correct.  Both of those are "gee we can't fix it" closed.
    Saturday, March 31, 2012 6:42 PM
  • I know but all of those are in the forum and we're not getting the people's logs and cases to Microsoft.  I've got an email into Microsoft, let me see what log files they need.
    Saturday, March 31, 2012 7:09 PM
  • Thank you Susan.  I/we all appreciate your help.  You make a difference.



    Saturday, March 31, 2012 7:12 PM
  • Same problem here.

    Error in backup of E:\$Extend\$RmMetadata [...] access denied [...]

    But I don't care anymore because this is just one more problem about WHS 2011 backups, after fighting more than a month trying to "correct" those WHS 2011 backup limitations (GPT, 2TB, single disk etc etc etc...) and bugs (client & server backup failures, connector installation failures after full barebore recovery, hardware changes (NIC) client not recognized etc etc etc...) I decide not to rely on the poorly implemented WHS backup feature and go third party. Actually, almost everything in my WHS 2011 box is third-party: media streaming (Mezzmo), backup (Acronis, second copy), antivirus (ESET),  etc... For the price one pays for WHS don't expect Microsoft to correct or improve this product promptly... 

    Good luck WHS fellows!


    Thursday, April 19, 2012 4:08 PM
  • I have had similar issues and they were all due to another pc in the network accessing one of the files in the Client Computer Backup folder.  When the file is being accessed it is write protected and the backup can not complete, hence fails with various error messages.  To confirm this is the issue stop accessing client computer backup files and do a manual backup.  If it works that is your issue.

    Night Owl

    Monday, April 30, 2012 1:17 AM
  • Hi, Bernhard

    For the E: volume, your active backup policy will backup the whole volume or you just selected some folders in the volume?

    Best Regards,


    Wednesday, May 2, 2012 9:36 AM
  • I found this on Microsoft Connect under


    I am testing it now.

    Posted by Microsoft on 5/30/2012 at 7:30 PM

    “The device is not ready” issue reported here is caused by less space to create Shadow Copy on volume.
    It is solved by increasing the shadow copy maximum size in the impacted volumes. After trying it, there is no such issue reported from customer.

    Best wishes,
    Windows Home and Small Business Server Team

    Saturday, June 2, 2012 7:56 PM
  • I have been testing Windows Server 2012 Beta and started to get the same error. There appears to be a solution at the end of this thread (not fully tested it yet and I assume it is also applicable to WHS2011):


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Thursday, August 23, 2012 12:35 PM
  • My server backups began failing after I installed a 2T Seagate AF drive.  After much teeth gnashing, I discovered it was Advanced Format, which has physical sector sizes that are incompatible with the virtual drive system. (There is a blog posting that explains the incompatibility in detail.)  I installed a Western Digital 2T drive with the smaller 512K physical sectors as the server backup disk.  My server backups again work properly. 
    Monday, August 5, 2013 3:46 PM