locked
CRM 2011 IFD + TMG 2010 Some links do not work from first click RRS feed

  • Question

  • Hi colleagues.

    I have annoying problem: some links in CRM website don not work from first click, user should click again to open Organization or Lead form. I'm sure that problem appeared after IFD configuration. After Claims-based Authentication configuration everything was OK. I suspect TMG 2010 used for CRM websites publication as a root of problem but can't determine necessary troubleshooting steps. Did somebody face same problem and can share some fix?

    Thanks in advance,

    Denys Shevchuk

     


    MCSA
    Tuesday, August 30, 2011 2:36 PM

Answers

  • My client faced the same need to click twice as well as a bigger concern that Save and New of any entity, such as Contacts, returned an empty page.  We are publishing through TMG but not using IFD in our scenario.  Diagnosing with Microsoft Support, they identified the issue as compression related and gave the following solution:

    1. Delete the existing CRM rule
    2.  Create a New Exchange Client publishing rule and set the rule to use OWA for Exchange 2007
    3.  Once the rule is created, remove the default paths in the rule and added a new path “/*”
    4. Go to Web Filters and disable the “compression filter” and “caching compression filter
    5. Apply the changes

    These changes fixed the Save and New issue as well as the need to click twice.  My understanding from MS Support is that the CRM 2011 compression is better, so you should use it instead of TMG 2010 compression.

    We also see the same issue for some of the client's internal locations due to Riverbed WAN Optimization, which we are still diagnosing.  But it seems that CRM 2011 does not completely get along with other compression and optimization on the network.  We had CRM 4 running in the same environment and did not experience these issues.

    Let me know if this helps or you find another solution.

    Regards,

    Kevin Feit

    www.capgemini.com

     

     

     

    • Marked as answer by Jim Glass Jr Tuesday, September 20, 2011 2:46 PM
    Tuesday, September 20, 2011 1:42 PM

All replies

  • I got a same problem. Looking for a solution:)
    Wednesday, August 31, 2011 2:15 AM
  • I got it working.  Here is my scenario:

    • CRM and ADFS are installed on different servers (binding IIS related websites to 443).
    • I made sure internal CRM was working
    • I created three Web Site Publishing rules on TMG for CRMorg.contoso.com (URL defined on IFD wizard), auth.contoso.com and adfs.contoso.com
    • Done.

    Hope that helps,

    G

    • Proposed as answer by Eric__1 Thursday, September 15, 2011 7:07 AM
    Friday, September 2, 2011 9:12 PM
  • Hello,

    Eric, I see that you proposed last message as answer. Have you got some success? Can you provide you troubleshooting steps?

    Thank you,

    Denys

     


    MCSA
    Thursday, September 15, 2011 1:05 PM
  • Hi Denys,

    1. Need to create four dns records(orgname, adfs, auth and dev) in your external domain which points to the TMG server.

    2. You need to create four Publishing rules in TMG(Orgname.domain.com, adfs.domain.com, auth.domain.com and dev.domain.com) which should be perfectly redirect to CRM and ADFS server.

    3. You need to enable the ports 443 and the other ports in Router and in CRM Server.

    Once these steps are perfectly done, you can able to access the CRM through internet.

    Please check this threat it might be helpful for you

    http://social.msdn.microsoft.com/Forums/en-US/crmdeployment/thread/91b3a08e-d6e5-414b-9474-c25c05de4d66

     

    Mark as Answer if you find this as helpful.

    Regards,

     


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    Thursday, September 15, 2011 1:35 PM
  • Hi Khaja,

    Went trough your post and link you gave me, but no result. My bet is that something wrong with only one rule in TMG: publishing Organization website.

    My configuration for this rule:

    HTTPS-Listener certificate for crm.domain.com and no auth
    Web Server Publishing rule with following options:
         i. Bridging: redirect requests to SSL Port 443
         ii. Link translation disabled
         iii. paths: /*
         iv. Auth delegation: No delegation, but client may auth directly
         v. To: internalcrm01.domain.local, forward host header, requests appear to come from the Forefront TMG computer

    And as result, nothing happens from first click when I click account record and another one gives result:

    When I do not use TMG for publishing CRM organization - everything is OK.

    Any suggestions will be appreciated!

    Thanks,

    Denys Shevchuk


    MCSA
    Tuesday, September 20, 2011 8:26 AM
  • Hi Denys,

    Please check this blog for Web Publishing rule for CRM 2011 in TMG.

    http://www.dynamicsexchange.com/Blogs/user.aspx?Tableid=285

     

    Regards,


    Khaja Mohiddin|||||http://www.dynamicsexchange.com/
    Tuesday, September 20, 2011 12:06 PM
  • My client faced the same need to click twice as well as a bigger concern that Save and New of any entity, such as Contacts, returned an empty page.  We are publishing through TMG but not using IFD in our scenario.  Diagnosing with Microsoft Support, they identified the issue as compression related and gave the following solution:

    1. Delete the existing CRM rule
    2.  Create a New Exchange Client publishing rule and set the rule to use OWA for Exchange 2007
    3.  Once the rule is created, remove the default paths in the rule and added a new path “/*”
    4. Go to Web Filters and disable the “compression filter” and “caching compression filter
    5. Apply the changes

    These changes fixed the Save and New issue as well as the need to click twice.  My understanding from MS Support is that the CRM 2011 compression is better, so you should use it instead of TMG 2010 compression.

    We also see the same issue for some of the client's internal locations due to Riverbed WAN Optimization, which we are still diagnosing.  But it seems that CRM 2011 does not completely get along with other compression and optimization on the network.  We had CRM 4 running in the same environment and did not experience these issues.

    Let me know if this helps or you find another solution.

    Regards,

    Kevin Feit

    www.capgemini.com

     

     

     

    • Marked as answer by Jim Glass Jr Tuesday, September 20, 2011 2:46 PM
    Tuesday, September 20, 2011 1:42 PM
  • Thank you Kevin for sharing your solution. It fitted exactly to my case!

    MCSA
    Wednesday, September 21, 2011 7:07 AM
  • Good morning!

    Regaring the Publishing I have some updates. Justs posted an summary of findings from the last days!

    Hopefully we get an fix from Microsoft soon, as this topic is coming up to an bad performance issue with no real workaround.

    http://dynamics-crm2011.blogspot.com/2012/01/tmg-2010-or-isa-or-ans-kind-of-reverse.html

     

    We have taken some networktraces an found out the following!

    It is an BUG in Dynamics CRM 2011. Everytime when the CRM Webserver

    receives an request including an "reverse proxy header" it answers with

    Cache-Control: public
    Vary: *

    to the response header. This“Vary: *” is causing the behavior that some CRM Page elements are not used out of the Internet Explorer Cache.

    We fixed this for one customer with creating a new ISA/TMG rule “Server publishing on Port 443” instead of using an Web publishing rule. But this can´t be the real solution due to security reasons!

    Cheers

    Christian

    Tuesday, January 24, 2012 10:19 AM
  • Please look at the solution in my blog post here below

    http://social.microsoft.com/Forums/en/crmdeployment/thread/c4cfb0cd-772c-4a20-8c48-495c6c6d39a7

     


    Thanks and Regards Suraj Singh My blog: http://blogs.technet.com/b/sooraj-sec/
    Friday, January 27, 2012 10:33 PM