none
Live Writer replace Quotation marks with "

    Question

  • Hello!
    I have a blog (http://spotterblog.de) with wordpress and i use live writer to publish to it. It's more conviniend then writing in the Wordpress Editor.
    In Wordpress you can install plugins. I have one vor Text in two columns. In Order to use the Plugin I have to insert "Smarttags"
    But if i insert the Smarttag which looks like this in the Code / html Window in Live Writer
    [column width="47%" padding="6%"]
    Column 1 content goes here.
    [/column]
    [column width="47%" padding="0"]
    Column 2 content goes here.
    [/column][end_columns]

    It will be changed in something like this after switching in any other view than the code view.
    [column width="47%" padding="6%"] Column 1 content goes here. [/column] [column width="47%" padding="0"] Column 2 content goes here. [/column][end_columns]
    The quotation marks are being replayed by " and as a result the Plugin does not work because the tag is not recogniced.
    I tried to change something in the options of live Writer because there are some points where are options to replace characters. But it doesnt help.

    Does someone have a solution?
    Sunday, April 5, 2009 10:13 AM

All replies

  • Hi flieger28,

    What version of Windows Live Writer are you using? (Help | About | Show log file)
    Wednesday, April 8, 2009 1:11 AM
    Owner
  • Hi flieger28,

    What version of Windows Live Writer are you using? (Help | About | Show log file)
     Joe, I'm having the same problem and it's the only thing between having the ultimate code plugin and WLW integration. The auto replacement of " with " is the only thing that breaks http://wordpress.org/extend/plugins/wp-synhighlight. I can go into PHP and try to decode_entities first, but it's an unneeded hack really.
    I'm using the latest WLW version 14.0.8064.206.
    Thursday, January 7, 2010 12:47 PM
  • You might try changing the markup style from "Default (XHTML)" to "HTML" (or vice versa if it is defaulting to HTML). It might or might not work--I'm not sitting near an instance of Writer to try it. If not, I think you might be out of luck other than handling it on the server side... sorry...
    Thursday, January 7, 2010 11:19 PM
    Owner
  • the latest version 15.4 has an option replacing quotmarks with &quot that's defautly on. you may want to switch it off.
    Saturday, June 11, 2011 2:25 PM