locked
Could not initialize UI subsystem RRS feed

  • Question

  •  

    Yall

     

    Bought 2 WHS sfwr and attempted to install on my Dell poweredge 6300. Config is as follows:

     

    SCSI disks - primary disk is SCSI ID 0 on mother board's controller

    DVD is HP SCSI DVD on separate controller

    Tape drive on same controller as DVD

     

    Boots to DVD correctly, then begins the install. After the little dialog box with progress bar, it gets interrupted with this Could not Initialize the UI subsystem.

     

    Both brand new medias yield the same issue and this is very frustrating.

     

    Tried to install my Server 2003 R2 and all went through OK ...

     

    What is going on here???

     

    Even tried to copy my DVD to a -R media in hopes it would be the format that is being rejected (which ougth not to be the case since WS03 R2 installs correctly) to no avail .. still the same error.

     

    H E L P

     

    AR

    Saturday, July 12, 2008 12:11 AM

Answers

  • My total storage is just over 600gb and am using it mainly for backing up 4 other computers and as a RAW photo file server. The RAW files rarely exceed 20mb in size. Will try doing another load when I get back home and will still make a video of how it flys.

     

    Mark

     

    • Marked as answer by ARosenthal Tuesday, September 9, 2008 6:03 PM
    Friday, July 18, 2008 1:54 PM

All replies

  • Same problem over here.

    Help appreciated!

    Bjorn

     

    Saturday, July 12, 2008 4:52 PM
  • I had this same problem!!  I have two servers... A Dell 2450 and a Dell 2650. Originally I was using the 2450 without any problem at all, loading WHS was totally normal. I later found out when the 2650 arrived that WHS would not load into it normally and I got the same message you did. I believe this is a driver issue where the driver for the 2650 is not on the WHS DVD but where the driver or equivelent file for the 2450 IS on the DVD or may simply reside on the 2450 server MB itself. I was going to get rid of the 2450 because the 2650 is quite a bit better server but what I do is use the 2450 to load WHS onto the drive... so for now I'm keeping the 2450 just in case I need to re-load WHS. At any rate after WHS is loaded on a drive in the 2450 I remove the drive from the 2450 and install it in the 2650. There is a bit of time and a few necessary re-boots where it automatically sees the change in servers and loads in the proper drivers for the 2650. After that and normal activation it runs just fine. Then I add in the other 4 drives. The reason I believe its a driver issue is because when you load Windows 2003 Standard Server OS onto any piece of hardware it prompts you almost immediately to press F4(I think) to load a driver for your SCSI or RAID sub-system... WHS doesn't present the opportunity to load this very necessary SCSI driver.

     

     If anyone knows another workaround for this issue please let us know as then I can send the old 2450 out the door.

     

    P.S. If you are near Salt Lake City I'd be happy to load it on your HD for you with my 2450. Then you can just slap the drive into your 6300. 

     

    Mark

    Thursday, July 17, 2008 12:28 AM
  •  I did a little more searching on the WHS forum and Ken Warren posted this back in 2007 because of the same problem....

     

    "If you need to use F6 to install drivers, you will need two sets of drivers for WHS. You'll need Vista drivers the first time you're prompted for them, then the second time you'll need W2K3 drivers the second time."

     

     Now I have to confess that in loading WHS I was never presented the opportunity to press F6. So I'm not sure what he means exactly. Ken... If you're out there reading perhaps you could clarify if there IS a time during load that we can press F6.

     

    Thanks!

    Mark


     

    Thursday, July 17, 2008 12:43 AM
  • Ken sees all...

    When you install Windows Home Server, you insert the DVD and reboot. Setup goes through a hardware detection exercise and lets you add storage drivers (it turns out that you can use Windows Server 2003 drivers; I was but an egg when I wrote that). You get warned that WHS will wipe your disks if you proceed, you click through without reading, panic when you realize that you forgot to move your MP3 collection off that drive and 5 years of illegal downloads have just vanished into the bit bucket but it's too late so you hope that your wife doesn't realize that her Yanni MP3s are also gone and ... <SMACK> ← (sound of L.A.R.T. (go ahead, look it up, we'll wait) hitting forehead) ...

    Sorry, I'm better now. Where was I? Oh, yes. So you install the drivers in the initial graphical portion of setup, and click through the warnings. Then your proto-server reboots. (You did leave the DVD in the drive, didn't you? Bad Things™ can happen if you don't.) This first reboot takes you into text mode setup for Windows Server 2003. At the beginning some prompts appear at the bottom of the screen. One of these prompts is "Press F6 if you need to install a 3rd party SCSI or RAID driver" (IIRC, I haven't done that for a week or two, and I don't pay attention to those prompts any more). You have to watch carefully or you'll miss it, as it's only visible on screen for a few seconds. You press F6 and Bob's your uncle.
    Thursday, July 17, 2008 2:18 AM
    Moderator
  • Right now I am trying to install it using Virtual PC and then restore it on a scsi drive; then I will try to start the 6300 with this disk and see what happens.

     

    I cannot believe this is happening. BTW, the specs ask for 60-70GB .. what is the actual size of your image at the 2450?

     

    AR

    Thursday, July 17, 2008 2:22 AM
  • Sorry it does not. In my case, I get the bios call to press any key to boot from cd, then it goes into loading with the black background and a progress bar, right after that it jumps to a mimic of Vista splash, and then it gets into the progress bar that yields the dialog mentioned. I could press F8 at the black background and get the menu options, but F6 goes nowhere.

     

    What you are describing is WS03's loading, not WHS.

     

    Thursday, July 17, 2008 2:27 AM
  •  Ya know I never checked the actual size of the image itself. But I know the finished image is not really all that large. I think you need the extra space when loading WHS so there is room to load extra stuff to complete the process... at the end of the load alot of that stuff is cleaned off of the drive and you're left with a lot smaller image thanwhen you started out. 

     

     I have an extra 146gb SCSI drive so I'll try it again when I get back home as per Kens suggestion... but I'm pretty sure I did trying re-booting the 2650 at load and it was still not sucessful... all I remember was the crawler thingy. What I may do is video off the monitor at the start of installation and put it up on You-Tube so you can all see what happens.

     

    Mark

     

    Thursday, July 17, 2008 3:46 AM
  • Just note that although Microsoft say that 80GB is the minimum, you really should be using a system disk at least 300GB, or even more if you intend moving large files, (video etc.), to the server. Also, a few have found that although they have an 80GB disk, when it's formatted, it ends up just too small for WHS to install.

    There really is two options presented to install the drivers required, during the graphical portion and then again during the text portion. This second time is VERY short, goodness knows why it couldn't have a pause built in, but it is short! The best approach appears to be keep pressing F6 during the start of the text portion as a least a number of users have had to redo the installation a few times to catch it.

    As WHS is built 'on top' of Server 2003, the drivers to use, if you can are server 2003 versions. XP versions can do at a pinch, but don't forget this is a server for your valuable data, and you want stability above all else.

     

    Colin

     

    Thursday, July 17, 2008 10:15 AM
  • My total storage is just over 600gb and am using it mainly for backing up 4 other computers and as a RAW photo file server. The RAW files rarely exceed 20mb in size. Will try doing another load when I get back home and will still make a video of how it flys.

     

    Mark

     

    • Marked as answer by ARosenthal Tuesday, September 9, 2008 6:03 PM
    Friday, July 18, 2008 1:54 PM
  •  

    Solution: 

    There are a lot of systems out there where the special, "friendly" installer for Windows home server will crash before it even gets to an option to install drivers.  Yes, I was able to get it to run ok by setting my disk configuartion to AHCI isntead of RAID, but there is no excuse for not supporting RAID on a server system, when it works fine on Client machines.  Bad Microsoft, bad!

    Here is how you get around this.  We are going to bypass the "friendly" installer, and go straight to the real Server 2003 installer. 

    Using a working computer (not the WHS one),   Copy the Server2003 folder on your WHS DVD to your computer's hard drive.  Download Nlite from their website www.nliteos.com which is a free tool for customizing your windows installation. 

    Run Nlite and tell it to use the folder you copied in the last step as it's source. 

    Don't import any sessions, click next. 

    Choose options 3 and 8 which are "Drivers" and "Bootable ISO".  Click next

    Click "insert" and point it to the raid driver for system.  These shoudl be on your motherboard CD and have a file called txtsetup.oem.  If your driver folder does not have a txtsetup.oem file, you need to extract the driver (perhaps using 7zip) or use the "make a floppy" utility from your RAID card manufacturer.  There is a great virtual floppy drive program that will let you do this without a real floppy drive.  I used Virtual floppy drive 2.1 as obtained from softpedia. 

    Once your drivers are done, click next and burn the CD or save the iso file for later burning.  Use this cd to boot your new WHS box and it will load, see your drives in their RAID configuration, and no more blue screens!  You do not need to press f6 because the drivers are already embedded into the setup files.

    Monday, January 26, 2009 9:42 PM