none
Unable to find drivers for network adapters when performing a restore of a laptop RRS feed

  • Question

  • Hi all, having some issues trying to perform a restore of my laptop from my WHS.  I've got a Samsung R480 laptop with a Marvell miniport NIC in it.  I downloaded and burned the latest iso of the home server restore CD, then boot off of it with no problem.  I get to the place where it finds the storage and network drivers, finds 5 storage devices with no problem, but no network adapters.  I hit "show details", and there's nothing in the network devices box.  I've got a USB thumb drive with the contents of the "Windows Home Server Drivers for Restore" on it (which are for Win 7 64 bit), so I hit "install drivers", then "scan" on the pop-up, (watch the light on the USB drive blinking away), it says drivers were found for my hardware, I hit OK, and still nothing in the network devices.  I've tried continuing on anyways, but of course that fails as well.

    I know the NIC is powered up as I get a link light on the switch (that the WHS is plugged directly into), and I've got a "minint-*" entry in my DHCP client table, so I know it's getting an IP, but I can't get the restore environment to recognize either my NIC or WLAN drivers.  Any ideas? 

    Saturday, February 26, 2011 12:43 AM

All replies

  • ...]  I've got a USB thumb drive with the contents of the "Windows Home Server Drivers for Restore" on it (which are for Win 7 64 bit) [...

    The restore is based on 32-bit software, so 64-bit drivers will not work.
    Try the 32-bit drivers for your NIC, supporting Vista or Windows 7.

    - Theo.


    No home server like Home Server
    Saturday, February 26, 2011 11:09 PM
    Moderator