locked
Assigning Rules RRS feed

  • Question

  • When I create rules for the CRM, I can assign this rules to records or leads within the user interface.  Once I assign the rule to the records the action occurs.  Is there anyway to automatically assign these rules to a record?

    Wednesday, November 14, 2007 6:03 PM

Answers

  • There is a delay before the rule executes; normally this will be up to 5 seconds, but could be longer if the CRM server is heavily loaded. Note that the user will not see the changes caused by the workflow rule immediately
    Wednesday, November 14, 2007 8:34 PM
    Moderator
  • This could be a permission issue. If a rule is applied manually it runs under the CRM context of the user who runs them, whereas an automatic rule runs under the context of the owner of the rule. If the rule owner doesn't have CRM permissions on the entity the rule applies to, or permissions on the process or process instance entities, then it the automatic rule won't work. The same applies if the rule owner account has been set to Restricted Access Mode
    Thursday, November 15, 2007 10:00 PM
    Moderator

All replies

  • Hi,

    Are you talking about Workflow Rules?

     

    Manual workflow rules are manually executed like you do. Create, Change Status and Assign workflows are exectuted automatically on the respective events.

     

    Wednesday, November 14, 2007 6:21 PM
    Moderator
  • Yes, I am talking about Workflow Rules.  When I setup a workflow rule for CREATE, it does not do it automatically.  I have to manually select it in the user interface. 

     

    Is there a delay between the time a lead is created and the time the workflow rule should execute?

     

    Wednesday, November 14, 2007 7:50 PM
  • There is a delay before the rule executes; normally this will be up to 5 seconds, but could be longer if the CRM server is heavily loaded. Note that the user will not see the changes caused by the workflow rule immediately
    Wednesday, November 14, 2007 8:34 PM
    Moderator
  • For some reason, the CRM workflows do not won't to work automatically.  If I create a rule that is a follows, is the CRM suppose to create an activity automatically:

     

    When lead is created

    Phone Call:  Call about system

     

     

     

    Is there something in the setup that I am missing?  If the manual apply rule works, shouldn't the automatic rules work?

     

     

     

    Thank you for your help this is driving me crazy.

    Wednesday, November 14, 2007 9:01 PM
  • This could be a permission issue. If a rule is applied manually it runs under the CRM context of the user who runs them, whereas an automatic rule runs under the context of the owner of the rule. If the rule owner doesn't have CRM permissions on the entity the rule applies to, or permissions on the process or process instance entities, then it the automatic rule won't work. The same applies if the rule owner account has been set to Restricted Access Mode
    Thursday, November 15, 2007 10:00 PM
    Moderator
  • The problems was that the Administrator's account was set to Restricted Access Mode.

     

     

     

    Thank you so very much.

    Wednesday, November 21, 2007 3:06 AM