locked
WHS with two routers, what is the correct configuration....? RRS feed

  • Question

  • I am using two routers, RT31P2 (Linksys VoIP w/ firmware version 1.30.07) and WRT54GS v.1 (Linksys wireless firmware version 4.7.1.1). The set up is as follows: Cable modem to VoIP Router to Wireless Router.  The VoIP router's IP is 192.168.15.1 and I have changed the wireless routers IP to be 198.168.15.2. I have disabled DHCP in the wireless router and in the Advanced Routing section of the wireless setup page, have changed the access from Gateway to Router.  I have the two routers connected to each other via LAN to LAN and have computers connected to all other available LAN ports.   At first, from the console's setting section, all tests came back as good and I was able to access WHS remotely from outside the LAN, but apparently only for a very short time.  The test now shows the Router Configurations Details as green checks for good to go.... but....in the Domain Name Details, it shows a RED X on   "Verifying Remote Access is accessible from the Internet" and I am unable to access the https://myname.livenode from outside of the LAN.
    Is there something I am missing in the configuration of my routers? 

    Friday, August 3, 2007 3:07 AM

Answers

  • Marshmaria

     

    When you are unabale to connect do you also try using the IP address to connect, could be a livenode issue

     

    Also it seems strange that your WRT54GS should have an IP address if you have DHCP disabled. It should have no IP Address. It should function as a "Switch"

     

    Your IP addresses seem to point to the VOIP Router managing DHCP but it may be because you changed the IP address on WRT54GS to 192.168.15.2 and you still have DHCP being given by the WRT54GS, since the normal range for DHC IP address on these router starts at 100. Please check this by browising to 192.168.15.2 if you connect to the WRT54GS then DHCP is still enable.

     

    I am not sure what you are usig PORTs 20-24 for, however you do not need UDP for 80 ,443,4125 for WHS.

     

    Also do I have it correct that you have port Fowaring set up  manually and UPnP is also enabled and fowarding these ports.Port triggering is also being used?

     

    It just a bit much and will cause conflicts

     

    Now for a suggested solution.

     

     I will start with a suggestion from Ken -using the VOIP Router to manage DHCP.

    So your set up would be the same as it is now -Modem>VOIP>WART54GS.

     

     

    On the WHS

    • Unconfigure Router
    • Unconfigure Domain Name
    • Turn Of Websites
    • Reset WHS to DHCP

    VOIP Router

    • Reset to Factory and verify
    • Enable UPnP

    WRT54GS

    • Disconnect from VOIP Router
    • Do a manual reset to Factory and verify
    • login to WRT54GS and disable DHCP
    • Do IP renew on the PC used to access the WRT54GS -IP address should not return a 192.168.X.X address migth look like 169.XX.XX.XX

    Connect one PC and  WHS  to VOIP Router

    • Restart WHS first
    • Restart PC

     

    VOIP Router

    Use PC to login and Configure VOIP Router to access Internet

    Phone should now work

     

     

     

    On WHS

    • Restart WebSite
    • Configure UPnP for Router
    • Configure Domaim Name

    If all works you should have all checks.

    Call a friend to verify Remote Access

    WRT54GS

    • Remove power from WRT54GS
    • Connect to VOIP Router Lan to Lan -
    • Reattached power to WRT54GS
    • Connect 1 PC to WRT54GS and restart PC.
    • check IP address should now be 192.168.15.XX
    • Check internet connectivity.

     

    Check Remote Access again

     

    Log in to VOIP Router and Check DHCP Clients

    you should have 3 Clients-if more something is not correct.

     

    When all is working reconnect your remaining PCs and you can return the "Stactic IP to WHS (use the one assigned by DHCP)

     

    Good Luck

     

     

     

     

     

     

     

    Monday, August 6, 2007 1:27 AM

All replies

  • I'm guessing that the VOIP router is connected to your incoming network connection, then the wireless router is connected to that, and your other PCs (including WHS) are attached to one or the other, butmostly the wireless router?

    If so, then in my opinion, the best configuration for WHS is probably to set your WRT54GS as an access point, rather than a router, and let the RT31P2 do the heavy lifting. Your VOIP router probably includes some QoS firmware to make sure that your phone service sounds reasonable, so you don't want to bring it inside the other router, which may not have the ability to prioritize traffic. Most likely the problems you're having with WHS are because it's got an extra internal hop to get to the Internet.

    You'll probably have to configure the VOIP router manually to forward the appropriate ports to WHS, but I think this network configuration will work for you.

    If my assumptions about your network topology are off please correct me and I'll be more than happy to take another guess. Smile
    Friday, August 3, 2007 4:24 AM
    Moderator
  • I do have the VOIP router connected to the incoming network connection.

    The WHS and 1 pc are connected dorectly to the VOIP router.  I have installed the whs connection software on the pc that is connected directly to the VOIP.  There are also 3 pcs hard wired to the wireless router.

    Linksys Support's answer for setting the WRT54GS to be an access point rather than a router included only the steps I have already taken... disable the DHCP in the wireless router, change its IP to be within the same network at this VOIP router and change it from 'gateway' to 'router' in the advanced routing setup page. Are there any other settings I need to change in the wireless router to turn that router into an access point ????????

    side note just for clarity: I have no problems at all with WHS when I am using only the VOIP router...and the voip does port forward automatically..the problem only occurs when the WRT54GS is connected as well.  Given how the topology is setup, do you still think I will need to do a manual port forard in the VOIP router ?

    And many thanks for your answers, Ken...networking is not a strong area for me.
    Friday, August 3, 2007 1:39 PM
  • Marshmaria,

    Here is a link that may provide additional insight: http://www.grc.com/nat/nats.htm

    Friday, August 3, 2007 8:50 PM
  •  Marshmarla wrote:

    I am using two routers, RT31P2 (Linksys VoIP w/ firmware version 1.30.07) and WRT54GS v.1 (Linksys wireless firmware version 4.7.1.1). The set up is as follows: Cable modem to VoIP Router to Wireless Router.  The VoIP router's IP is 192.168.15.1 and I have changed the wireless routers IP to be 198.168.15.2. I have disabled DHCP in the wireless router and in the Advanced Routing section of the wireless setup page, have changed the access from Gateway to Router.  I have the two routers connected to each other via LAN to LAN and have computers connected to all other available LAN ports.   At first, from the console's setting section, all tests came back as good and I was able to access WHS remotely from outside the LAN, but apparently only for a very short time.  The test now shows the Router Configurations Details as green checks for good to go.... but....in the Domain Name Details, it shows a RED X on   "Verifying Remote Access is accessible from the Internet" and I am unable to access the https://myname.livenode from outside of the LAN.
    Is there something I am missing in the configuration of my routers? 



    Simplest thought is to check port forwarding on BOTH boxes.  The server will only configure the first box it sees with UPnP - and the Linksys is not that good at this.

    I am now running three boxes on the LAN here
    The first is a AG041 - wired router / adsl modem - this is configured as the DHCP server
    The other two are a WRT54G and WRT54GS and I had real problems getting this stable:
    1) DHCP would stop working
    2) Links would not resolve
    3) Boxes would lock up

    I tried the classic bit at a time and updating the firmware but it was not stable.  In the end I sorted it by changing the firmware in the WAP units to DD-WRT (even though this is one way for the GS at this time).  I now have the AG041 as was and the two WAPs as APs and DCHP forwarders with the router port set as an extra LAN port <vbg> and it has taken everything I can throw at it for two weeks now with no problems.

    Points to note:

    1) This software upgrade can brick your WAP (i.e. do not blame me)
    2) The forums are a great help - read them well - follow the links (esp. for the GS)
    3) Depending on where the server is plugged in you may have to set the port forwarding on more than one device
    4) Its great to be away from the Linksys software - the new one is not a match on the Linux version.
    5) Send them some money - it may be free but its worth more than that

    Andrew

    Saturday, August 4, 2007 11:28 PM
  • Post the IP address of the PC connected to the WRT54GS.

    Sunday, August 5, 2007 1:13 PM
  • I have three computers connected to the WRT54GS..the IPs are as follows:
    192.168.15.103 (running Vista)
    192.168.15.102 (running xp)
    192.168.15.101 (running xp)

    I also have two computers connected to the VOIP router...the ips are as follows:
    192.168.15.100 (running XP)
    192.168.15.3 (running WHS)

    ---------------------------------------------------------------------------
    Here's my configuration right now:

    Setup is... Modem to VOIP router to WRT54GS
    WRTG connected via lan to lan to the VOIP
    WHS computer is connected to a lan port on the VOIP

    VOIP address...192.168.15.1
    WRTG address..192.168.15.2
    WHS computer..static set to 192.168.15.3
    (DNS settings taken from running ipconfig /all)

    In Port Forward on the VOIP router...
    opened ports are 80, 443, 4125 and 20-24
    (all opened for both TCP & UDP and all pointing to the WHS computer with address of 192.168.15.3)

    In port trigger on the VOIP router...
    443 and 4125 are open

    In UpnP Forward on the VOIP router...
    HTTP port 80 is enabled for ip address.... 3

    In the security section on the VOIP router...Filter Internet NAT Redirection is Disabled

    AND in the WRTG router....

    DHCP disabled
    gateway setting changed to Router
    In the Security tab of the WRTG...under Block WAN Requests...check mark entered on Filter Internet NAT redirection

    I was able to connect remotely from outside of the LAN after manually setting the above configuration, but only for an hour or so...now I am getting page unavailable
    Sunday, August 5, 2007 11:57 PM
  • Marshmaria

     

    When you are unabale to connect do you also try using the IP address to connect, could be a livenode issue

     

    Also it seems strange that your WRT54GS should have an IP address if you have DHCP disabled. It should have no IP Address. It should function as a "Switch"

     

    Your IP addresses seem to point to the VOIP Router managing DHCP but it may be because you changed the IP address on WRT54GS to 192.168.15.2 and you still have DHCP being given by the WRT54GS, since the normal range for DHC IP address on these router starts at 100. Please check this by browising to 192.168.15.2 if you connect to the WRT54GS then DHCP is still enable.

     

    I am not sure what you are usig PORTs 20-24 for, however you do not need UDP for 80 ,443,4125 for WHS.

     

    Also do I have it correct that you have port Fowaring set up  manually and UPnP is also enabled and fowarding these ports.Port triggering is also being used?

     

    It just a bit much and will cause conflicts

     

    Now for a suggested solution.

     

     I will start with a suggestion from Ken -using the VOIP Router to manage DHCP.

    So your set up would be the same as it is now -Modem>VOIP>WART54GS.

     

     

    On the WHS

    • Unconfigure Router
    • Unconfigure Domain Name
    • Turn Of Websites
    • Reset WHS to DHCP

    VOIP Router

    • Reset to Factory and verify
    • Enable UPnP

    WRT54GS

    • Disconnect from VOIP Router
    • Do a manual reset to Factory and verify
    • login to WRT54GS and disable DHCP
    • Do IP renew on the PC used to access the WRT54GS -IP address should not return a 192.168.X.X address migth look like 169.XX.XX.XX

    Connect one PC and  WHS  to VOIP Router

    • Restart WHS first
    • Restart PC

     

    VOIP Router

    Use PC to login and Configure VOIP Router to access Internet

    Phone should now work

     

     

     

    On WHS

    • Restart WebSite
    • Configure UPnP for Router
    • Configure Domaim Name

    If all works you should have all checks.

    Call a friend to verify Remote Access

    WRT54GS

    • Remove power from WRT54GS
    • Connect to VOIP Router Lan to Lan -
    • Reattached power to WRT54GS
    • Connect 1 PC to WRT54GS and restart PC.
    • check IP address should now be 192.168.15.XX
    • Check internet connectivity.

     

    Check Remote Access again

     

    Log in to VOIP Router and Check DHCP Clients

    you should have 3 Clients-if more something is not correct.

     

    When all is working reconnect your remaining PCs and you can return the "Stactic IP to WHS (use the one assigned by DHCP)

     

    Good Luck

     

     

     

     

     

     

     

    Monday, August 6, 2007 1:27 AM
  • Thanks Rouza (and Ken)..I will give this a go..hopefully, I will post next with favorable results.

    And by the way, you were correct about the WRT54GS no longer having an IP, I can no longer access it with a browser using the ip of 192.168.15.2. 
    So, at this point, if nothing else, at least I have figured out how to turn DHCP off. hahaha


    FOLLOW UP....I used the set up as detailed by Rouza..I've been up and running with full remote access from outside of the Lan for close to 4 days now without any issues !!!!!!!

    side note: Thanks for the help guys.

    Monday, August 6, 2007 1:53 AM