locked
No connection when router plugged into modem RRS feed

  • Question

  • I was having problems accessing the server to install the Connector Software so what I did was unplug the router from the modem. Everything installs and I can access the server, however as soon as the router is plugged back into the modem I lose connection to the server again. The rest of the network is working properly.  I can see the server from all my computers, all shared folders on the network are accessible and I have internet access.  It's a Belkin N+ router if that helps.  Any ideas?

    Thanks,
    James

    Sunday, March 1, 2009 7:44 PM

Answers

  • Please try configuring your router to issue the DNS addresses your ISP provides to it's DHCP clients, rather than the router's IP address.

    I'm not on the WHS team, I just post a lot. :)
    Saturday, March 7, 2009 2:46 PM
    Moderator

All replies

  • Hi,

    You have a miss-configured network, as mentioned in the other thread.
    Could you post the ipconfig /all  as mentioned. (you just need to do a remote desktop connection to your server to get it's info).
    It sounds provisionally, as though your server has the wrong DNS entries: these should point to whatever is providing it's IP address, usually your router in a home network, not to external DNS servers.

    Colin

    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Sunday, March 1, 2009 7:55 PM
    Moderator
  • I can't seem to figure out how to do an ipconfig/all on the server.  I can access it as long as the modem isn't plugged in so I don't beleive I need to do a Remote Desktop connection.
    Thanks again,
    James
    Monday, March 2, 2009 12:10 AM
  • But, could you do so anyways?  Unplug the modem if you need to  (to establish the RDP connection to your server.)

    You should (so that we have a frame of reference) post the output of ipconfig /all from a commnd promt, from both your server, and one client PC.
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, March 2, 2009 1:12 AM
  •  OK. I can access the server via it local ip address.  How do I get a command prompt on the server?  Sorry but today is literally the first time I'm accessing the server and learning how to navigate it.
    Thanks,
    James
    Monday, March 2, 2009 2:34 AM
  • Are you connecting to the server's Console (lauched via the WHS Connector icon on a client), or are you connecting via Remote Desktop?
    If the former, we need you to RDP into the server.
    On any PC on your network:
    Start > Run > mstsc.exe <enter>   Enter the server's IP address, and click Connect.
    The username is Administrator, and the password is your Console password.
    Once you're connected:
    Start > Run > cmd > <enter>
    Type ipconfig /all <enter>
    To copy the info out:  right-click anywhere in the command prompt > select all > hit <enter>.  Contents are now copied to your local clipboard (on the machine that you're running the RDP connection from); paste that into your reply.

    Also post the output of ipconfig / all from that client PC.


    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, March 2, 2009 2:49 AM
  • What DNS provider are you using? Are you using the DNS servers that your ISP provides, or are you using a third party DNS service?
    I'm not on the WHS team, I just post a lot. :)
    Monday, March 2, 2009 7:25 PM
    Moderator
  • I actually got it working with the help of HP Support. The problem was that there was a DNS suffix "Pinging hpserver.belkin xxx.xxx.xxx.xxx"  (I realize I didn't get to post my ipconfig results for the forum to figure it out)
    Here's what they had me do:
    Open the following file in Notepad: C:\Windows\System32\drivers\etc\hosts

    Between the lines:
    127.0.0.1 localhost
    ::1 localhost

    enter:
    192.168.2.8 HPServer


    So it looks like
    127.0.0.1 localhost
    192.168.2.8 HPServer
    ::1 localhost

    Of course subsitute your ip address and server's name.

    After I did this, the belkin suffix was removed and I'm able to connect.  Apparently this is common with Belkin routers.
    Hope this helps others.
    James
    Wednesday, March 4, 2009 12:51 AM
  • Although the file I edited works, it's seems like a patch rather than a true fix and it has to be done on all my machines.  I'd rather get rid of the belkin suffix that keeps getting added.  Below are the ping results showing the belkin suffix and the ipconfig results.
    Thanks!

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\Jamie>ping hpserver

    Pinging hpserver.Belkin [24.28.193.9] with 32 bytes of data:
    Reply from 24.28.193.9: bytes=32 time=39ms TTL=111
    Reply from 24.28.193.9: bytes=32 time=38ms TTL=111
    Reply from 24.28.193.9: bytes=32 time=40ms TTL=111
    Reply from 24.28.193.9: bytes=32 time=43ms TTL=111

    Ping statistics for 24.28.193.9:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 38ms, Maximum = 43ms, Average = 40ms

    C:\Users\Jamie>ipconfig/all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Marias-Laptop
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : Belkin

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . : Belkin
       Description . . . . . . . . . . . : Broadcom 4322AG 802.11a/b/g/draft-n Wi-Fi
     Adapter
       Physical Address. . . . . . . . . : 00-21-00-68-E4-08
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:48bc:a57e:1234:15ba:d6c3:928d:b2fa(D
    eprecated)
       Temporary IPv6 Address. . . . . . : 2002:48bc:a57e:1234:fcb6:65f2:c791:bc8(De
    precated)
       Link-local IPv6 Address . . . . . : fe80::15ba:d6c3:928d:b2fa%11(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.2.5(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Wednesday, March 04, 2009 7:10:34 PM
       Lease Expires . . . . . . . . . . : Friday, March 02, 2018 8:54:23 PM
       Default Gateway . . . . . . . . . : fe80::21c:dfff:fed4:a898%11
                                           192.168.2.1
       DHCP Server . . . . . . . . . . . : 192.168.2.1
       DHCPv6 IAID . . . . . . . . . . . : 234889472
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-8E-BB-A1-00-21-00-68-E4-08

       DNS Servers . . . . . . . . . . . : 192.168.2.1
                                           192.168.2.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : Belkin
       Description . . . . . . . . . . . : Realtek RTL8102E Family PCI-E Fast Ethern
    et NIC (NDIS 6.0)
       Physical Address. . . . . . . . . : 00-1E-EC-B8-27-7F
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 6:

       Connection-specific DNS Suffix  . : Belkin
       Description . . . . . . . . . . . : isatap.Belkin
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::5efe:192.168.2.5%13(Preferred)
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 192.168.2.1
                                           192.168.2.1
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Local Area Connection* 12:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 02-00-54-55-4E-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:3c15:3fe8:3f57:fdfa(Pref
    erred)
       Link-local IPv6 Address . . . . . : fe80::3c15:3fe8:3f57:fdfa%12(Preferred)
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    C:\Users\Jamie>

    Thursday, March 5, 2009 3:13 AM
  •  
    Ken Warren said:

    What DNS provider are you using? Are you using the DNS servers that your ISP provides, or are you using a third party DNS service?


    I'm not on the WHS team, I just post a lot. :)



    I'm using the DNS server my ISP provides.  However I did get one reply on another site that stated,
    "The best fix is to change the WAN DNS in the Belkin to a DNS service provider that does not find the name of your server and come up with the wrong IP.  This will allow the Belkin to find the WHS on your home network."
    Does this sound like a possible permanent solution rather then editing the Host file on each computer?
    Thanks!
    Jamie

    Saturday, March 7, 2009 3:20 AM
  • Please try configuring your router to issue the DNS addresses your ISP provides to it's DHCP clients, rather than the router's IP address.

    I'm not on the WHS team, I just post a lot. :)
    Saturday, March 7, 2009 2:46 PM
    Moderator