none
NNTP Bridge failing with newsreader reporting error 503 prgram fault - command not performed ... Passport Header Not Found

    Question

  • Anyone else getting this occurring?

    I've tried logging off and re-validating my account - that seemed to succeed, but the problem persists.

    FWIW, the bridge debug window shows the following:

    CheckTicket: The remote server returned an error: (500) Internal Server Error.
    X-MSNSERVER: BL3302____PAP118
    Strict-Transport-Security: max-age=31536000; includeSubDomains
    X-QosStats: {"ApiId":0,"ResultType":5,"SourcePropertyId":42,"TargetPropertyId":27}
    X-Content-Type-Options: nosniff
    X-HTTP-Live-Request-Id: API.b3e2b603-9c0f-4be7-8e06-58dd8e783f40
    X-AsmVersion: UNKNOWN; 19.32.0.0
    Content-Length: 147
    Cache-Control: private, no-cache, no-store, must-revalidate
    Content-Type: application/json; charset=UTF-8
    Date: Tue, 01 Dec 2015 22:50:57 GMT
    P3P: CP="BUS CUR CONo FIN IVDo ONL OUR PHY SAMo TELo"
    Server: Live-API/19.32.1019.4006 Microsoft-HTTPAPI/2.0


    [Client 1] DataReceived failed: Exception:
    Type System.ServiceModel.FaultException
    Source: mscorlib
    Message: Passport Header Not Found
    Stack-Trace:

    Server stack trace:
       at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at CommunityForumsNNTPServer.WebServiceDataSource.Forums.IForumsService.GetForumNewsGroupByName(String discussionGroupName)
       at CommunityForumsNNTPServer.WebServiceDataSource.Forums.ForumsServiceClient.GetForumNewsGroupByName(String discussionGroupName)
       at CommunityForumsNNTPServer.WebServiceDataSource.MicrosoftForumsServiceProvider.<>c__DisplayClass18.<GetForumNewsGroupByName>b__16()
       at CommunityForumsNNTPServer.WebServiceDataSource.MicrosoftForumsServiceProvider.RetryCall[TResult](Func`1 func, UInt32 retryCount)
       at CommunityForumsNNTPServer.WebServiceDataSource.MicrosoftForumsServiceProvider.GetForumNewsGroupByName(String discussionGroupName)
       at CommunityForumsNNTPServer.ForumDataSource.GetNewsgroup(String clientUsername, String groupName, Boolean updateFirstLastNumber)
       at CommunityForumsNNTPServer.NNTPServer.NntpCommandGroup.GetSelectedNewsgroup(String groupName, Client client)
       at CommunityForumsNNTPServer.NNTPServer.NntpCommandGroup.Parse(String parameters, Action`1 writeAction, Client client)
       at CommunityForumsNNTPServer.NNTPServer.NntpServer.DataReceived(String data, Int32 clientNumber)

    Tuesday, December 1, 2015 10:57 PM

Answers

All replies

  • Yes, I got the same thing. I was able to get the article list when I opened my newsreader, but I was checking posts in a newsgroup on a different news server first. When I tried to open a group, it was stalling forever and finally died with the error Passport not Found. Now I get the same error when trying to get the article count.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Tuesday, December 1, 2015 11:17 PM
  • It seems to work now...

    Wednesday, December 2, 2015 8:22 AM
  • >It seems to work now...

    Yep, it's OK for me too this morning.

    Wednesday, December 2, 2015 11:38 AM