ActiveX Server Now Requires Elevated Privileges RRS feed

  • Question

  • I have an ActiveX server that I wrote in VB6 (32 bit). After a recent Windows 10 Update (now at Version 10.0.15063), the ActiveX server can no longer be instantiated. In a test project (MS Excel 2013 VB), when I try to instantiate the object, it throws an error:

    [Beginning of error]

    Run-time error ‘-2147024156 (8000702e4)’:

    Automation error

    The requested operation requires elevation.

    [End of error]

    I have tried going to the .exe and setting it to “Run this program as administrator” in the “Compatibility” tab of the Properties dialog. Still the same issue. I have also gone into DCOMCNFG and have opened up all permissions there. I have opened registry permissions at HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\{myappid} as well. Is there a new setting that I need to add in the registry? I believe this behavior started after KB2693643 was installed, but not sure about it.


    Thursday, June 8, 2017 5:52 PM

All replies

  • 1) You can turn UAC off to run your solution. However,  you should keep the machine off of the internet.

    2) You can login to the machine using the super admin account, with all programs run under the account to have elevated privileges.

    You should stay off internet using the account.

    You got two options. 😎

    Thursday, June 8, 2017 7:30 PM
  • Hi wayne3200,

    Since this forum is discussing and asking questions about the Visual Basic programming language, IDE, libraries, samples, and tools (Not for VB6 questions). And your issue is more related to VB6. This link about vb6, please refer that:

    Thank you for participating in the forum activities.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact

    Friday, June 9, 2017 2:10 AM