locked
CRM 4: Organization Pending & Invalid Argument in browser RRS feed

  • Question

  • We upgraded from CRM3 to CRM4.

     

    I noticed in the Deployment Manager under Organizations, that the status is "Pending"

     

    Also, when attempting to browse to CRM using http://servername:5555/organisation

    we receive an Invalid Argument statement?

     

    The Application event log has an ASP.NET 2.0.50727.0 warning in it with the following details:

    Exception information:

    Exception type: CrmArgumentException

    Exception message: Message name 'Assign' does not exist.

     

    Thread information:

    Thread ID: 1

    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Is impersonating: False

    Stack trace: at Microsoft.Crm.ObjectModel.SdkMessageProcessingStepServiceInternal`1.GetSdkMessageId(String messageName, ExecutionContext context)

    at Microsoft.Crm.Extensibility.V3CalloutImporter.CreateLockRequest()

    at Microsoft.Crm.Extensibility.V3CalloutImporter.InternalImport()

    at Microsoft.Crm.Extensibility.V3CalloutImporter.Import()

    at Microsoft.Crm.WebServices.CrmAuthenticationSoapExtensionBase..cctor()

     

    Does anyone have suggestions for resolving this?

    Sunday, March 23, 2008 12:58 PM

Answers

All replies

  •  

    Hi.

     

    Basically the pending state is an installation internal state < users can either enable or disable an organization >, witch means that the installation did not complete successfully.

     

    You should check the installation log (C:\Documents and Settings\Application Data\Microsoft\MSCRM\Logs) and see exactly where it failed.

     

    The second error clearly indicates that the database configuration was not completed; this might also be an active directory issue, check if the sqlaccessgroup, reportinggroup and privreportinggroup were created. If so you might check if their security roles exist in the database.

     

    Check that all CRM and sql service are up and running. If so reopen the deployment manager and see if the state changed. If not, you will need to repair the installation.

     

    If the installation is successful then the organization state should be enabled.

     

    Cheers,

    Adi

    Sunday, March 23, 2008 3:34 PM
  • Hi Adi,

    Thank you for your response.  The CRM40svrsetup.log states the following at the end:
    - Microsoft Dynamics CRM Server install Completed.
    - The installation of Microsoft Dynamics CRM Server has been successfully completed.

    The SQLAccessGroup, ReportingGroup and PrivReportingGroup exists in AD and has security access to the MSCRM and CONFIG databases.

    All SQL and CRM services are running.  I have repaired the installation but the state does not change.  I have also uninstalled CRM4.0 and re-installed it - the situation stays the same.

    Looking forward to any other suggestions.
    Sunday, March 23, 2008 4:36 PM
  • Is it a multi-tenant installation? If so, can you create a new organization and set it as default?

    Did you enable Verbose Tracing? It might indicate what's wrong.

     

    Adi

     

     

     

    Sunday, March 23, 2008 5:59 PM
  • It is a multi-tenant installation.  I created a new organization, set it to default and deleted the actual organization.  Imported the actual organisation again and the status was then enabled.  I deleted the "test" organization.  I have enabled verbose tracing and here is an extract from the w3wp log file:

    Exception encountered when trying to load string from custom resources System.TypeInitializationException: The type initializer for 'Microsoft.Crm.WebServices.CrmAuthenticationSoapExtensionBase' threw an exception. ---> Microsoft.Crm.CrmArgumentException: Message name 'Assign' does not exist. ---> System.ArgumentException: Message name 'Assign' does not exist.
    Parameter name: messageName

    Sunday, March 23, 2008 6:57 PM
  • Hi.

     

    Try running the following query against the database. Are you getting any results?

    If not, you may eliminate the joined tables one by one until rows are returned.

     

    select      distinct

                smp.endpoint, smf.primaryobjecttypecode, sm.availability, sm.categoryname, sm.name as messagename, o.name as orgname,

            sm.sdkmessageid, smps.mode, smps.modename, smps.stage

    from    filteredsdkmessage as sm inner join

            filteredsdkmessagefilter as smf on smf.sdkmessageid = sm.sdkmessageid inner join

            filteredsdkmessagepair as smp on smp.sdkmessageid = sm.sdkmessageid inner join

                filteredorganization as o on o.organizationid = sm.organizationid inner join

            filteredsdkmessageprocessingstep as smps on smps.sdkmessageid = sm.sdkmessageid

    where     (sm.name = 'Assign')

     

    Hope this would shed some light…

     

    Adi

     

    Sunday, March 23, 2008 9:39 PM
  • Hi Adi,

    When I run the query against the MSCRM database, no results are returned.  I am not quite sure how to eliminate the joined tables though.  Interestingly, all the SdlMessage tables are empty.
    Monday, March 24, 2008 6:10 AM
  • Hi.

     

    Create a simple select * from filteredsdkmessage sm are you getting results?

    If you do the target the Assign message select * from filteredsdkmessage sm where sm.name = 'Assign'

     

    Now make the same query against the sdkmessage table

    select * from sdkmessage sm

    or

    select * from sdkmessage sm where name = 'Assign'

    are you getting results?

     

    If you do the something is wrong with the current user security settings.

     

    Tell me how it went and we'll take it from there…

    Adi

     

    Monday, March 24, 2008 8:23 AM
  • Hi,

    When executing the select * from filteredsdkmessage sm query against the MSCRM database, no results are returned.

    Similarly, the select * from sdkmessage sm query returns no results.

    Regards
    Monday, March 24, 2008 9:44 AM
  • I suggest opening a support case with ms.

    This certainly seems like a faulty installation.

     

    Adi

     

     

    Monday, March 24, 2008 10:24 AM
  • Thanks Adi for all of your assistance.  It was greatly appreciated.

    In the interim, we have rolled back to CRM 3.
    Monday, March 24, 2008 11:54 AM
  • Hi.

     

    Look at this thread: http://groups.google.com/group/microsoft.public.crm/browse_thread/thread/979876b37f67a872

     

    It seems that calling ms support is unavoidable.

     

    Best of luck

    Adi

     

    Monday, March 24, 2008 12:24 PM
  • Solved this issue where the MS CRM 4 (single instance) deployment manager says organisations pending.

    To change pending into Enabled i had to right click on Organisations and choose new organisations.

    Then i had to give a new temp organisation name and go through the 20mins of reinstall, then again add the orginisation name i actually wanted as the new organisation. Along the way you need to detatch the old databases org_MSCRM.

    Then finally you have a new MSCRM install to start again with.

     

    Tuesday, September 2, 2008 5:43 PM
  • Hi Stuart,
    can you please better explain which is the solution you've found ?

    we are facing a similar issue, and the organization is in pending status.


    after a crm 3.0 to 4.0 upgrade:

    First we encounter an error like the one mentioned in this article:

     

    http://support.microsoft.com/kb/927226/en-us

     

    we have performed all steps, now the upgrade seems to proceed correctly.

     

    But when I access the Distribution Manager, the organization is in status pending.

     

    When I try to access the CRM page, the error is like:

    No Microsoft Dynamics CRM user exists with the specified domain name and user ID

     

    Putting the name of the default organization, the real error is

     

    Server error in / application

    Invalid column name ‘FeatureSet’

     
    now i would lilke to try your solution, but i'm not able to understand it.

    many thanks
    massimiliano



    Tuesday, September 8, 2009 11:52 AM