locked
SyncToy 2.0 does not work when flash drive drive letter changed... RRS feed

  • Question

  • Hello,

    My problem is that my flash drive letter changed and when I went to run the sync on the folder pair I got the error related to cannot find the folder pair.

    After having read some postings they mention something regarding a BIN file which I don't see on either folder pair.  There is DAT file on each folder pair.

    C:\DATA FILES\TEST DATA   --->  F:\SYNCTOY BACKUP\TEST DATA

    The feature that SyncToy says works has never worked for me on any system I have used.  Am I doing something wrong?  I am using ECHO with no other changed options.

    thanks, David
    Tuesday, July 14, 2009 8:20 PM

All replies

  • David,

    I have same issue.  I'm guessing neither of us are "doing" anything wrong.  I suspect one of two things--either the feature simply does not work as advertised, or... there's something about our computer systems that are interfering with the feature.  But I'm running SyncToy on two machines (one XP and one VISTA) and have the same problem on both, so I don't think it's a system issue.  Nor do I think it has anything to do with the ECHO option as it will happen with the "CONTRIBUTE" option as well.

    I started with the SyncToy 2 beta version and first experienced the problem there, so was happy when I read the problem had been addressed in the official release of version 2.  I updated and am now running what I understand to be the most current official release (2.0.100.0), but still have the same problem on both machines.

    What I do as a work-around when I run into the problem, is simply to re-assign the drive letters on my computers so they once again match what SyncToy is expecting.  
    Thursday, July 16, 2009 4:37 PM
  • Hi -

    Can you give me more information on what are the exact specifications on your flash drive ( Model/make/FileSystem/Size, etc) - everything that will help us maybe try to repro the problem. We know we had a problem with external HD's at the time of the beta release but fixed that for RTM. The only other thing you want to remember is that the feature does not work for Read-Only drives that are only the source of files.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Friday, July 17, 2009 12:47 AM