locked
Remote: "Unable log you in because of an account restriction"? RRS feed

  • Question

  • Got remote working post a WHS rebuild - thanks to Olaf.

    Got three PCs on the network.

    One of them, I can connect - just like the good old days.

    But on the other two, I'm getting "Unable log you in because of an account restriction".

    Both have My Computer | Properties | Remote | Allow users to connect remotely to this compouter = True.

    When I try to log in, I'm 99.9% sure I am specifying a valid UserID/PW.

    Can anybody put a finer point on "... an account restriction"?
    Sunday, October 18, 2009 12:54 AM

All replies

  • Got remote working post a WHS rebuild - thanks to Olaf.

    Got three PCs on the network.

    One of them, I can connect - just like the good old days.

    But on the other two, I'm getting "Unable log you in because of an account restriction".

    Both have My Computer | Properties | Remote | Allow users to connect remotely to this compouter = True.

    When I try to log in, I'm 99.9% sure I am specifying a valid UserID/PW.

    Can anybody put a finer point on "... an account restriction"?

    To clarify:  Are you saying you are able to connect to the Remote Access website, but when you try to use Remote Desktop Connection to logon to a client, you get that message?  If so, what happens if you try to connect to that same client through RDC within your LAN (instead of using the website)?
    Sunday, October 18, 2009 1:09 AM
    Moderator
  •   To clarify:  Are you saying you are able to connect to the Remote Access website, but when you try to use Remote Desktop Connection to logon to a client, you get that message?  If so, what happens if you try to connect to that same client through RDC within your LAN (instead of using the website)?

    Yes.   I'm going to https:\\HuiNalu.HomeServer.com, selecting the "Computers" tab, and then double-clicking on the name of the PC in question.

    When I try to Remote Desktop to a problem PC, I get the same message - suggesting that the issue is outside of WHS.

    Checked the props of each PC's UserID and found no diff.

    Then it dawned on me that, on the problem PCs, the user's PW was Null.

    Assigned a PW, and was able to RDC.

    Went back to https:\\HuiNalu.HomeServer.com, got the "incorrect password" notification a couple of times and then, after five minutes or so, was able to connect.   I guess there's some sort of latency between setting a PW and having Remote Desktop be able to work with it.

    Bottom line: Problem Solved.

    Thanks.
    Sunday, October 18, 2009 2:22 PM

  • Yes.   I'm going to https:\\HuiNalu.HomeServer.com, selecting the "Computers" tab, and then double-clicking on the name of the PC in question.

    When I try to Remote Desktop to a problem PC, I get the same message - suggesting that the issue is outside of WHS.

    Checked the props of each PC's UserID and found no diff.

    Then it dawned on me that, on the problem PCs, the user's PW was Null.

    Assigned a PW, and was able to RDC.

    Went back to https:\\HuiNalu.HomeServer.com, got the "incorrect password" notification a couple of times and then, after five minutes or so, was able to connect.   I guess there's some sort of latency between setting a PW and having Remote Desktop be able to work with it.

    Bottom line: Problem Solved.

    Thanks.
    FYI, if you want to continue to use blank passwords through RDC, you need to change the security policy on your clients.  Open a Run box and type gpedit.msc.  Then go to Local Computer Policy > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options.  Look for Accounts: Limit local account use of blank passwords to console logon only and set it to Disabled.
    Sunday, October 18, 2009 11:37 PM
    Moderator
  • FYI, if you want to continue to use blank passwords through RDC, you need to change the security policy on your clients.  Open a Run box and type gpedit.msc.  Then go to Local Computer Policy > Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options.  Look for Accounts: Limit local account use of blank passwords to console logon only and set it to Disabled.

    I'll probably do that on my little "walking around" PC - where the convenience factor is significant.

    But now that the subject has surfaced for me, I'm thinking that once a PC is available for remote connection via WHS, blank passwords seem a Bad Idea.

    Or am I overreacting it's no big deal considering WHS's security?
    Monday, October 19, 2009 2:44 PM
  • Blank passwords are a Bad Idea period. Use a good password (the Windows Home Server most secure option is a good place to start) for everything, and use different passwords for different things.
    I'm not on the WHS team, I just post a lot. :)
    Monday, October 19, 2009 3:04 PM
    Moderator