locked
Problem with Email Router RRS feed

  • Question

  • Hello,

    We are on CRM 2013 on-premise. We are using the CRM email router to automatically create email activities for every email that arrives in a shared group mailbox. 

    Now we are changing the email addresses that are being used in the email router queues. 

    However I keep having problems changing this... I keep getting "Invalid Argument" when I try to change the email addresses. I tried to change the email address on the Queue or on the mailbox itself. I even try restarting the email router and 'Reject Email' first. No luck.

    Any ideas on how to update the email addresses used in the CRM email router queue?

    I will have a trace shortly. They take a while to show up for some reason...

    Thanks!

    -tri


    • Edited by triangular Monday, June 15, 2015 9:30 PM
    Monday, June 15, 2015 9:30 PM

All replies

  • By the way I don't see any trace error messages for this (but will keep looking for one).

    When the error message happens I downloaded the message and this is what it says:

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: attributePlatformNameDetail: 
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220989</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>attributePlatformName</Message>
      <Timestamp>2015-06-15T22:05:09.9908764Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText i:nil="true" />
    </OrganizationServiceFault>

    Monday, June 15, 2015 10:06 PM
  • Hi Tri,

    Did you have any luck with this? I have the same error when trying to change the email on a Queue.

    Thanks

    Richard

    Monday, November 23, 2015 11:46 AM
  • Hi,

    It's been a while since I fiddled with the email router but I think you change the address on the queue, approve email, start email router and then load users/queues and test it, then update and close. Does this make any sence?

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Monday, November 23, 2015 12:14 PM
  • OK thanks for the reply, it does make sense but it was sort of what i was trying to do except it was erroring at the first step of changing the email address

    However I have just found out that the corresponding e-mail address doesn't exist in Exchange so i think that they may be the cause of the error!

    (EDIT) still getting the error even though the Exchange mailbox now exists.  I'm not sure what to do.

    Thanks again

    Richard


    Monday, November 23, 2015 1:17 PM
  • Hi Rickard,

    The problem is it doesn't even allow me to change the email address on the queue...

    Hi Richard,

    No I couldn't get around this I had to create a brand new queue for this...

    Thanks,

    -tri

    Monday, November 23, 2015 2:16 PM
  • Hi,

    If you're getting the error while changing the email address on a user or queue you should get an error in the trace log, have you turned those on and had a look there?

    Regards


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Monday, November 23, 2015 4:58 PM
  • In the end i cheated and created a new Queue, it wasn't what the user wanted but too much time had been spent on it already. It would have been good to get to the bottom of it in case it happens again but never mind.

    Thanks for your replies and suggestions Rickard.

    Richard

    Tuesday, November 24, 2015 8:54 AM