none
Error 1720

    Question

  • I am trying to install activclient and I get the following error when it tries to complete. The install requires an install of windows installer 3.1 and Microsoft Visual C++ 2005 Redistribute which install correctly. Any ideas? The error is as follows;

    Event Type: Error
    Event Source: MsiInstaller
    Event Category: None
    Event ID: 11720
    Date:  6/3/2008
    Time:  11:00:03 AM
    Description:
    Product: ActivClient 6.1 x86 -- Error 1720.There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action acImmWMICleanAfterInstall script error -2147217406, :  Line 178, Column 2,

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 7b 41 43 31 39 34 38 35   {AC19485
    0008: 35 2d 46 37 41 43 2d 34   5-F7AC-4
    0010: 44 30 34 2d 42 34 43 39   D04-B4C9
    0018: 2d 30 37 42 41 34 36 46   -07BA46F
    0020: 43 42 36 39 37 7d         CB697} 

    • Moved by Figo Fei Monday, June 9, 2008 4:58 AM off topic for vs setup
    Thursday, June 5, 2008 1:15 PM

All replies

  •  I got this from ActivIdentity.  It didn't work for me, but I wanted to see if it would work for you.   I have the same problem.... 





    Cause

     

    The affected computers had WMI errors. You could install the older versions of ActivClient on computers with WMI errors, but installing

    v6.1 won't work until you fix the WMI problems on the machine. 

     

     

    Solution

     

    To fix the WMI errors :

     

    1. At the command line, type net stop winmgmt. You may get a warning that other services need to be stopped as well; type Y and continue.

    2. Open Explorer and go to the folder called %SystemRoot%\System32\WBEM\Repository.

    3. Delete that folder and everything in it.

    4. Reboot the system normally.

    5. On the next login, open a command prompt and type the following commands in this order:

    winmgmt /clearadap

    winmgmt /kill

    winmgmt /unregserver

    winmgmt /regserver

    winmgmt /resyncperf


    Wednesday, June 11, 2008 1:41 PM
  • that didn't work for me, any other ideas?
    Thursday, July 31, 2008 4:10 PM
  • This worked for me.  I have been fighting this issue, when time allowed, for weeks.  I have tried the microsoft installer cleanup utility, installed windows script 5.6, installed the latest windows installer 4.5 and cleared all kinds of temp folders, and this solution above worked for me.

    Not sure it was related, but I uninstalled Mcafee and Spybot because I was going to reapply SP3, when I found this article.  I will be reinstalling those now.
    Wednesday, May 6, 2009 2:33 PM
  • The solution above worked for me also.
    Wednesday, April 7, 2010 5:54 PM